Written by
Tim Brotherhood
and
Adam Haas

These materials are © 2010, Parametric Technology Corporation (PTC)
All rights reserved under copyright laws of the United Kingdom, United States and other countries.

Copying and use of these materials is authorized only in the schools colleges and universities of teachers who are authorized to teach Creo Elements/Pro in the classroom.
All other use is prohibited unless written permission is obtained from the copyright holder.

Proofing and comments – Ayora Berry, Mark Fischer, Adam Haas, Myron Moss.
Trialing materials -

In order to ensure these materials are of the highest quality, users are asked to report errors to the author.
Suggestions for improvements and other activities would also be very welcome.

In order to ensure these materials are of the highest quality, users are asked to report errors to the author.
Suggestions for improvements and other activities would also be very welcome.

Feedback

tbrotherhood@ptc.com

Copyright © 2010 Parametric Technology Corporation. All Rights Reserved. Copyright for PTC software products is with Parametric Technology Corporation, its subsidiary companies (collectively “PTC”), and their respective licensors. This software is provided under written license agreement, contains valuable trade secrets and proprietary information, and is protected by the copyright laws of the United States and other countries. It may not be copied or distributed in any form or medium, disclosed to third parties, or used in any manner not provided for in the software licenses agreement except with written prior approval from PTC.

UNAUTHORIZED USE OF SOFTWARE OR ITS DOCUMENTATION CAN RESULT IN CIVIL DAMAGES AND CRIMINAL PROSECUTION.

User and training guides and related documentation from PTC is subject to the copyright laws of the United States and other countries and is provided under a license agreement that restricts copying, disclosure, and use of such documentation. PTC hereby grants to the licensed software user the right to make copies in printed form of this documentation if provided on software media, but only for internal/personal use and in accordance with the license agreement under which the applicable software is licensed. Any copy made shall include the PTC copyright notice and any other proprietary notice provided by PTC. Training materials may not be copied without the express written consent of PTC. This documentation may not be disclosed, transferred, modified, or reduced to any form, including electronic media, or transmitted or made publicly available by any means without the prior written consent of PTC and no authorization is granted to make copies for such purposes. Information described herein is furnished for general information only, is subject to change without notice, and should not be construed as a warranty or commitment by PTC. PTC assumes no responsibility or liability for any errors or inaccuracies that may appear in this document.
Contents

Introduction ................................................................................................................................. 5
Understanding the Creo Elements/Pro interface ................................................................. 6
Working directories and saving your work ............................................................................. 9
  Working Directory Theory ................................................................................................. 10
  Opening Files .................................................................................................................... 10
  Saving Files ....................................................................................................................... 11
Procedure - Modeling the cube corner ................................................................................. 12
  Step 1: Set working directory and create a new part ....................................................... 13
  Step 2: Create a sketch to define the cube ..................................................................... 15
  Step 3: Extrude the corner block ...................................................................................... 20
  Step 4: Extrude first hole ................................................................................................. 22
  Step 5: Extrude second hole ............................................................................................ 26
  Step 6: Hole using a feature ............................................................................................. 30
  Step 7: Corner rounds ....................................................................................................... 33
  Step 8: Chamfer holes ....................................................................................................... 35
Procedure - Modeling the strut ............................................................................................. 37
  Step 1: Set working directory and create a new part ....................................................... 37
  Step 2: Sketch the peg diameter ....................................................................................... 39
  Step 3: Extrude peg solid ................................................................................................. 42
  Step 4: Extrude shoulder solid ......................................................................................... 44
  Step 5: Revolve an arc to thin the center of the strut ....................................................... 48
  Step 6: Round corners ...................................................................................................... 54
  Step 7: Chamfer strut ends ............................................................................................... 56
Procedure – Assembly ........................................................................................................... 58
  Step 1: Set working directory and start a new assembly ................................................ 59
  Step 2: Add the first component to the assembly ............................................................ 61
  Step 3: Add the first strut to the assembly ....................................................................... 64
Step 4: Applying color textures to parts .................................................................69
Step 5: Adding another strut ..................................................................................72

Procedure - Rendering ..........................................................................................75
Step 1: Render toolbar and apply a scene..............................................................75
Step 2: Draft render .................................................................................................78
Step 3: Adding perspective .....................................................................................79
Step 4: Render setup .................................................................................................80
Step 5: Final render ..................................................................................................81

Engineering drawing ...............................................................................................83
Step 1: Set working directory and open cube corner ............................................84
Step 2: New engineering drawing ..........................................................................85
Step 3: Changing the drawing scale ........................................................................87
Step 4: Moving views ..............................................................................................89
Step 5: Adding dimensions .....................................................................................90
Step 6: Adding annotations ......................................................................................94

Accreditation task .....................................................................................................96
Accreditation and licensing .......................................................................................96
Submitting your work ..............................................................................................97

D:\Users\tbrotherhood\Documents\Curriculum\PTC\00Teacher\2011 Primer\2011 Primer.docx
Module 1

Introduction

This primer will introduce you to the modeling, visualization and drafting tools in Creo Elements/Pro.

Creo Elements/Pro is one of the leading 3D modeling programs and used by many of the top product development companies in the world.

You will be taught how to use Creo Elements/Pro to model two components for a construction kit, a cube and a strut. You will then be show how to put these together to form an assembly.
Module 2
Understanding the Creo Elements/Pro interface

The Main Interface includes the following areas:

- Graphics Area
- Main Menu
- Toolbars
- Dashboard
- Message Window
- Dialog Boxes
- Menu Manager
- Drawing Ribbon

Main Interface Theory

There are many different areas of the Creo Elements/Pro user interface that you use when creating models. The areas that display depend upon the function being performed. Areas of the main interface include

Graphics Area — The working area of Creo Elements/Pro in which you view, create, and modify Creo Elements/Pro models such as parts, assemblies, and drawings.
• **Main Menu** — Located at the top of the interface, the main menu contains standard options such as File, Edit, and View.

  ```
  File  Edit  View  Insert  Analysis  Info  Applications  Tools  Window  Help
  ```

• **Toolbars** — Toolbars contain icons for commonly used tools and functions.

• **Message Area** — The message area provides you with prompts, feedback, and messages from Creo Elements/Pro

  ```
  • Select component to display assembly information.
  • Showing edge created by feature U (ROUND), model CORNER_CUBE.
  • Distance = 100.000
  • Showing part STRUT_100.
  ```

• **Dashboard** — Locked at the top of the user interface, the Dashboard appears when you create or edit the definition of a feature.
  
  – The Dashboard provides you with controls, inputs, status, and guidance for carrying out a task, such as creating or editing a feature. Changes are immediately visible on the screen.
  
  – Various dashboard tabs are available with additional feature options.
  
  – Dashboard icons on the left include feature controls while the Pause, Preview, Complete Feature, and Cancel Feature options are on the right.
- **Dialog Boxes** — Are content-sensitive windows that appear, displaying and prompting you for information.

- **Menu Manager** — A cascading menu that appears on the far right during the use of certain functions and modes within Creo Elements/Pro. You work from top to bottom in this menu; however, clicking “Done” is done from bottom to top. Bold menu options will be automatically selected if the middle mouse button is clicked.

- **Drawing Ribbon** — A context-sensitive menu across the top of the interface that appears when working on drawings. The drawing ribbon arranges commands into logical tasks through tabs and groups.
Working directories and saving your work

The Working Directory is the location for opening files from and saving new files to.

Setting your Working Directory:

- Creo Elements/Pro is started in a default working directory.
- A working directory is the folder you open files from and save files to.
- The working directory is set per session; it is not saved when you exit Creo Elements/Pro.

Open Files - The File Open dialog box looks to the working directory.

Save Files - Files are saved to the folder they were opened from, this is not always the working directory.
Working Directory Theory

The working directory is the designated location for opening and saving files. The default working directory is the “Start in” location defined in the Creo Elements/Pro start icon, typically the “My Documents” folder.

If you are not using PTC’s Windchill PDMLink to manage your Creo Elements/Pro data, it is best practice to organize your work by creating a folder for each project you are working on. Each time you start Creo Elements/Pro, you should set the working directory to the folder you plan to work in. In this course you will be instructed to set your working directory to the location of the module and exercise folder.

There are three methods to set your working directory, use the method you are most comfortable with:

- **From the File menu** - Click File > Set Working Directory and browse to and select the directory that is to be the new working directory. Click OK. This is the easiest and most straightforward method.

- **From the Folder Tree or Browser** - Right-click the folder that is to be the new working directory and select Set Working Directory.

- **From the File Open dialog box** - Right-click the folder that is to be the new working directory and select Set Working Directory.

You can browse directly to the working directory at any time by selecting the Working Directory common folder from the Navigator.

Opening Files

After you have set your working directory, you will see the files in that folder each time you click Open in Creo Elements/Pro.

You can use any of the following methods to open a file:

- **Click File > Open** from the main menu or Open from the main toolbar and the File Open dialog box appears. Browse to the file, select it, and either double-click it or click Open.

- **Browse to the desired folder using the Navigator (either with Common Folders or through the Folder Tree) to display its contents in the browser. Then, you can either double-click the file in the file list, or right-click the file in the file list then select Open.**

- **You can also drag the file from the file list onto the graphics area.**

The File Open dialog box is the equivalent of the Navigator and Browser combination in the main interface.
Saving Files

By default, files are saved to the folder they were opened from. If you create a new part, assembly, or drawing, it will be saved to your current working directory.

You can use any of the following methods to save a file:

- Click **File > Save** from the main menu then hit **Enter**.
- Click **Save** from the main toolbar.

What have you learned?

- Creo Elements/Pro screen interface
- Dashboard, dialogs and ribbon
- Working directories and file management
Procedure - Modeling the cube corner

Scenario

This section will teach you how to model a cube shaped corner block for the construction kit.

You will start by creating a new part, add a square sketch, and use this to extrude the cube shape. Extruded circles will create two of the holes and a hole feature will be used for the third hole.

Rounds on the outer corners and chamfers on the holes will complete the model.
Step 1: Set working directory and create a new part

1. If necessary, start Creo Elements/Pro:

2. Setting the working directory:
   - In the main toolbar across the top of the screen, click **File > Set Working Directory**.
   - In the Select Working Directory dialog, browse to the folder where you want to store your construction kit components. We suggest creating a new folder (right click > **New Folder**) for each project.
   - Double-click to open the folder where you want to save models.
   - Click **OK** to set the folder as your working directory.

   ![Image](image1.png)

   The corner cube part you create will be created in, saved to, and opened from this “working directory”.

3. Create the new corner cube part model:
   - Click **New** from the file toolbar, at the top-left of the interface.
   - In the New dialog box, notice the default object Type is **Part** and Sub-type is **Solid**, these are the correct selections for creating a solid part.
   - Type **Corner_cube** in the **Name** field and click **OK**.

   ![Image](image2.png)

   You cannot have spaces in filenames so use spaces or hyphens.
4. Change the display of datums:
   • Use the datum display toolbar at the top of the interface to ensure that only the display of datum planes is enabled.

The datum planes FRONT, RIGHT and TOP represent the 3D space of your model. Think of datum planes as the framework your model will be built on.

Datum planes have a front or positive surface and back or negative surface.

The frame showing the placement of each datum plane is colored brown when viewed from the front or positive side and gray when viewed from the rear of negative side.

What have you learned?
   • Set working directory and start a new part
   • Display datum features
   • Datum plane theory
Step 2: Create a sketch to define the cube

You will begin the corner cube model by creating a 2D sketch feature containing a square. The FRONT datum plane will be the sketch plane containing a square, 30 mm across the flats. Center lines will be used to constrain the square symmetrical about the vertical and horizontal references. You will add an equal length constraint on adjacent sides of the square.

1. Start a new Sketch:
   • In the Feature toolbar on the right of the screen, click on the Sketch tool.

2. Select and orient the Sketch Plane:
   • Click to select datum plane FRONT (from the model tree or graphics area) as the sketch plane.
   • In the Sketch dialog box, ensure the selected Reference is datum plane TOP and the selected Orientation direction is Top.
   • Click Sketch to enter Sketcher.

3. Turn off the display of datum planes:
   • Use the datum display toolbar at the top of the interface to turn the display of datum planes off.

4. Create horizontal center line:
   • In the sketcher toolbar on the right of the graphics area, click the small triangle next to the Line tool and, from the fly out menu click on the centerline tool.
• Move the cursor over the dashed brown horizontal reference line. Notice the cursor snaps as you pass over the reference.

• When the cursor snaps to the horizontal reference, click X1 to locate one point on the centerline.

• Move the cursor until it snaps to another position on the horizontal reference X2 then click to finish drawing the first centerline.

5. Create vertical center line:

• Move the cursor over the dashed brown vertical reference line.

• When the cursor snaps to the vertical reference, click X1 to locate one point on the centerline.

• Move the cursor until it snaps to another position on the vertical reference X2, then click to finish drawing the second centerline.
6. Sketching the rectangle:
   • In the sketcher toolbar on the right of the graphics area, click the Rectangle tool.
   • Click at X1 to snap the first corner of the square.
   • Move the mouse cursor diagonally down and to the right. As you move the cursor, a rubber band rectangle will stretch as the cursor moves.
   When the cursor approaches X2 the rectangle will snap to be symmetrical about one of the center lines.
   • You should see a pair of red arrows to show this symmetry. Allow this snap to remain and move the cursor to snap symmetrical across the other center line.
   • When the rectangle is snapped in both directions, click at X2 to complete the rectangle.

7. Adding an “equal length” geometric constraint:
   • In the Sketcher toolbar on the right of the screen click on the One by one

Sketches are controlled by two types of parametric constraint.

Dimensions allow you to alter sizes.

Geometric constraints including; equal length, parallelism, perpendicular, coincident, etc.

You will add an equal length geometric constraint between two adjacent lines on the rectangle to make it a square. Creo Elements/Pro is smart enough to remove one of the dimensions automatically to avoid over constraining the sketch.
select tool.

- Click X1 to select the top horizontal line in the rectangle. The line should turn red to show it is selected.
- Hold down CTRL on the keyboard and click X2 to add a vertical line to the selection. This line will also turn red.
- With both lines selected, click the right mouse button and, from the floating menu, select Equal.

A pair of L1 constraints will appear next to the two lines that were selected.

There should be just one dimension on the sketch. This is called a “weak” dimension and colored gray. Sketch dimensions are “parametric” meaning when you change them the geometry will change to match the new value. You will change the dimension to 30mm and lock it.

8. Change the remaining dimension to 30mm:

- Move the cursor over the dimension number X1 and double left click.
- Type the new value of 30mm then press Enter on the keyboard.
- The dimension length will change and the square will resize.

The dimension text will change color to pale orange to show it is now a strong dimension.

You will now lock the dimension to prevent it changing accidentally.
• Click to select the dimension.
• Right mouse click and, from the floating menu, select Lock.
The dimension color will change to a darker orange to show it is locked.
• In the Sketcher toolbar on the right of the screen, click the blue check mark to exit sketcher.
The new Sketch feature is added to the bottom of the model tree.
• In the main toolbar, click on to save your model.
• In the Save Object dialog, click OK.

What have you learned?
• Creating a new sketch
• References
• Creating sketch geometry - center lines, rectangles
• Geometric constraints – symmetry, equal length
• Dimension constraints
Step 3: Extrude the corner block

You will use the sketch to define the section for an extrude. The extrude will be 30mm long and equal distance on both sides of the sketch. Keeping the datum planes in the center of the cube helps locate the holes later in this exercise. Extrude is a sketch based feature.

1. Change the view to Default:
   - On the keyboard, hold down the **CTRL** key and press **D**. The view of the square will rotate until it appears to be leaning over.
   - The sketch should be colored red to show it is selected. If not, click on a line in the sketch to select it.

2. Extrude the cube:
   - In the Feature toolbar on the right of the screen, click on the **Extrude** tool.

Creo Elements/Pro will try to extrude the selected square and preview this on the model.

When you started the Extrude, a dashboard opened across the top of the graphics window where you will change the parameters for the extrude.

3. Making changes to in the graphics window:
   - Click on the yellow arrow in the extrude preview to see what happens.
   - Click and drag the small white squares in the preview to see what they do.
• Open the depth drop down menu X1 and select the **both sides** option.

• Click in the depth field X2, type **30** and hit **Enter** on the keyboard.

• In the dashboard, click on ✓ to apply the extrude and save it to the model tree.

If the dashboard mysteriously closes before intended, you probably middle mouse clicked. Engineers use many shortcuts to speed up their work and middle click is the shortcut to close the dashboard!

• If your dashboard closed, to re-open it move the cursor over the **Extrude** entry in the model tree, right click and, from the floating menu, select **Edit Definition**.

**What have you learned?**

- Viewing the model – default, spin.
- Datum plane - visibility.
- Sketch based feature – Extrude, symmetrical.
- Dashboard interface.
- Edit Definition to re-open and change existing features.
Step 4: Extrude first hole

You will create a new sketch on the front face of the cube with an 8mm diameter circle centered in the middle of the block. The sketch will be used to create an extrude, removing material all the way through the block.

1. Display of datum planes:
   - Change to the Default model view by holding down the CTRL key and pressing D on the keyboard.
   - Use the datum display toolbar at the top of the screen to turn the display of datum planes on.

2. Start a new sketch:
   - In the Feature toolbar on the right of the screen, click on the Sketch tool.

3. Select and orient the Sketch Plane:
   - Click to select X1 the front face of the cube as the sketch plane.
   - In the Sketch dialog box, ensure the selected Reference is datum plane TOP and the selected Orientation direction is Top.
   - In the dialog, click Sketch to enter Sketcher.

   The model will rotate until the sketch plane is parallel with the computer screen.

4. Drawing a circle:
   - In the sketcher toolbar on the right of the screen, click on the Circle tool.
   - Move the cursor until it snaps to the point where both reference license cross and click X1 to locate the centre of the circle at this point.
   - Move the cursor away from the center and click X2 to complete the circle.
• In the Sketcher toolbar, click on the **One by one** tool.

5. Lock the diameter dimension:
   • Click to select the dimension.
   • Right mouse click and, from the floating menu, select **Lock**.
   • Double click on the weak diameter dimension X1, then type in 8 and hit **Enter** on the keyboard.

The circle will resize and the dimension color will change to a darker orange to show it is locked.

   • In the Sketcher toolbar on the right of the screen, click **✓** the blue check mark to exit sketcher.

6. Change the view to Default:
   • On the keyboard, hold down the **CTRL** key and press D. The view of the cube will rotate.

The sketch should be colored red to show it is selected.

   • If not, click on a line in the sketch to select it.
7. Extrude the circle to form a hole:
   • In the Feature toolbar on the right of the screen, click on \( \text{Extrude} \) tool.

Creo Elements/Pro will try to extrude the selected circle sketch and preview the extrusion.
   • Reverse the direction of the extrude by clicking on the yellow arrow that points along the axis of the hole.
   • In the extrude dashboard, open the depth drop down menu and select \( \text{intersect with all surfaces} \).
   • Click on \( \text{Remove material} \) button.
   • In the dashboard click on \( \text{preview} \) to preview the extrusion.
   • Use middle mouse + drag to rotate the model checking to see if the hole goes all the way through the cube.
   • In the dashboard, click on \( \text{apply and save} \) to apply and save the extrude to the model tree.

8. Save your model:
   • Open the File menu, click on Save.
   • In the dialog click OK.
What have you learned?

- Viewing the model – Default.
- Display of datums.
- New sketch on surface.
- Sketcher geometry – Circle, dimension, lock dimension.
- Extrude – removing material, changing direction, intersect will all surfaces.
- Saving the model
Step 5: Extrude second hole

You will use the same technique to extrude another 8mm diameter hole, this time from the side of the cube.

- Change to the Default model view by holding down the CTRL key and pressing D on the keyboard.

1. Display of datum planes:
   - Use the datum display toolbar at the top of the screen to turn the display of datum planes on.

2. Start a new sketch:
   - In the Feature toolbar on the right of the screen, click on the Sketch tool
   - Click to select X1, the side face of the cube, as the sketch plane.

3. Changing the sketch references and orientation:
   - In the Sketch dialog box, click in the References field.
   - In the model tree, click to select the FRONT datum plane.
   - In the Sketch dialog, open the Orientation drop down menu and select Left.
   - Click on Sketch to close the dialog and begin sketching.

The model will rotate until the sketch plane is parallel with the computer screen.
4. Drawing a circle:
   - In the sketcher toolbar on the right of the screen, click on \( \text{Circle} \) the \textbf{Circle} tool.
   - Move the cursor until it snaps to the point where both reference lines cross and click \( X_1 \) to locate the centre of the circle.
   - Move the cursor away from the center and click \( X_2 \) to complete the circle.

   - In the Sketcher toolbar, click on \( \Rightarrow \) the \textbf{One by one} tool.

5. Set the diameter of the circle:
   - Double click on the weak diameter dimension \( X_1 \), then type in 8 and hit \textbf{Enter} on the keyboard.

   The circle will resize

6. Lock the diameter dimension:
   - Click to select the dimension.
   - Right mouse click and, from the floating menu, select \textbf{Lock}.

   The circle will resize and the dimension color will change to a darker orange to show it is locked.

   - In the Sketcher toolbar on the right of the screen, click \( \checkmark \) the blue check mark to exit sketcher.
7. Change the view to Default:
   • On the keyboard, hold down the **CTRL** key and press **D**. The view of the cube will rotate.

   The sketch should be colored red to show it is selected.
   • If not, click on the **Sketch 3** entry in the model tree to select it.

8. Extrude the circle to form a hole:
   • In the Feature toolbar on the right of the screen, click on the **Extrude** tool.

   Creo Elements/Pro will extrude the selected sketch and preview the extrusion on the model.
   • Reverse the direction of the extrude by clicking at **X1** on the yellow arrow that points along the axis of the hole.
• In the extrude dashboard, open the depth drop down menu and select intersect with all surfaces.

• Click on the Remove material button.

• In the dashboard click on to preview the extrusion.

• Spin the model to check the hole goes all the way through the cube.

• In the dashboard, click on to apply and save the extrude feature to the model tree.

9. Save your model:
• Open the File menu, click on Save.
• In the dialog click OK.

Accepting default names for features is fine for simple models like this. Complex models can have hundreds of features making it difficult to find a particular entry in the model tree to make edits. It is good practice to give key features recognizable names. Features can be renamed when they are created or by clicking twice on the text in the model tree, making sure to pause between clicks.

What have you learned?
• Viewing the model – Default.
• Renaming feature names.
• Specifying references in sketch dialog.
• Sketcher – Circle, dimension, lock dimension.
• Extrude – remove material, changing direction, intersect will all surfaces.
• Saving the model.
Step 6: Hole using a feature

Creo Elements/Pro has a dedicated “Hole” tool. Holes are direct features meaning they don’t rely on sketches. The placement of holes can be done in many different ways. This hole will be located on a surface of the cube and with zero dimensions from the two perpendicular datum planes.

- Change to the Default model view by holding down the CTRL key and pressing D on the keyboard.

1. Display of datum planes:
   - Use the datum display toolbar at the top of the screen to turn the display of datum planes on.

2. Start the hole tool:
   - In the feature toolbar on the right of the screen click on the Hole tool.
   - In the graphics window click on the top surface of the cube.
   - The hole preview appears on the model and the Hole dashboard opens across the top of the graphics window.

You will now locate two placement handles which fix where on the surface the hole axis is located.
3. Setting the placement handles:

Radiating from the centre of the hole you will see two diamond shaped green drag handles.

- Drag one of the green drag handles X1 over the FRONT datum plane until the plane pre-highlights in blue then release the left mouse button.
- Drag the other green diamond handles onto the RIGHT datum plane.

**Tip:** It is easy to snap a handle onto the wrong geometry. If this happens, drag it again into the intended location.

You should now have a dimension between each of the datum planes and the centre of the hole.

- Double click on each of these dimensions and change them to 0 (zero).

**Tip:** The hole dashboard is open across the top of the screen. You will use the dashboard to alter the depth of the hole.

4. Set the diameter and depth for the hole:

- In the hole dashboard, click in the diameter field X1, type in 8 and hit Enter on the keyboard.
- Open the depth pull-down menu X2 and select intersect with all surfaces.
This is what the model should look like when all the hole options are set correctly.

- Click on ✔ to complete the feature and add the new hole entry to the model tree.

5. Save your model:
   - Open the File menu, click on Save.
   - In the dialog click OK.

What have you learned?

- Direct feature – Hole
- Viewing the model – Default
- Hole references – surface
- Hole placement - offset from datum planes
- Hole dashboard – diameter, depth intersect with all surfaces.
- Saving the model
Step 7: Corner rounds

Round is a “Direct” feature applied to edges on a solid model. You will now add a 5mm radius round to the 12 outside edges of the cube.

1. Starting the Round tool:
   • In the feature toolbar on the right of the screen, click the Round tool. The round dashboard opens across the top of the graphics screen.

2. Setting the round radius:
   • In the dashboard change the radius X1 value to 5 mm.

3. Selecting edges on the front of the cube to round:
   • In the graphics window click to select one of the edges shown in red on the cube.
   • Holding down CTRL on the keyboard, click to add all the other edges shown in red.

4. Rotating the model:
   • Release the CTRL key on the keyboard.
   • With the cursor in the graphics window, hold down the middle mouse button and drag to spin the model until you can see the edges not currently selected.

   If you middle click without spinning the model, the dashboard will close. This is only a minor inconvenience as any of the entries in the model tree can be re-opened to edit them.

   • If you need to re-open the round dashboard, move the cursor over the Extrude entry in the model tree, right click and, from the floating menu, select Edit.
**Definition.**

5. Selecting the remaining edges:
   - Hold down **CTRL** and select the remaining edges.

6. Complete the round feature:
   - In the round dashboard, click on ☑ to close the dashboard and add the round to the model tree.

This is what the cube looks like with the rounds applied.

7. Saving your model:
   - Open the **File** menu, click on **Save**.
   - In the dialog click **OK**.

**What have you learned?**

- Direct feature – Round.
- Round dashboard - radius.
- Selecting edge references – individual, adding reference edges.
- Rotating the model.
- Editing model tree entries – Accidental closure of the dashboard
- Saving the model.
Step 8: Chamfer holes

Chamfers are “Direct” features applied to edges on a solid model. You will now add 0.5mm chamfers to the edges of the holes on the cube.

1. Starting the Chamfer tool:
   - In the feature toolbar on the right of the screen, click the Chamfer tool. The chamfer dashboard opens across the top of the graphics screen.

2. Setting the round radius:
   - In the dashboard change the chamfer width X1 to 0.5 mm.

3. Selecting the edges of holes to chamfer:
   - In the graphics window click to select one of the hole edges shown here in red on the cube.
   - Holding down CTRL on the keyboard, click to add the other two hole edges shown in red.

4. Rotating the model:
   - Release the CTRL key on the keyboard.
   - With the cursor in the graphics window, hold down the middle mouse button and drag to spin the model until you can see the hole edges not currently selected.

If you middle click without spinning the model, the dashboard will close. This is only a minor inconvenience as any of the entries in the model tree can be re-opened to edit them.
If you need to re-open the round dashboard, move the cursor over the **Extrude** entry in the model tree, right click and, from the floating menu, select **Edit Definition**.

5. Selecting the remaining edges:
   - Hold down **CTRL** and select the remaining edges.

6. Complete the round feature:
   - In the round dashboard, click on ✔ to close the dashboard and add the round to the model tree.

This is what the cube looks like with the rounds applied.

8. Saving your model:
   - Open the **File** menu, click on **Save**.
   - In the dialog click **OK**.

What have you learned?

- Direct feature – Chamfer.
- Chamfer dashboard – width (D x D).
- Selecting edge references – individual, adding reference edges.
- Rotating the model.
- Editing model tree entries – Accidental closure of the dashboard
- Saving the model.
Module 2

Procedure - Modeling the strut

Scenario

Connecting the corner cubes will be struts with pegs at each end that fit into the holes in the corner cubes. The kit is based on 100 mm pacing between cubes so the strut is named with this distance in the filename.

After creating a new part, you will sketch a small circle at the centre of the strut and extrude this on both sides of the sketch to form the pegs. A larger circle, also located in the centre of the strut, is extruded to form the shouldered section. Finally, a revolved arc cuts material from the strut to create the narrowed centre section of the strut.

Step 1: Set working directory and create a new part.

1. If necessary, start Creo Elements/Pro:
2. Setting the working directory:
   - In the main toolbar across the top of the screen, click File > Set Working Directory.
   - In the Select Working Directory dialog, browse to the folder where your corner cube was saved.
   - Double-click to open the folder where your corner cube was saved.
   - Click OK to set the folder as your working directory.

The Strut part you create will be created in, saved to, and opened from this “working directory”, the same folder your corner cube was created in.
3. Create the new strut part model:
   - Click **New** from the file toolbar, at the top-left of the interface.
   - In the New dialog box, notice the default object Type is **Part** and Sub-type is **Solid**, these are the correct selections for creating a solid part.
   - Type **Strut_100** in the **Name** field and click **OK**.

4. Change the display of datums:
   - Use the datum display toolbar at the top of the interface to ensure that only the display of datum planes is enabled.

**What have you learned?**
- Setting the working directory.
- Create a new part
- Datum display – visibility
- Viewing the model – default, spin.
Step 2: Sketch the peg diameter

Begin the strut by creating a 2D sketch feature containing a circle. The FRONT datum plane will be the sketch plane containing a circle 8 mm diameter. The centre of the circle is located at the intersection of the default reference lines.

1. Start a new Sketch:
   - In the Feature toolbar on the right of the screen, click on the Sketch tool.

2. Select the Sketch Plane:
   - Click to select datum plane RIGHT (from the model tree or graphics area) as the sketch plane.
   - In the Sketch dialog box, ensure the selected Reference is datum plane TOP and the selected Orientation direction is Top.
   - Click Sketch to enter Sketcher.

The model will rotate until the sketch plane is parallel with the computer screen.

You are now in sketch mode. The sketch plane FRONT is parallel to the computer screen, oriented by datum plane TOP facing towards the top of the screen. Sketcher toolbars have replaced the feature toolbars on the right side of the interface.

3. Turn off the display of datum planes:
   - Use the datum display toolbar at the top of the interface to turn the display of datum planes off.
4. **Drawing a circle:**
   - In the sketcher toolbar on the right of the screen, click on the **Circle** tool.
   - Move the cursor until it snaps to the point where both reference license cross and click X1 to locate the centre of the circle.
   - Move the cursor away from the center and click X2 to complete the circle.
   - In the Sketcher toolbar, click on the **One by one** tool.

5. **Lock the diameter dimension:**
   - Click to select the dimension.
   - Right mouse click and, from the floating menu, select **Lock**.
   - Double click on the weak diameter dimension X1, then type in 8 and hit **Enter** on the keyboard.

   The circle will resize and the dimension color will change to a darker orange to show it is locked.
   - In the Sketcher toolbar on the right of the screen, click the blue check mark to exit sketcher.

6. **Change the view to Default:**
   - On the keyboard, hold down the **CTRL** key and press **D**. The view of the cube will rotate.

   The sketch should be colored red to show it is selected.
   - If not, click on the **Sketch 1** entry in the model tree to select it.
What have you learned?

- Sketch – new sketch, datums, direction.
- Datum display – visibility.
- Viewing the model – default.
- Sketching geometry – circle, change dimensions, lock dimensions.
- Viewing the model – default, spin.
Step 3: Extrude peg solid

You will now extrude the circle equal on both sides of the sketch a total of 90 mm long. This will form the peg section of the strut.

1. Extrude the circle to form the pegs solid:
   - In the Feature toolbar on the right of the screen, click on the Extrude tool.
   - Creo Elements/Pro will try to extrude the selected circle sketch and preview the extrusion.
   - In the dashboard open the depth drop-down list X1 and select the Extrude on both sides... option.
   - In the dashboard, click in the depth field X2, type 90 press Enter on the keyboard.
   - In the dashboard, click on to apply and save the extrude to the model tree.

2. Save your model:
   - Open the File menu, click on Save.
   - In the dialog click OK.
What have you learned?

- Viewing the model – default, spin.
- Datum plane - visibility.
- Extrude - sketch based feature, to a depth, symmetrical.
- Dashboard interface.
- Saving the current model.
Step 4: Extrude shoulder solid

You will use the same technique to **extrude** by 70 mm, a 12 mm diameter circle drawn on the **RIGHT** datum plane, **equal on both sides** to form the shouldered part of the strut.

1. Display of datum planes:
   - Change to the **Default** model view by holding down the **CTRL** key and pressing D on the keyboard.
   - Use the datum display toolbar at the top of the screen to turn the display of datum planes on.

2. Start a new sketch:
   - In the Feature toolbar on the right of the screen, click on the **Sketch** tool.
   - In the graphics window, click on the **RIGHT** datum plane as the sketch plane.
   - The default settings in the Sketch dialog are fine so click on the **Sketch** button to begin sketching.

The model will rotate until the sketch plane is parallel with the computer screen.
3. **Drawing a circle:**
   - In the sketcher toolbar on the right of the screen, click on \( \text{Circle} \) tool.
   - Move the cursor until it snaps to the point where both reference lines cross and click \( X1 \) to locate the centre of the circle.
   - Move the cursor away from the center and click \( X2 \) to complete the circle.

   - In the Sketcher toolbar, click on \( \text{One by one} \) tool.

4. **Set the diameter of the circle:**
   - Double click on the weak diameter dimension \( X1 \), then type in 12 and hit \( \text{Enter} \) on the keyboard.

   The circle will resize

5. **Lock the diameter dimension:**
   - Click to select the dimension.
   - Right mouse click and, from the floating menu, select \( \text{Lock} \).

   The dimension color will change to a darker orange to show it is locked.

   - In the Sketcher toolbar on the right of the screen, click the blue check mark to exit sketcher.

6. **Change the view to Default:**
   - On the keyboard, hold down the \( \text{CTRL} \) key and press D. The view of the cube will rotate.

   The sketched circle should be colored red to show it is selected.

   - If not, click on the \( \text{Sketch 2} \) entry in the model tree to select it.
7. Extrude the circle to form the shouldered part of the strut:
   • In the Feature toolbar on the right of the screen, click on the Extrude tool.
   Creo Elements/Pro will preview the extrusion.

   ![Extrude Preview]

   • In the extrude dashboard, open the depth drop down list X1 and select the Extrude on both sides… option.
   • In the dashboard, click in the depth field X2, type 70 press Enter on the keyboard.

   ![Extrude Dashboard]

   • In the dashboard, click on to apply and save the extrude feature to the model tree.

8. Save your model:
   • Open the File menu, click on Save.
   • In the dialog click OK.
What have you learned?

- Datum plane - visibility.
- Viewing the model – default, spin.
- Sketch – new sketch, references.
- Sketch geometry – circle, diameter dimension, locking dimensions.
- Extrude - sketch based feature, to a depth, symmetrical.
- Dashboard interface.
- Saving the current model.
Step 5: Revolve an arc to thin the center of the strut

You will use a Revolve feature with an arc sketch drawn on the FRONT datum plane to remove material around the centre of the strut. This will make the strut lighter and use less material.

- Change to the Default model view by holding down the CTRL key and pressing D on the keyboard.

1. Display of datum planes:
   - Use the datum display toolbar at the top of the screen to turn the display of datum planes on.

![Datum Planes](image)

2. Start a new sketch:
   - In the Feature toolbar on the right of the screen, click on the Sketch tool.
   - In the graphics window, click on the RIGHT datum plane as the sketch plane.
   - The default settings in the Sketch dialog are fine so click on the Sketch button to begin sketching.

![Sketch Dialog](image)

3. Turn off the display of datum planes:
   - Use the datum display toolbar at the top of the interface to turn the display of datum planes off.

![Datum Planes Off](image)

The model will rotate until the sketch plane is parallel with the computer screen.
The geometry you will be creating must be snapped to the edge of the strut. To allow you to do this you will create an extra reference.

4. Adding sketch references:
   - In the main toolbar across the top of the screen click on Sketch and from the drop-down menu select References.

The references dialog opens.
   - In the graphics window click X1 to select the top edge of the strut.

A new Surface reference will be added to the References dialog.
   - Click Close.

5. Sketch a circle:
   - In the sketcher toolbar on the right of the screen, click on the Circle tool.
   - Move the cursor until it snaps to a point X1 on the vertical reference line above the strut. Click to locate the center of the circle.
   - Move the cursor away from the center and click X2 to complete the circle.

6. Trimming the circle above the reference:
• In the sketcher toolbar on the right of the screen select the **Delete Segment** tool.

• Move the cursor over the top part of the circle X1 and click to delete.

• Move the cursor over the other part of the circle X2 above the reference and click to delete.

7. Add dimension constraints to the arc:

   There are several ways to add a dimension to a sketch. Here you will left click on two entities in the sketch. Then, right click to place the dimension text.

• Zoom in on the center of the arc.

• In the sketcher toolbar on the right of the screen, click on the **Normal Create Defining Dimension** tool.

• Left click X1 on the horizontal reference line.

• Left click X2 on the arc

• Middle click at X3 to place the dimension text

• Type 4 for the dimension and press **Enter** on the keyboard.
• The dimension tool should still be active. If not, select it in the sketcher toolbar.
• Left click X1 on one end of the arc.
• Left click X2 on the other end of the arc.
• Middle click at X3 to position the dimension text.
• Type 60 for the dimension and press Enter on the keyboard.

The sketch should look like this.

8. Adding a Geometric center line:

A revolved feature needs a sketch profile and an axis. You will add a Geometric Centerline in the sketch to act as the axis of revolution.

• In the sketcher toolbar on the right of the screen click on small arrow next to the line tool.
• In the fly-out menu select the Geometry Centerline tool.
• Click in two positions, X1 and X2, snapped to the horizontal reference to draw the
geometry centerline.

- In the Skether toolbar on the right of the screen, click the blue check mark to exit sketcher.

9. Change the view to Default:
   - On the keyboard, hold down the **CTRL** key and press **D**. The view of the strut will rotate.

![Image of strut](image.png)

10. Revolve the sketch to remove materials from the strut:
    - The sketch should still be selected. If not, click on the Sketch 3 entry, in the model tree.
    - The sketch lines should be highlighted in red in the model like those above.
    - In the Feature toolbar on the right of the screen click on **Revolve**.
    - The revolve feature will preview on the model and the revolve dashboard will open across the top of the screen.

![Image of revolve feature](image.png)

- Click at **X1** to create a **Solid** revolve.
- Click at **X2** to **Remove** material from the model.
- Click at **X3**, the glasses button **️**, to preview the feature on the model.
• Click ✓ to complete the feature and add the revolve to the model tree.

11. Save your model:

• Open the File menu, click on Save.
• In the dialog click OK.

What have you learned?

• Datum plane - visibility.
• Viewing the model – default, spin.
• Sketch – new sketch, adding new references.
• Sketch geometry – circle, geometry centre lines, trimming lines.
• Sketch dimensions – editing, adding new, locking,
• Revolve - sketch based feature, requires a profile and a center line.
• Revolve dashboard – create solid, remove material, preview.
• Saving the current model.
Step 6: Round corners

Remember, Round is a “Direct” feature applied to edges on a solid model. You will now add a 0.5 mm radius to the shoulders of the strut.

1. Starting the Round tool:
   • In the feature toolbar on the right of the screen, click the Round tool. The round dashboard opens across the top of the graphics screen.

2. Setting the round radius:
   • In the dashboard change the radius X1 value to 0.5 mm then press Enter on the keyboard.

3. Selecting edges on the strut to round:
   • In the graphics window click to select one of the edges shown in red.
   • Holding down CTRL on the keyboard, click to add the other edge shown in red.
   • In the dashboard click on ✓ to complete the feature and add the round to the model tree.

4. Save your model:
   • Open the File menu, click on Save.
   • In the dialog click OK.
What have you learned?

- Direct feature – Round.
- Round dashboard - radius.
- Selecting edge references – individual, adding reference edges.
- Saving the model.
Step 7: Chamfer strut ends

Like rounds, chamfers are also “Direct” features and applied to edges on a solid model. You will add 0.5mm chamfers to the both ends of the strut to make it easier to insert the strut ends into the cubes

1. Starting the Chamfer tool:
   - In the feature toolbar on the right of the screen, click the Chamfer tool. The chamfer dashboard opens across the top of the graphics screen.

2. Setting the round radius:
   - In the dashboard change the chamfer width X1 to 0.5 mm then press Enter on the keyboard.

3. Selecting edges on strut to chamfer:
   - In the graphics window, click to select one of the edges shown here in red.
   - Holding down CTRL on the keyboard, click to add the other edge shown in red.
   - In the dashboard click on to complete the feature and add the round to the model tree.

4. Save your model:
   - Open the File menu, click on Save.
   - In the dialog click OK.
What have you learned?

- Direct feature – Chamfer.
- Chamfer dashboard – width (D x D).
- Selecting edge references – individual, adding reference edges.
- Saving the model.
Module 3
Procedure – Assembly

Scenario
This section will teach you how to assemble the components.

You will start by creating an assembly part then add a cube constrained to the x,y,z coordinates. Struts are added to any available holes in the cube. Once you have struts in place additional cubes can be added to the assembly.
Step 1: Set working directory and start a new assembly

1. If necessary, start Creo Elements/Pro:

2. Setting the working directory:
   - In the main toolbar across the top of the screen, click **File > Set Working Directory**.
   - In the Select Working Directory dialog, browse to the folder where your corner cube and strut were saved.
   - Double-click to open the folder where your corner cube was saved.
   - Click **OK** to set the folder as your working directory.

   The assembly file you create will be created in, saved to, and opened from this “working directory”, the same folder where your cube and strut are stored.

3. Create the new assembly file:
   - Click **New** from the file toolbar, at the top-left of the interface.
   - In the New dialog box, change the file **Type** to **Assembly**.
   - Type **Kit_assembly** in the **Name** field and click **OK**.

   Spaces are not valid characters in Creo Elements/Pro filenames. Use underscore or hyphens instead.
5. Change the display of datums:
   • Use the datum display toolbar at the top of the interface to ensure that only the display of coordinate systems is enabled.

What have you learned?
   • Set working directory – existing folder.
   • Create new assembly
   • Datums – visibility.
Step 2: Add the first component to the assembly

The first component you will add is a corner cube which should be fixed in position as a stable reference for the other components you will add.

1. Selecting the component to add:
   - In the Feature toolbar on the right of the screen, click on to add a component to the assembly.
   - In the Open dialog, from the list on the left, click on Working Directory.
   - From the list of models, click on Corner_cube.prt.

   The file you have selected will preview in the Open dialog.
   - Click to add the part to the assembly.

   The part will be ‘attached’ to the cursor and the assembly dashboard opens across the top of the screen.

2. Temporarily locate the part ready for placement:
   - Move the corner cube near to the ASM coordinate system and click to temporarily locate it ready for placement.
3. Add constraints:
   - In the assembly dashboard, open the **Automatic** constraint list and select **Default**.
   - The corner cube will move until the x,y,z coordinates of the corner cube and the assembly are coincident. The cube will change color to yellow signifying it is **Fully Constrained** in the assembly.

The Assembly dashboard records the **Default** location for the cube and confirms the part is **Fully constrained**.

4. Finish constraining the part:
   - Click on **✓** to close the assembly dashboard and add the component to the model tree.
   - The corner cube returns to its original gray color.

**What have you learned?**
- Adding a component to an assembly – temporary placement.
- Assembly dashboard – status, fully constrained.
- Assembly constraints – Automatic, insert, mate, assumptions.
- Datums – visibility.
Step 3: Add the first strut to the assembly

You will add the first strut to the assembly by aligning the peg with a hole then mating the face of the shoulder with the face of the cube. This replicates exactly how you would assemble a peg with real components.

1. Turn off the display of datum planes:
   - Use the datum display toolbar at the top of the interface to turn the display of datum planes off.

2. Selecting the strut to add:
   - In the Feature toolbar on the right of the screen, click on to add a component to the assembly.
   - In the Open dialog, from the list on the left, click on Working Directory.
   - From the list of models, click on Strut_100.prt.

The file you have selected will preview in the Open dialog.
   - Click to add the part to the assembly.

The part will be ‘attached’ to the cursor and the Assembly dashboard opens across the top of the screen.

3. Temporarily locate the part ready for placement:
   - Click to place the strut temporarily in the assembly.
Creo Elements/Pro will try to guess the correct assembly constraints. To help with this process, you will orient the strut close to where you want it before adding assembly constraints.

**Component placement controls**

Allows reorientation of components during placement

<table>
<thead>
<tr>
<th>Operation</th>
<th>Keyboard – mouse selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spin – The component will spin within the assembly. Partially constrained components only spin in unconstrained directions.</td>
<td>Ctrl + Alt + Vertical arrows</td>
</tr>
<tr>
<td>Pan - The component will pan about the assembly. Partially constrained components only pan in unconstrained directions.</td>
<td>Ctrl + Alt + Horizontal arrows</td>
</tr>
<tr>
<td>Component Drag – The component will spin and pan about the assembly. Partially constrained components can only be dragged in unconstrained directions.</td>
<td>Ctrl + Alt + Vertical arrows</td>
</tr>
</tbody>
</table>

4. Position the strut close to its intended location:

   - Use the component placement controls described above to move the strut inline, and close to a hole in the cube.

If the dashboard mysteriously closes before intended, you probably middle mouse clicked. Engineers use many shortcuts to speed up their work and middle click is one that closes the dashboard!

   - If you need to re-open the assembly dashboard, move the cursor over the strut
entry in the model tree, right click and, from the floating menu, select Edit Definition.

5. Adding the first assembly constraint:

- In the graphics window, move the cursor over the peg X1 closest to a hole in the cube
- When the cylindrical surface of the peg pre-highlights light blue, click to select it. The surface will turn red.
- Move the mouse over the adjacent hole in the corner cube X2 and when the inside surface pre-highlights, click to select the surface.

Creo Elements/Pro recognizes two cylindrical surfaces and applies an Insert constraint

The strut will move to center the peg in line with the hole and an Insert label will appear on the model.

6. Adding a second assembly constraint:

- In the graphics window select X1 the flat face on the cube facing the strut.
- Hold down the middle mouse button and drag to rotate the model until you can see the flat face on the strut.
- Click to select X2 the face shown here pre-highlighted light blue.

Creo Elements/Pro recognizes two flat surfaces facing each other and applies a Mate constraint. The strut will move to make the two surfaces meet.
• On the keyboard, hold down **CTRL** and press ‘D’ to change to the Default view.

The strut has changed color to yellow signifying it is **Fully Constrained** in the assembly. A **Mate** label appears on the model.

The dashboard stores the **Mate** constraint and reports the strut is **Fully constrained**.

7. Finish constraining the part:
   • Click on **✓** to close the assembly dashboard and add the component to the model tree.

The corner cube returns to its original gray color.

Using constraints like Insert and Mate, three constraints are normally needed to fully constrain a component. In this example, the strut should still be free to rotate. However, Creo Elements/Pro made an assumption and prevented rotation.

Teachers completing this primer are accredited to use Creo Elements/Pro in school and given access to follow-on curriculum projects and learning materials which explain this and all other aspects of Creo Elements/Pro.
What have you learned?

- Datum – visibility.
- Adding a component to an assembly – temporary placement.
- Component placement – mouse/keyboard controls.
- Model tree – re-opening an entry for editing (Edit Definition).
- Assembly dashboard – status, fully constrained.
- Assembly constraints – Automatic, insert, mate, assumptions
- Saving the current model.
Step 4: Applying color textures to parts

The components look dull with the default battleship gray color. Creo Elements/Pro lets you apply colors and a wide range of textures representing almost any material. You will now apply colored textures to your components by opening them from the assembly.

Your assembly should still be open on screen.

1. Opening the corner cube part from the assembly:
   - In the model tree, move the mouse cursor over the CORNER_CUBE.PRT, right click and, from the floating menu, click Open.

The Corner cube part will open in a new Creo Elements/Pro window.

2. Applying a color to the part:
   - In the top toolbar, click on to open the Appearance Gallery.
   - Scroll the list of My Appearances X1 to find the yellow button and click X2 to select it.

The Appearances Manager will close, the mouse cursor will change to a paint brush , and the Select dialog opens in the top right corner of the screen.
• Move the paint brush cursor over the top entry in the model tree CORNER_CUBE.PRT and click to apply the color to the entire part.

• Either click OK in the Select dialog or, Middle mouse click to confirm the texture change.

The Corner cube will have the new color applied.

3. Save and close your model:
   • Open the File menu, click on Save.
   • In the dialog click OK.
   • In the File menu click on Close Window

You will return to the Assembly.

4. Applying a color texture to the strut:
   • Repeat the process to apply a dark green color to the strut.

After closing the strut, you will return to the assembly. Because Creo Elements/Pro is associative, changes to the parts are immediately seen in the assembly.

What have you learned?

• Opening a part from an assembly.
• Applying textures – Applying a default color appearance to a part.
• Saving the current model.
Step 5: Adding another strut

1. Selecting the component to add:
   - In the Feature toolbar on the right of the screen, click on 🔄 to add a component to the assembly.
   - In the Open dialog, from the list on the left, click on Working Directory.
   - From the list of models, click on Strut_100.prt.
   The file you have selected will preview in the Open dialog.
   - Click 🔄 to add the part to the assembly.
   The part will be ‘attached’ to the cursor and the Assembly dashboard opens across the top of the screen.

2. Temporarily locate the part ready for placement:
   - Click 🔄 to place the strut temporarily in the assembly.
   Notice the strut already has an insert constraint applied and the peg surface selected?

⚠️ Creo Elements/Pro knows this is the second strut in succession being assembled and is offering you the same constraints on the strut and waiting for you to select the hole it will be inserted in. You will assemble this strut into the top hole.
3. Add assembly constraints to locate the strut in the assembly:
   - Select the internal surface of the hole X1 on the top of the corner cube.
   The strut will rotate to line up with the hole.

Creo Elements/Pro is now asking you which surface to Mate.
   - Click X1 on the top flat face of the cube.
   - The strut will move until the shoulder of the strut is up against the cube corner surface.

The strut turns yellow to show it cannot move in the assembly and the dashboard reports **Fully Constrained**.

4. Finish adding the strut to the assembly:
   - Either click ✓ in the assembly dashboard or, Middle click to complete the assembly, close the dashboard and add the strut to the model tree.

The assembly has one corner cube and two struts.
Continue adding struts and corners until your assembly is complete.
What have you learned?

- Assembly - adding a component, temporary placement.
- Assembly – the same constraints are offered when adding identical components, fully constrained.
- Saving the current model.
Module 4
Procedure - Rendering

Scenario

This section will teach you how to create a photo-realistic image of your model. This process is often called rendering.

You will start by applying a “Scene” to your model which includes details of the room, lighting and any special effects. Creo Elements/Pro uses these settings and calculates the light paths to create the finished image.

Step 1: Render toolbar and apply a scene

1. If necessary, start Creo Elements/Pro:
2. Setting the working directory:
   • In the main toolbar across the top of the screen, click File > Set Working Directory.
   • In the Select Working Directory dialog, browse to the folder where your construction kit models were saved.
   • Double-click to open the folder.
   • Click OK to set the folder as your working directory.

The assembly will be opened from the “working directory” and any changes you make plus additional files will be saved to the same directory.

3. Open your assembly:
   • Open the File menu and select Open.
   • Navigate to the Working Directory, select your assembly, then click Open.
Creo Elements/Pro stores a number of views of the model. A pictorial view is needed for this render so you will change the view to Isometric or Trimetric.

4. Changing the model view:
   - In the main toolbar across the top of the screen, click on to open the list of Saved views.
   - Click on Isometric or Trimetric view.

If your version of Creo Elements/Pro doesn’t have Isometric or Trimetric views, zoom and spin your model into the postion you require.

5. Opening the Render toolbar:
   - You will apply one of the default scenes to your model then snap the floor to the bottom of your assembly.
   - Move your mouse into a blank area of the top toolbar, right mouse click and, from the floating menu, click Render.

The render buttons will be added to the top toolbar.
6. Applying a scene:
   
   • In the render toolbar, click on to open the Scene dialog.
   
   • Scroll through the list of scenes then double click on one to apply it to your model.
   
   • Check/tick the Save a scene with model option.
   
   • In the Scenes dialog click on the Room tab.
   
   • In the Room Orientation section, click on the button next to the floor spin wheel. This snaps the floor to the bottom of your assembly.
   
   • Click Close to finish making change to the Scene settings.

What have you learned?

   • Starting Creo Elements/Pro
   • Setting working directory – existing folder.
   • Opening an existing model.
   • Viewing the model – pictorial views, trimetric/isometric.
   • Render toolbar.
   • Scenes – applying to model, floor position,
Step 2: Draft render

Draft render will let you see whether the changes you made to the Scene settings are giving you the desired effect. Draft render doesn’t take long and gives you the opportunity to go back and quickly try out other scenes and settings.

1. Draft render:
   • In the Render toolbar, click on [Draft render] to carry out a Draft render.
   • There will be a short wait with progress reported in the Render Abort dialog.

When the draft render finishes the graphics window will display a grainy image representing the effects you have applied.

   • If you are not happy with the way your model looks, try applying a different scene.
   • Once you are happy with the draft render you can continue to refine the quality of the render.

Each time you change the scene you also need to snap the floor to the model before trying the render.

What have you learned?

   • Draft render.
   • Scenes – Applying a new scene, positioning the floor.
Step 3: Adding perspective

Perspective adds realism to the render by reducing the apparent size of objects as they get further away. An understanding of photography can help achieve the results you want.

1. Apply perspective:
   - In the render toolbar, click on the Perspective Settings button. The Perspective dialog opens.
   - Use the Eye distance slider combined with zooming the graphics window until you see the amount of perspective you want.
   - Click OK to close the Perspective dialog.

What have you learned?
- Perspective – applying to the model, adjusting.
- Scenes – Applying a new scene, positioning the floor.
Step 4: Render setup

Render setup contains many options including the quality of the image. You will increase the quality from the default Draft setting to Maximum.

- In the render toolbar, click on 📊 to open the Render Setup dialog.
- Change the Quality setting to Maximum.
- Look at the options under each of the tabs to see the wide range of settings Creo Elements/Pro provides.
- Leave the other settings and click Close.

What have you learned?
- Render quality settings
- Brief overview of available render settings.
Step 5: Final render

- Make sure your model is in the right position.
- In the Render toolbar, click on 🗞️ to carry out the final render.

The render may take some time especially on slower computers. Creo Elements/Pro is doing a great deal of mathematical calculation to work out light paths, shadows and multiple reflections.

During the render process you will see the resolution improve a section at a time.

The final render should look quite realistic even with the default settings.

The level of realism is only limited by the users understanding of space, form, light, texture, and how to adjust the settings in Creo Elements/Pro.

In the example below, additional objects have been added to create a context for the gearbox adding greatly to the realism of the scene.
What have you learned?

- Final render.
- Setting the context for render.
Module 5
Engineering drawing

Scenario

The final section of this introductory tutorial teaches you how to create an engineering drawing from a Creo Elements/Pro model.

This process is largely automated and, because models and drawings are “associative”, changes to the model are immediately reflected in the drawing.
Step 1: Set working directory and open cube corner

1. If necessary, start Creo Elements/Pro:
2. Set the working directory:
   - In the main toolbar across the top of the screen, click File > Set Working Directory.
   - In the Select Working Directory dialog, browse to the folder where you're the parts and assembly you created earlier are stored.
   - Double-click to open the folder.
   - Click OK to set the folder as your working directory.

3. Opening the cube corner part:
   - In the Main menu open the File menu and click on Open.
   - If necessary click on Working Directory in the left panel of the Open File Dialog.
   - Select your Cube_corner.prt model and click Open.

What have you learned?
- Starring Creo Elements/Pro.
- Setting the working directory.
- Opening an existing component.
Step 2: New engineering drawing

Templates in Creo Elements/Pro will take a part that is open on screen and construct an engineering drawing. The A3/B size templates automatically create a border, title block, three orthographic views and a pictorial representation! Dimensions are easily imported from the 3D model and annotations can be added.

1. Start a new drawing:
   - In the main toolbar open the File menu and click New.
   - In the New dialog, click Drawing for the Type and type in Corner_cube for the Name.
   - The Default template option should remain selected.
   - Click on OK and New Drawing dialog opens.
   - Leave Use template selected.
   - Select the paper size you require, here we have chosen a3_drawing.
   - Click OK to create the drawing.

Depending which template you select, you will see slightly different arrangements of views.

For example the a4_drawing template has only two orthographic views.
The template has saved a great deal of work creating borders, title blocks and the different views. You may want to change the scale of the drawing and add dimensions and annotations.

**What have you learned?**

- Opening an existing component.
- Starting a new drawing - paper size, template.
- Automation – borders, title blocks, views.
Step 3: Changing the drawing scale

Automatic creation of the drawing will have chosen a scale to match the size of the model to the paper size. The scale is displayed below the drawing.

1. Changing the drawing scale:
   
   • Locate the scale display at the bottom left corner of the drawing screen and double click to open the scale dialog.

   ![Scale Dialog]

   • Type a new scale then click on to ✓ to apply the new scale to the drawing.

   ![Scaled Drawing]

You should always choose a scale that would be listed in a national or international standard. If Creo Elements/Pro does not change the scale, try a different value.
What have you learned?

- Drawing scale – changing the scale.
Step 4: Moving views

By default, views are locked in position and will need to be unlocked before they can be moved.

1. Unlock a view:

   • Make sure the Layout tab is selected in the Drawing ribbon toolbar.
   • In the model click on a view to select it. The view border will turn red to show it is selected.
   • Right click on the selected view in the lower left corner of the drawing and, from the floating menu, click Lock view movement to toggle the lock off.
   • The view should still be selected so move the mouse over the view and click and drag the view to a new location.

   If you are dragging the front view, you should see the other “projected” views move as you drag.

   • When you have finished moving the views you can lock them again.

What have you learned?

   • Drawing views – unlocking, moving, locking.
Step 5: Adding dimensions

There are two ways to add dimensions to a drawing.
You can “show” the dimensions used to create features in the 3D model. These have the advantage of being able to change the 3D model if they are altered in the drawing.

“Added” or “driven” dimensions can be inserted into a drawing. These report the size of the model and will update if the model changes but this type of drawing dimension cannot be used to control the 3D model.

1. Showing dimensions:
   - In the drawing ribbon across the top of the graphics window, make sure the **Annotations** tab is selected.
   - In the graphics window, select the view you want to add dimensions to. The border of the sketch will turn red showing it is selected.
   - In the Annotation ribbon, click on **Show Model Annotations**.
The Show Model Annotations dialog will open listing all the dimensions that were used to create the 3D model of the corner cube. These can be checked/ticked individually to make them appear on the drawing in the select view. Near the bottom of the dialog is a button to add all the dimensions.

- Click to show all dimensions on the selected view.

The dimensions will appear on the selected view but may not be placed properly.

2. Moving dimensions:
   - Click away from the model views to cancel any selections.
   - Click to select the text for one of the dimensions. The text will turn red to show it is selected.
   - Click on the selected text and drag it to a new location.

Here the 30mm linear dimension has been moved between the limit lines.

3. Deleting dimensions:

Just above the cube is a 0 (zero) dimension that is not required on the drawing.

- Click to select the dimension then press Del on the keyboard.

The dimension is removed from the drawing but will remain in the 3D model.

4. Moving dimensions to a different view:
Some of the dimensions would be better displayed on another view.

- Click to select the hole diameter under front view.
- Right click on the selected text and from the floating menu, click Move item to View.
- Click to select the plan view above to complete the move.

- Move the diameter into a suitable position.

The drawing below has had all the dimensions rearranged.
What have you learned?

- Drawing dimensions – overview, showing, adding.
- Showing dimensions on a drawing view.
- Moving dimensions to another view.
- Dimensions – Repositioning text, deleting.
Step 6: Adding annotations

Annotations will complete this basic drawing. You will add your school name to the title block.

1. Adding annotation text:
   - In the Drawing ribbon the Annotate tab should be active.
   - Click on \( \text{Annotate} \) to begin adding a Note.

Menu Manager opens listing the default options: No Leader, Horizontal, Standard and Default (alignment). These defaults are fine for our title text.
   - At the bottom of the Menu Manager, click on Make Note.
   - Click X1 in the middle of the empty cell at the top of the title block.
   - In the Note text entry dialog, type the name of your school. If you want a second line of text click \( \checkmark \) or press Enter on the keyboard.
   - Click \( \checkmark \) twice or press Enter on the keyboard twice place the text.
   - Click on Done/Return to close the Menu Manager.
   - Select the new text and move it into position.

2. Edit annotation text:
• Click to select the text. A red rectangle surrounds the text to show it is selected.

• Right click on the text and, from the floating menu, click Properties.
• In the Properties dialog edit the text.
• Click on the Text Style tab to see other parameters you can change.
• Click OK close the dialog.

What have you learned?
• Adding annotations - note.
• Note text – positioning, adding text, moving, editing, formatting.
Module 6

Accreditation task

The only thing left to do to get your school license of Creo Elements/Pro is to use the skills you have learned to model a new component for the kit.

Here are some suggestions but we really want your ideas!

Modified components

New components

Accreditation and licensing

Teachers who complete this accredited course, submit their models and have them approved are issued with a school site license for Creo Elements/Pro and access to our comprehensive curriculum and training materials.

Using Creo Elements/Pro, we ask you to design and model a new component for the kit using the techniques you have learned. Create an assembly using your component and
Submitting your work

You will need to have an email client setup up to use this method of emailing us your work. Alternatively zip the folder containing all your models and email the zip file along with the details below.

- Open your assembly containing the new component you have designed.
- In the Main toolbar click File.
- Click Send to then click Mail Recipient (as an attachment).
- Check/tick the Create a zip… option.

- A new email will be created.
- Complete the information shown on the right.
- Send the email.

Email: schools@ptc.com
Message header: Creo Elements/Pro - Teacher accreditation
Teacher name:
School Name:
School Address:
Trainer name/Online: