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Software License Agreement
The Easy Grade Pro™ software program is licensed by 
ORBIS Software™, Inc. for use only on the terms and 
conditions that follow. Refer to the License/Registration 
Card for the specific license type. Use of the Easy Grade 
Pro™ software indicates that you accept all terms.
• To use Easy Grade Pro™, you must have a valid 

single-user license or your employer must have a valid 
site license. Under no condition does a site license 
apply to more than one school or college-level 
department. 

• For Single-user License: You may use Easy Grade 
Pro™ on any computer in which you are the primary 
user. Your name and registration number must appear 
in the Easy Grade Pro™ title screen. If you transfer the 
software license you may not retain a copy and the 
new owner must agree to the terms of this agreement.

• For Site License: You may use Easy Grade Pro™ on 
any computer owned by the employer and on any 
computer in which you are the primary user. Your 
employer’s name or site name and registration 
number must appear in the Easy Grade Pro™ title 
screen. The software license may not be transferred 
without permission from Orbis Software™, Inc.

• Windows/Macintosh Platforms: You may use Easy 
Grade Pro™ only on the platform(s) specified on the 
license card. 

• You may use Easy Grade Pro™ only for its intended 
purpose. You may not modify the software, make any 
attempt to discover the source code or create 
derivative works based on the software. 

Replacement of CD-ROM
If an original CD-ROM becomes defective it will be 
replaced without charge if returned within ninety days of 
the date of purchase.

Copyright 
Copyright © 1992-2002 by ORBIS Software, Inc. All rights 
reserved. This software and manual may not be copied or 
transferred to any medium in whole or part except as 
permitted by U.S. Copyright Law or by written permission 
from ORBIS Software, Inc.

Warranty
The Easy Grade Pro program and documentation are 
sold “as is” without warranty of any kind. It is your 
responsibility to verify the results obtained from the use 
of the program. ORBIS Software reserves the right to 
make changes in the program and documentation at any 
time and without notice.

ORBIS SOFTWARE, INC. MAKES 
NO WARRANTIES, EITHER 
EXPRESSED OR IMPLIED, 
INCLUDING BUT NOT LIMITED 
TO IMPLIED WARRANTIES OF 
MERCHANTABILITY OR FITNESS 
FOR A PARTICULAR PURPOSE. 
THE EXCLUSION OF IMPLIED 
WARRANTIES IS NOT 
PERMITTED BY SOME STATES. 
THE ABOVE EXCLUSION MAY 
NOT APPLY TO YOU. THERE MAY 
BE RIGHTS THAT YOU HAVE 
THAT VARY FROM STATE TO 
STATE. IN THAT EVENT, ANY 
IMPLIED WARRANTIES ARE 
LIMITED IN DURATION TO 
THIRTY(30) DAYS FROM THE 
DATE OF DELIVERY OF THE 
SOFTWARE.

In no event will ORBIS Software, Inc. be liable to any 
person for any direct, indirect, special, incidental, 
consequential or similar damages. In no case shall 
ORBIS Software Inc.'s liability exceed the purchase price 
for the software.

Trademark Information
ORBIS Software™ and Easy Grade Pro™ are trademarks 
of ORBIS Software, Inc. and use of them without prior 
consent is prohibited. “Apple”, “Macintosh”, and “Power 
Macintosh” are registered trademarks of Apple 
Computer, Inc. “Windows” is a registered trademark of 
Microsoft Corporation. Palm, Graffiti and HotSync are 
registered trademarks and Palm OS is a trademark of 
3Com Corporation or its subsidiaries.

Dedication
Easy Grade Pro is dedicated to Tommy. If it weren't for 
him, there would be no Easy Grade Pro.

Contacting Orbis Software 
Address: P.O. BOX 73745, Puyallup, WA 98373
*Phone: (253) 848-6899 (Pacific Time)

Fax: (253) 848-6505 (fax only)
Web: www.orbissoft.com

www.easygradepro.com
Sales: sales@orbissoft.com

*Support: support@orbissoft.com
*Before contacting Orbis Software for technical 
support, be sure to view the list of Frequently Asked 
Questions  and contact information at the end of this 
manual.
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1
Getting Started

Welcome to Easy Grade Pro 3.6 from Orbis Software! With Easy Grade Pro, you will be able to manage your student data 
with ease and effectiveness. Easy Grade Pro allows you to create an electronic gradebook which, like a paper gradebook, 
can store student, assignment, score and attendance data on all of your classes and subjects. But unlike a paper gradebook, 
an Easy Grade Pro gradebook provides an abundance of tools to save you time, provides you with a wealth of information 
about your students, and allows you to generate professional internet and paper reports to effectively communicate your 
data with others.

What’s New in Version 3.6
■ New ways to produce student reports for internet viewing with password security. (page 69)
■ The ability to produce student reports in html for attaching to your email to parents and students. (page 75)
■ Compatibility with EGP Clipboard 1.0, the new Palm OS companion to Easy Grade Pro 3.6. (pages 33-34)
■ Color coding of scores and attendance marks based on category, percent ranges, etc. (page 29)
■ Score categories can now be assigned their own grade scales for greater grading flexibility. (page 24)
■ Curving of the overall grade using percentage offsets. (page 48)
■ New tools for the tool bar: Export, Import, Internet, Palm Setup and Show Colors. (page 9)
■ Easy combining of multiple gradebooks for printing of multi-teacher reports. (page 78)
■ Importing can now be used to update student rosters. (pages 77-78)
■ Automatic selection of up to six summary comments per student base on user-defined selection rules. (pages 60-61)
■ Combine term grades using overall grades in addition to term grades. (pages 27-28)
■ A variety of smaller enhancements.

System Requirements
Easy Grade Pro 3.6 requires Windows 95, 98, NT, 2000, XP or Mac OS 7.0+, a color monitor with 256+ colors with at least 640x480 
resolution, a CD-ROM drive (to install the software), a hard disk drive with 4 MB of free space, and a minimum of 16 MB of RAM 
(or 8 MB of RAM for Macintosh 680x0-based systems).

Installing Easy Grade Pro
1 Install Easy Grade Pro.

Macintosh: Insert the installation CD-ROM. The icon of the disk will appear on the desktop. Double-click the Easy Grade 
Pro 3.6 Installer icon and follow the steps.
Windows: Insert the installation CD-ROM and follow the onscreen instructions that appear automatically. If nothing 
appears, choose Run from the Start menu, type D:\setup.exe and press enter. Use the drive letter for your CD-ROM drive in 
place of D.

2 Eject the disk. 
The Easy Grade Pro disk is used for installation only. Be sure to store it in a safe place. 

Chapter 1: Getting Started     5



3 Start Easy Grade Pro.
Macintosh: Double-click on the Easy Grade Pro™ 3.6 icon in the Easy Grade Pro folder created during installation.
Windows: Click on Start in the corner of your screen, choose Programs, and then choose Easy Grade Pro. 

4 Carefully type the serial number  from the Installation card and click OK. 

5 Carefully type the registration name  and click OK. 
Be careful entering the registration name -- it will appear on all reports. 

How to Use this Manual
This manual has been designed to be a reference tool rather than something that should be read from beginning to end. You'll 
find simple, step-by-step instructions along with lots of illustrations. You are encouraged to have this manual at hand as you 
learn to use the program; the explanations and tips can save time and provide insight into what's going on.

Chapters 2-3: Getting Started
If you are new to Easy Grade Pro, you’ll save time by thoroughly investigating the first three chapters. Chapter 2, Getting Help, 
explains how to quickly get answers to questions while you are using the program. You’ll find several Quick Reference sheets. 
Chapter 3, Tutorial, should not be missed; by spending time going through its short lessons, you’ll quickly discover how you 
can use Easy Grade Pro with your classes and students.

Chapters 4-7: Starting Your Own Gradebook
When you are ready to start your own gradebook, take a look at chapters four through seven. Chapter 4, The Gradebook, 
explains how a gradebook is structured and how to create one. Chapter 5, Options, describes the variety of options available. In 
Chapter 6, Students, and Chapter 7, Assignments you'll learn how to add and work with students and assignments.

Chapters 8-9: The Charts
Before you start entering scores, be sure to look at Chapter 8, The Score Chart  because it describes a variety of ways to quickly 
enter scores. It explains how to add notes to scores, how to add extra credit, how to curve and drop scores and how to 
override calculated grades. If you will be working with attendance, seats or student record data, check out Chapter 9, The Other 
Charts for explanations and suggestions about the four remaining charts.

Chapter 10: The Most Important Chapter
If you only read one chapter, it should be Chapter 10, Security. It is essential that you follow a fail-safe plan for protecting your 
student data.

Chapters 11-17: The Other Chapters
Chapters 11 through 17 are available when needed. They cover summaries (Chapter 11, Summaries), communicating student 
data (Chapter 12, Printed Reports, Chapter 13, Internet Reports, Chapter 14, Email Reports, Chapter 15, Porting), how to use a 
gradebook on both Macintosh and Windows computers (Chapter 16, Working Cross Platform) and a chapter with a list of the 
most frequently asked questions of our technical support staff and contact information. (Chapter 17, Technical Support).
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2
Getting Help

 
Getting Help within the Program
The Easy Grade Pro application provides help in the form of balloon help, status bar help and a context-sensitive help window. 

Balloon Help (Macintosh only)
Balloons are short descriptions that appear and disappear as the mouse arrow is moved around in a window. Easy Grade Pro 
has balloons for toolbar tools, for regions in the main gradebook window, and for objects in most windows. To turn balloon 

help on and off, click the Balloon Help tool  found in nearly every window or choose Show/Hide Balloons from the Help 
menu.

Status Bar Help (Windows only)
The status bar is a region at the bottom of the main gradebook window. It provides information about the tool, menu or region 
currently pointed to by the mouse. To turn the status bar on, choose Show Status Bar from the Help menu. When an object is 
pointed to with the mouse arrow, text will appear (like the text shown below). To turn this help off, select the menu item again.

Help Window
Use the Help window whenever you need a detailed description or explanation. To open this window, click the Help tool  
found in most windows or choose Easy Grade Pro Help from the Help menu. Easy Grade Pro will display information based on 
the window in which the tool is clicked. The Help window has two views: Index and Contents (shown below). 
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3
Tutorial

The four lessons in this chapter will introduce you to the structure, tools and options found in Easy Grade Pro. The word to 
remember is explore; these lessons are meant to be springboards for your own exploration. Be sure to utilize the help tools 

 and Quick Reference charts found in Chapter 2 as you work through the lessons.

Lesson 1: Moving around a Gradebook
1 Open the gradebook named Demo Gradebook.

Macintosh: Double-click on the icon titled Demo Gradebook found inside the Easy Grade Pro Folder. 
Windows: Click on Start in the corner of your screen, point to Programs, point to Easy Grade Pro and click Demo 
Gradebook.

Easy Grade Pro will display its title window and then the gradebook window will appear as shown above. This is the gradebook 
of a fictitious sixth grade teacher, Ms. Demo, who teaches Reading, Math, Language Arts and Science. She also teaches science to 
the students in another sixth grade class. The homeroom teacher of those students teaches Social Studies to both classes. Ms. 
Demo is currently in the second quarter of the school year and you are viewing the score chart for the class Quarter 2: Reading. 
Notice that the name of this class is on the Class menu below the tabs.

Class Menu

2 Press on the Class menu on the tool bar to switch to Quarter 2: Math.
Notice that Ms. Demo's math class has most of the same students as her reading class but the assignments are different.
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3 Use the Class menu to move to Quarter 2:Science-1 and then to Quarter 2:Science-2. 
Recall that Ms. Demo teaches science to both sixth grade classes. The science classes have the same assignments but 
different students. By the way, Ms. Demo enters assignments into just one class and then copies them to the other class.

4 Move to the Social Studies class to view a class imported from the other sixth grade teacher's gradebook.
Notice that the students are the same but several items are different. Ms. Demo does not teach this class -- it is taught by an 
associate. But Ms. Demo wants to keep track of her students’ performance in all classes and wants to include their Social 
Studies grades in the progress reports sent to parents. So, periodically, she imports (either by floppy disk or directly over a 
network) the entire Social Studies class from her associate's Easy Grade Pro gradebook. 

5 Switch back to Quarter 2: Reading. Then click on the Attend. tab to switch to the attendance chart.
You can also switch charts using the Chart menu. Notice that the new chart displays dates and attendance marks. Ms. 
Demo takes attendance in just one class, Reading, because it is the first class. A class has five charts: score, attendance, 
seating, student and assignment.

Press here

6 Use the tabs (or Chart menu) to view all five charts.

Explore: An Easy Grade Pro gradebook can have hundreds of classes and each can have its own students, assignments and 
options. Before moving to the next lesson, you may wish to explore charts and classes throughout the gradebook.

Lesson 2: Adding an Assignment
Probably the most time consuming task in the grading process is that of adding assignments and scores. Easy Grade Pro 
provides many tools to make this task easy and fast. In this lesson, you'll be introduced to some of these tools. To begin this 
lesson, the Demo Gradebook must be open and the score chart must be visible.

1 Using the Class menu, move to Quarter 2: Science-1.
You'll know that you are in this class when its title is visible on the tool bar. 

 Be sure you are viewing the score chart. If necessary, click the Score tab or choose Score from the Chart menu.

2 To prepare for the entering of scores, click the small triangle below-left of the first tab so that the 
triangle points downwards (if it is not already pointing downwards).
The triangle (circled below) shows and hides a row of grades and special scores. (Note: if the tool bar is visible instead of the 
tool palette, this triangle is not available. Choose Show Tool Bar from the Edit menu.)

3 Click the Add Assignment button visible after the last assignment or choose Add Assignment from the 
Tool menu.
After clicking, the Records window will open to the first empty assignment record.
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4 In the Name field, type Star Lab.
The box should already have a flashing cursor in it. If not, press the tab key as needed until the flashing cursor is in the box. 

5 Press tab to move to the Max. Score field. Type 25.
The maximum score is the score that earns a 100%. On this assignment, a student that earns a score of 25 will receive a 100%.

6 Press tab to move to the Points field. Type 100.
Points refers to the value or weight of the assignment. Ms. Demo uses 100 on any assignment that has a normal value. She 
uses a higher number for more important assignments and a lower number for less important assignments.

7 Set the due date of the assignment on the calendar. 
The date is used by Easy Grade Pro when sorting, using filters and producing graphs.

8 Press on the Category menu and select Classwork.
The category is used when sorting assignments, when using filters and in graphs and reports. You can view, edit and create 
score categories in the Class Options window but you’ll see these later.

9 Click the Done button.
You should be viewing the score chart again. The first score cell under the new assignment's title should have the flashing 
cursor in it. If not, click on the first empty box under the Star Lab assignment. Now it's time to enter scores. Just to make 
things interesting, you'll enter scores in several different ways.

10 Enter the scores for the ten students as follows:
(If you make a mistake, simply click on the score cell with the error and try again.)

Student #1: Type the number 25 and press enter.
Student #2: Click on the B grade on the tool bar. Do not push the enter key because the next cell is automatically 

selected after clicking. You can set up the grades that appear on the tool bar. In fact, you can have a 
different set of grades for each student and for each category.

Student #3: Press the letter m. This enters a score of mi  for missing. You can customize up to thirty special scores 
and give them any meaning you wish. Notice that the score turns red. Ms. Demo has set things up so that 
all failing scores are displayed in red.

Student #4: Type the number 25. Do not push enter. 

Now click the Fill Down tool  on the tool bar. Notice that 25 is repeated all the way down.

11 Click the Undo tool  on the tool bar or choose Undo from the Edit menu to prepare for the next step.
Notice that the score of 25 is removed from the students. Undo is nearly always available to reverse the last action.

12 Select the seven blank score cells by pressing on the first and dragging to the last. Release the mouse.
The seven score cells should be highlighted as shown on the next page.
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Press on this cell.

Drag to this cell.

13 Click on the A+ grade on the tool bar.
A score of 25 is entered for each student. Try clicking on other grades and special scores in the tool bar. 

Recall that Ms. Demo teaches two science classes and both have the same assignments. It is easy to copy assignments from 
one class to another. In the next few steps, you'll do just that.

14 Using the Class menu on the tool bar, move to Quarter 2: Science-2. 

15 Click on the Copy Class Data tool  or Choose Copy ->Assignments... from the Tool menu. 
The Copy Class Data window will open. The Copy window can be used to copy assignments, students, options and other 
class data. It can copy several items together and copy them to several classes at the same time.

16 First click on the Assign. tab at the top. In the top-left list, click on Quarter 2: Science-1. In the bottom-
left list, click on Quarter 2: Science-2. In the right-hand list, click on Star Lab. Finally, click Copy.
The assignment will be copied from Science-1 to Science-2. After the window closes, the first score cell for the new assignment 
will be selected, ready for you to enter scores.

The rest of this lesson will focus on entering scores for the copied assignment. You'll use a very powerful tool that allows you 
to easily enter scores from a mixed stack of papers. Since you don't actually have the student papers, you'll simply pretend.

17 Click on the Find tool  on the tool bar or choose Find from the Tool menu to open the Find Window.

 

18 Select Use Continuous Search Mode. Then click Exit.
The continuous search mode causes Easy Grade Pro to return to this window after every score is entered. This means that 
whenever the enter key is pressed, or whenever a grade is clicked on the tool bar, the Find window will reappear.
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19 In the score chart, select the first score cell for the Star Lab assignment.
This score cell is for Kelly Armstrong. The cursor should be flashing in this score cell.

20 You will be pretending to enter scores directly from student papers. Follow these steps:
Paper #1: In Kelly Armstrong's score cell, enter a 25 and press enter. The Find window will reopen.
Paper #2: The next paper belongs to Josef Talbo. In the Find window, type the letter T and notice that Easy Grade 

Pro completes it with “Talbo, Josef”. Press enter. Now click Sat on the tool bar. The Find window reopens.
Paper #3: Tad Nguyen earned a 20. Type an N in the Find window and press enter. Type a 20 and press enter again.
Paper #4: Justin Bronin earned an 18. Type the letter B and notice that Easy Grade Pro completes it with ‘Benjamin, 

Atunde’. Type the letter r and notice that Easy Grade Pro completes it with ‘Bronin, Justin’. Press enter. 
Type his score.

Go ahead and finish the remaining scores on your own -- just make them up! When you are done, be sure to deselect the Use 
Continuous Search Mode box (so the Find window will stop reappearing) and click Exit. The Find window can be used to enter 
papers even when those papers are mixed by class. By setting the option Search through all current-term classes, Easy Grade 
Pro will search in other classes if the student is not found in the current class.

Lesson 3: Options and Tools
This lesson, which has been divided into five short parts, will guide you in an exploration of some of the options and tools 
within a gradebook. To begin this lesson, the Demo Gradebook must be open.

Part A: Gradebook and Class Options
Easy Grade Pro offers an abundance of options to accommodate your personal style. Some options, such as font and font size, 
affect the entire gradebook and are called Gradebook Options. But many options apply only to a single class; these are called 
Class Options and include items like grade scales, categories, weighting, calendars, colors and more. In this section, you’ll view 
and edit both types of options. Don’t forget to utilize the Help tool(s) to gain additional information about the options.

1 Select Gradebook Options from the Edit menu and explore all tabs. Then click Done.

2 Select Class Options from the Edit menu and explore all tabs. Then click the Done button.

Part B: Adding a New Data Column
Easy Grade Pro provides numerous ways to configure the charts so that they best suit your needs. For example, in the score 
chart, columns can be added which show class rank, points, or nearly any other data about your students. The next few steps 
will show you how to do this.
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1 Switch to the score chart view of Quarter 2: Reading. Above the column of student names, press on the 
11 of 11 Students title.

2 From the menu that appears, choose Add NEW Column (first item).
A new column will appear to the immediate right. It will also be titled 11 of 11 Students.

3 Press on the new column’s title and choose Main Grades->Class Rank.
The title and content of the column will change to display the rank for each student.

4 To resize the column, move the mouse so that the arrow is over the line to the right of the Class Rank 
title. Press and drag the line to the left.

Press here

Explore: You can have up to eight, user-defined, relocatable data columns in a class. To relocate a column, press on its 
data. The cursor will change to a hand. Then drag the column left or right to the new position and let go. Try adding, 
resizing and relocating data columns. You can also relocate any student and assignment row or column by pressing on the 
student’s or assignment’s name and dragging up or down. Try it!

Part C: Using Filters
Easy Grade Pro allows you to configure the charts so that they display just the students, assignments, scores or attendance 
dates that you want to see. For example, the score chart has four small menus that allow you to control display (circled below). 
Similar menus are found in nearly every chart. In this section, you will explore these four menus to discover what they do.
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1 Switch to the score chart in any class and explore the display menus.
Choose the first item in each menu to return to the standard view. Note that in the right-most menu, the last item allows you 
to open a window where you can design your own filters. You may wish to take a moment to try this. 

2 Switch to the other charts (except seating) and explore the display menus.

Part D: Setting the Display of Seats and Furniture
The seating chart allows you to place seats and furniture nearly anywhere. It also allows you to change the shape, size, rotation 
and color of these items. Use the Chart menu or tabs to switch to this chart. Then try these:
■ Move a single item by dragging it.
■ Swap two seats by dragging one to another. (The upper-left corners must be aligned.)
■ Select more than one item by clicking while holding down the shift key or by dragging a rectangle around the seats.
■ Drag a group of selected items.
■ Double-click on a seat to open the Seat Options window. Try different settings.
■ Double-click on a piece of furniture to open the Furniture Options window. Try different settings.

Part E: Other Tools and Windows
Many special windows can be opened by double-clicking, right-clicking (Windows) and control-clicking (Macintosh) in different 
regions of the charts. Try these suggestions for opening windows from the score chart:
■ Double-click on any row number to open the Summaries window for that student.
■ Double-click on any column number to open the Summaries window for that assignment.
■ Double-click on any score cell to open the Score Note window.
■ Double-click on any student or assignment name to open the Records window.
■ Single-click in the small box to the left of the first score for any student to open the Lock/Curve Grade window.

Lesson 4: Working with Reports
In this lesson, you will be taken through the steps of selecting one report, its range and options. Then, instead of printing the 
report, you will preview the report on screen. The Demo Gradebook should be open and visible. You can be in any class.

1 Click the Print tool  on the tool bar or choose Print from the File menu.
After clicking, the Print Reports window will open. Notice that there are three tabs with nineteen reports.

2 Click the Student tab, select the Single-class Progress item and click Next.
After clicking, the Report Options window will open. The Report Options window allows you to set the items to be included, 
set options, preview reports and then print the reports to paper or disk. There is a different window for each report. 

3 Set the range and options as desired.
The upper half of the window allows you to select the students to receive reports. The lower half allows you to select the 
items to be included in each report. Click the set buttons to open windows where additional options can be set. Click the 

Page/Print Setup button to set options based on your printer. To get a description of an option, click on the help tool .
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4 Click the Preview button.
The Print Preview window has two views: fit-in-screen and full-size. The fit-in-screen view shows the entire page. In the fit-in-
screen view, the cursor is a magnifying glass. By clicking once on any part of the page, the view automatically switches to the 
full-size view. In the full-size view the cursor becomes a hand. By pressing the mouse button, the page can be grabbed and 
dragged about. Double-clicking causes the view to change to the original view. The Zoom button can also be used to toggle 
between the two views. Your can right-click to choose from different zoom levels (Windows).

5 Click the Done button to close the Print Preview window.
If you like, change any options in the Report Options window, then preview again to see how the report has changed.

6 Click the Cancel button in the Report Options window.

Explore: If you'd like, repeat the steps in this lesson for other reports. It's easy. All the reports have options which allow 
much customization. Several reports (charts, graphs) can be printed in color. When you are done, click the Cancel button.

This is the end of Lesson 4 and the end of this chapter. You can quit Easy Grade Pro by choosing Quit/Exit from the File 
menu. By the way, all changes that you made during these lessons have been automatically saved. With Easy Grade Pro, 
changes are always automatically saved!
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4
The Gradebook

An Easy Grade Pro gradebook is very similar to a paper gradebook: both consist of classes with students, assignments, 
scores and attendance. This chapter explains how to create a gradebook and perform basic gradebook management.

Starting a New Gradebook
An Easy Grade Pro gradebook is a single computer file that holds one or more classes. It is usually best to create only one 
gradebook for a year because it saves time and minimizes duplication of efforts. However, a gradebook can become large; if you 
intend to use a floppy disk to transfer or store a copy of your gradebook, you may need to use Easy Grade Pro’s compress tool 
(File menu) or start a new gradebook at the start of each major grading period.

1 Start Easy Grade Pro. If a gradebook opens automatically, choose Close from the File menu. 
After a few seconds, a small window will appear (shown below). 

With Easy Grade Pro for Windows, the gradebook that was last viewed automatically reopens whenever Easy Grade Pro 
is started directly. If this happens, choose Close from the File menu.

2 Click the Create a New Gradebook button.

3 Type the name of your new gradebook and choose the location to save it.
Do not use the name of a class for the gradebook’s name unless the gradebook will contain only one class. 
Be sure to Save your gradebook to the hard disk of a computer and not to a floppy disk. A floppy disk is slow and 
unreliable. Use a floppy disk only to store a copy or transfer a gradebook from one computer’s hard drive to another.

4 Click the Save button.

 The icon for your new gradebook is a notebook with a large check mark on it. 

Adding Classes to a Gradebook
1 Open the Records window to the first blank class record.

There are different ways to open the Records window. If your gradebook has no classes, a window (below-left) will 
automatically appear. Click the Add Classes button. If your gradebook has classes, choose Add Class from the Tool menu. 
In either case, the Records window will open (below-right).
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2 Type the name of the class in the Class/Subject Name field and press tab.
Be sure to use a unique name for the class. Examples include Math, Reading, English(1), English(2), etc. 

 Do not include a term name with the name of the class.

3 (Optional) Edit the Class Weight and press tab.
Class weight is used in some reports when a student’s weighted average for several classes is calculated. In most cases it 
should be kept at 1.00. If you have a class that is worth half of a normal class, set the class weight to 0.50 and so on.

4 (Optional) Edit the Term Labels in the column on the left.
Any of the term labels can be changed. You can use First 6 Weeks, Semester 2, etc. If you will give a final exam that must be 
weighted, then you must add the final exam as a term. Changes made to these labels will apply to all classes.

5 Select the terms for which the class will be taught.
 You must select at least one term.

6 (Optional) Edit the Custom Labels and add Custom Data.
There are eight custom data fields. You can edit the labels of these fields as well as enter any kind of information. You might 
put course number, section number, etc. 

7 (Optional) Add more classes.
To add more classes, click the Next Class button or press enter.

8 Click Done to close the Records window.
The new class names have now been placed in the Class menu which is used to switch to the classes in a gradebook.

Managing/Sorting Class Records
At any time, you can view, edit or add data to a class record. You may wish to add a new term, change the name of the 
class or change the name of the term. To make changes, choose Records from the Chart menu or click the Records tool 

. Click the Classes tab and make the desired changes. The order of the class records determines the order in which 
the classes appear in the Class menu and in reports. If you need to change the order, choose Sort Classes from the View 
menu. A window will open where you can change the order.

Saving your Changes
Like most database programs that can deal with large amounts of data, Easy Grade Pro automatically saves all of your 
changes. You trigger the automatic saving of data whenever you switch classes, switch charts and choose most menu 
commands or even leave your computer idle for a few minutes.

 Although Easy Grade Pro automatically saves your changes, you are strongly encouraged to make backup copies of 
your gradebook. Refer to Chapter 12, Security, for a discussion on ways to protect your important student data.
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5
Options

Easy Grade Pro attempts to accommodate the variations in how teachers manage student data by providing options on 
two levels: class as well as gradebook. Class options apply only to a specific class in one term; gradebook options apply to 
the entire gradebook. This chapter explains how to view and edit both types of options. It also show how to copy class 
options from one class to others.

Class Options in General
Each class within a gradebook can have its own grading scales, score categories, special scores, attendance categories and other 
options. Together, these are known as class options because they are stored with the class and are unique to it. A class has no 
options until it is viewed for the first time. Easy Grade Pro automatically copies options into the class, either from a prior term 
class, from an adjacent class or from a built-in set of options if it is the first class in the gradebook.

Class Options can be viewed and edited at any time in the Class Options window. To open this window, choose Class Options 

from the Edit menu or click the Class Options tool . This window consists of a series of tabs, one for each type of class 
option. The following sections explain the options found under each tab. 

Changes that you make to the Class Options in one class have no effect on other existing classes. However, it is easy to 
copy options from one class to other classes. For more information, see the section Copying Class Options to other 
Classes on page 30.

Class Options: Grade Scales
A grade scale is used to convert the percent on an assignment, a category average and the overall average to some meaningful 
label. For example, it may be used to convert a 98% to an A+. A scale consists of one or more grades with a minimum or cutoff 
percent for each. Grades can be letters (A,B,C), words (Outstanding, Satisfactory) or numbers (4.00, 3.00). A class may have 
multiple grade scales. Each student is assigned the first grade scale but you can have different scales for different students. You 
can even assign scales to score categories in case you wish a certain category of assignments to always use a certain scale. 
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Guidelines
■ To edit grade scale options, choose Class Options from the Edit menu and select the Scale tab.
■ The names of one or more scales will appear in the list on the left. The first grade scale in the list is the most important one 

because it is initially assigned to all students. 
■ The scales can be put into any order by pressing on the row numbers and dragging.
■ Before editing a scale or using the Duplicate and Delete buttons, select the scale by clicking on its row number. The grades 

and minimum percents will appear to the right.
■ The minimum percents must be in descending order and the last percent must be 0.
■ Use the small blue arrows to insert or delete a row anywhere in a scale. 

■ To assign a scale to a student (other than the first scale), choose Records from the Chart menu or click the Records tool  
and select the Students tab, or choose Students from the Chart menu. Then select a scale from the menu for each student.

■ To assign a scale to a score category (other than the student’s scale), click the Category tab in the Class Options window 
and make your selection from the pop up menu after the category’s name.

What happens when a grade is typed or clicked to give a score?
Although grades are normally used to convert percents to meaningful labels, Easy Grade Pro allows you to enter 
scores on assignments by typing grades (if the Allow typing of Grades and Special Scores option is on in the 
Gradebook Options window) and by clicking on grades on the tool bar. What score does a student get when an 
A+ or C+ is entered? The score is based on the grade click value of the grade. For all grade scales, the grade click 
value for the top grade is 100%. For all other grades, it is the average percent for the grade. For an A+ (the top 
grade) the student will get a score that is equivalent to 100%. If a C+ ranges from 76% to 80%, the student will get a 
score that is equivalent to 78%. Grade click values are automatically set and editing is usually unnecessary. To edit 
them, click the blue arrow above the scroll bar on the right in the Scales view of the Class Options window. Grade 
click values are always reset to default values when changes are made to a grade scale.

Class Options: Rounding
Rounding options include whole numbers, tenths and hundredths, and are used whenever percents are calculated. As an 
example, suppose a student has earned 89.638%. After rounding, the number displayed will be 90% for ones rounding, 89.6% for 
tenths rounding and 89.64% for hundredths. Ones rounding results in cleaner looking numbers. Hundredths rounding results 
in greater accuracy. For many teachers, tenths rounding offers a good compromise. Rounding can be edited only in the 
Rounding view of the Class Options window.

Class Options: Score Categories
Whenever an assignment is added to a class, a score category must be selected. Categories are used in graphs, summary charts, 
filters and reports. They help provide useful information about a student’s performance. They can also affect a student’s overall 
grade if the weighted-categories option is turned on. A class can have up to fifteen score categories.
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Guidelines
■ Score Category options can be edited only in the Category view of the Class Options window.
■ Since each class has its own set of options, you can use subject-specific names such as Lab Activity. 
■ Category options can be changed at any time but be careful if the category is already being used by an assignment in the 

class. Verify all assignments after making changes!
■ Score categories can be weighted with percents to ensure that they have the desired value. For example, tests can be worth 

50%, homework 30% and participation 20%. If you use weights, be sure that their sum is 100%. There is one drawback to 
using category weights: classes that use category weighting can only have their terms combined using term weights. Classes 
that don’t use category weighting can have their terms combined using term weights or points. Refer to the section Class 
Options: Combine Term starting on page 27 for additional information on this. 

■ Categories can have grade scales assigned to them. For example, you can have a category named Effort that uses a +1, +2, 
+3 grade scale. Easy Grade Pro will use the category’s assigned grade scale in the score chart, in assignment graphs and in 
reports. Grade scales can be created and edited in the Scale view of the Class Options window.

Class Options: Score Footnotes
Score footnotes are short comments that can be attached to scores to provide additional meaning. They can be included in 
progress reports and filters. Footnotes can be attached to scores in several ways: 1) by double-clicking on a score cell and then 
selecting the footnote from a list; 2) by pressing the footnote number on the keyboard while holding down the option key 
(Macintosh); 3) by right-clicking (Windows) or control-clicking (Macintosh) on a score cell; and 4) by clicking on a footnote in 
the mini-summary. Footnote options can be viewed and edited only in the Footnote view of the Class Options window. If you 
change a footnote that is already being used, be sure to limit the change to something with the same meaning, or remove the 
footnote from the scores that use it.

Class Options: Special Scores
Special scores are scores you design that can be used in place of numeric scores on assignments. Some examples include ex, yes, 
no and +. A special score has five attributes. Its name is used as a key in reports. Its code is used in place of the numeric score. 
Its  shortcut  is a single key that, when pressed, enters the code into a score cell. The value% is the percentage value of the score 
and missing determines whether the score should be picked up when a missing work filter is used or a missing work report is 
printed.

Guidelines
■ Special Score options can be edited only in the Score view of the Class Options window.
■ You may define up to thirty special scores.
■ It is best if your special scores do not include numbers because of the confusion that may result. If you do use numbers, 

include other symbols so it is clear that the score has a different meaning. For example, consider using +1 through +5 
instead of 1 through 5. As an exception to the rule above, you may want to use 0 as a special score if you would like to have 
zeros count as missing when missing work filters are used.

■ The value of a special score should be blank (no value) or between 0 and 100%.
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■ If you change a special score that is already being used, any location that had the prior score will display the new one. 

Special score codes can be entered into cells in the Score chart in three ways. A code can be entered by clicking on the tool bar 
(see below). A code can be entered by direct typing if the Gradebook Option Allow typing of Grades and Special Scores is on. A 
code can also be entered by pressing a single-key shortcut if the Gradebook Option Allow typing of Special Score Shortcuts  is 
on. Of the three methods, the shortcut is fastest. To show or hide the special scores on the tool bar, click the small triangle to 
the left of the class menu on the tool bar. To quickly switch between the direct typing and shortcut modes, press the small 
triangle below the class menu. A menu will pop up allowing you to make your selection.

Class Options: Attendance Categories
You can set up to fifteen attendance categories. An attendance category has four attributes. The category is the full name of the 
category. The master category names the major grouping that the category belongs to. The code is the one- or two-character 
mark that is entered in an attendance cell. The value is used when calculating totals and should be 1.00 for full-day marks, 0.50 
for half-day, etc.

Guidelines
■ Attendance options can be edited only in the Attendance view of the Class Options window 
■ You can change items at any time, but it is best not to change items that are being used unless you simply change a name to 

a synonym. 
■ You should never remove items in use, or change their position.
■ Each term of a class should have the same attendance codes. When attendance is combined across terms, it is matched 

using the codes.
■ Elementary teachers can use just one class for attendance each term because the multi-class progress report will 

automatically find that class when compiling the report. 

Class Options: Calendar
Calendar options allow you to set the days that the class meets, the starting and ending dates and no-school days. A calendar 
only needs to be set if attendance will be taken. Calendar options can be edited only in the Calendar view of the Class Options 
window. Set your calendar carefully. Once student attendance data has been added to a class, you will be able to change neither 
the days that the class meets nor the first day of the term. 

26     Chapter 5: Options



Class Options: Combine Term
Some background information: In Easy Grade Pro, each term of a class is actually a separate and distinct class within the 
gradebook. For example, let’s say an instructor will be teaching Chemistry for two quarters. To add the class to the gradebook, 
the instructor opens the Records window, types the name of the class and adds two check marks in the Terms column. Easy 
Grade Pro will actually add two classes to the gradebook: Quarter 1: Chemistry and Quarter 2: Chemistry. There are several 
benefits to having each term as a separate class. Grade scales, categories and other options can be changed in one term without 
data in prior terms being inadvertently changed or regraded. Students can be removed from one term without losing their data 
in earlier terms. Switching classes is faster because classes are smaller. 

The Combine Term options are used to combine data in one or more prior-term classes with the current class. When terms are 
combined, Easy Grade Pro goes to each of the prior-term classes set in the Class Options window and tries to match the 
students. Whenever a match is found, the student’s overall points, overall grade and attendance totals for that term are copied 
to and combined with the current class using the combining method that has been set.

Guidelines
■ Combine Term options can be edited only in the Term view of the Class Options window.
■ Choose Combine grades using weights to ensure that each term has a set value. Don’t use this method unless you are at or 

near the end of the current term because temporary grade distortions can occur when the current term has only a few 
assignments.

■ Choose Combine grades using points if you want the current term to be a direct continuation of the prior term or if you 
want the sum of the points in a term to determine the weight of the term. This option is not available if any of the classes 
being combined uses score category weighting.

■ You may choose to match the students by ID or name. Each student’s ID number or name must be identical in all terms.
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■ Select the prior-term classes by pressing on the menus below the name of the current class. When selecting classes, you 
must choose between combining the term or the overall grade from the class for each student. In most cases, you will 
choose to combine the term grade. See the question When should I combine overall grades instead of term grades? below 
for an explanation of this option.

■ Enter the term weights as desired. If you want reports to display individual terms without combining the term grades, use 
100% for the current term and 0% for others.

What do I do when a student doesn’t match?
When terms are combined, a window will always appear listing any students that could not be matched. If a student didn’t 
match but should have, it is probably because the student’s name or ID number is different. You’ll have to change the name or 
ID in the affected class and then, from the current-term class, choose Recombine Terms from the Tool menu. 

How is a class changed by using combine term options?
After combining, the overall grades and attendance totals found in charts, summaries and reports reflect all combined terms. In 
the scores and attendance charts, special columns can be added adjacent to the column of student names that show data from 
individual terms. (See Adding Columns to Show Special Data on page 50.) Many reports and summaries will display multi-term 
data automatically or as an option.

How often do I need to combine terms?
You usually do not need to set term options more than once in a term for a class. Whenever you enter a score or attendance 
mark in your current class, Easy Grade Pro calculates new totals that include the copied, prior-term data. However, if you make 
changes to grades or attendance data in any of the prior term classes, you must recombine the terms to bring the updated 
data into your current term (see the next section to learn how).

How do I recombine terms?
Recombining terms causes Easy Grade Pro to go back to each class that is combined with your current class and recopy the 
grades and attendance data. This is used whenever the current copied grades or attendance data are not complete or not 
current. To recombine the data, choose Recombine Terms from the Tool menu.

How do I un-combine terms?
You may occasionally want to combine terms just long enough to print certain reports. To later un-combine terms, open the 
Class Options window to the Term view. Press on each prior term class listed in this window and choose None in the menu 
that appears. When you exit from this window, your class will be un-combined.

When should I combine overall grades instead of term grades? 
When setting your combine term options, you must choose to combine the term or overall grades from each selected class. 
Usually you will combine the term grades. However, you may want to combine overall grades under certain circumstances. For 
example, suppose you set up your gradebook with the following terms: Quarter 1, Quarter 2, Semester 1, Quarter 3, Quarter 4, 
Semester 2, Final Exam and Year Grade. In your Semester 2 class, you combined term grades for Quarters 1 and 2. In your 
Semester 2 class, you combined term grades for Quarters 3 and 4. However, in your Year Grade class, you combined the overall 
grade from Semester 1, with the overall grade from Semester 2 with the term grade from Final Exam to produce a year-end grade. 
In summary, you will usually combine term grades. However, if one of the classes you are combining has combine term options 
set in it, then you may want to combine the overall grade from it instead.

I have to include a weighted final exam. What do I do?
When a final exam must be weighted with one or more other terms, the final exam should be treated in the same way as the 
terms. As an example, you might set up your terms in the Records window as follows: Semester 1, Semester 2 and Final Exam. 
Your Final Exam will actually be a separate class within your gradebook. From within the Final Exam Class, you might set the 
combine term options as follows: Semester 1 - 40%, Semester 2 - 40% and Final Exam - 20%. The overall grades will be found in 
the Final Exam class.
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Class Options: Seat Format
If you plan to use the seating chart for a class, you can use the Seat Format options to set the size, shape, name and formats for 
all of the seats. 

Guidelines
■ Seat Format options can be edited only in the Seat view of the Class Options window.
■ To change the seat shape, drag the box at the lower-right corner of the sample seat.
■ Use the buttons to set the name and attendance formats. These options affect all seats.
■ If you would like to change the rotation, color or locked status of a seat, double-click on the seat in the actual seating chart. 

The format window will appear for that seat where you can make your selections.
■ To copy the seat format options from one class to others, choose Copy->Class Options from the Tool menu. To copy the 

seating chart structure and furniture from one class to others, choose Copy->Seats from the Tool menu.

Class Options: Color
You can set the background and grid colors used in all charts and in bar graphs. You can also set colors for scores and 
attendance marks used in the score and attendance charts.

Guidelines
■ Use the Grid Color and Background Color buttons to open a window where you can choose new colors.
■ Use the Score Colors and Attendance Colors tabs to switch between setting colors for the score chart and for the 

attendance chart. You may set colors for both charts.
■ Use the Select colors base on menu to choose the basis for color selection using the six pop up menus and buttons below.
■ Use the six pop up menus in the bottom half of the window to set the category, score or percent associated with the color 

to the right of each menu. Use the six buttons to open a window where you can choose new colors.

■ Colors can be turned on and off using the Show Colors tool  and using the Show Colors item in the View menu.
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Copying Class Options to other Classes
It is easy to copy options in one class to others using the Copy Class Data window. Choose Copy->Class Options from the 

Tool menu or click the Copy Class Data tool  and select the Options tab. In the upper-left list, select the class to copy from. 
In the lower-left list, select the class(es) to copy to. Select the options you wish to copy and click Copy. 

Use caution in copying class options: you might accidentally copy options that you don’t want copied, causing 
unintentional changes to occur. 

Note: This ends the last section on Class Options. The remainder of this chapter explains Gradebook Options and 
tools that affect the entire gradebook.

Gradebook Options: Display
Display Options include font, font size, column and row highlighting, student name order, and other items that affect the 
display in the five main charts. These can be edited only in the Gradebook Options window.

Guidelines
■ Display options can be edited in the Display view of the Gradebook Options window opened from the Edit menu.
■ The Font  and Size menus affect display in the main charts and the text in the Summaries and Score Notes windows. 
■ The Highlight menu items control how a column and row are highlighted whenever a cell is selected in one of the charts.
■ The Show Students  menu allows you to set the order of a student’s first and last names in most charts and reports. (This 

menu does not affect the seating chart.)
■ The Show Grades menu allows you to set the display of grades (not scores) in the charts. It has no effect on student reports 

(which have their own Show Grades menus).
■ The Show  for missing work option causes an M to be drawn in the score chart for each student that has at least one 

score that counts as missing.
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Gradebook Options: General
General Options control the behavior of typing, warnings, scrolling, the movement of palettes and compression.

Guidelines
■ General options can be edited in the General view of the Gradebook Options window opened from the Edit menu.
■ The Allow typing of Special Score Shortcuts option allows you to use the single-key special score shortcuts set in the Score 

view of the Class Options window.
■ The Allow typing of Grades and Special Scores option allows you to type grades and special score codes directly into 

scores cells in the score chart.
■ The Give warning when a score is changed option allows you to be given a warning when a non-blank score or attendance 

code is changed. This can help minimize accidental changes.
■ The Give warning when a score exceeds the maximum option allows you to be given a warning the first time a score is 

entered which exceeds the assignment’s maximum.
■ The Scroll to top when the last score is entered  option makes it easier to enter scores from a paper gradebook. When a 

score is entered for the last student, Easy Grade Pro scrolls up to the first student on the next assignment.
■ The Scroll to left when a cell is selected option causes Easy Grade Pro to scroll the selected item to the left. (This affects all 

charts but seating.)
■ The Palettes: automatically position based on chart option causes the tool palette and the mini-summary windows to 

move up or down, based on the chart. Palettes move up in the score and attendance charts, and down in the others.
■ The Palettes: hide in Seating, Student & Assign. charts option causes the floating tool palette and the mini-summary 

window to automatically close (disappear) whenever moving to the seating, student and assignments charts.
■ Use the Compression  option to cause each class to be compressed during automatic saving. The class will take up less 

space but will take more time to save. To compress the entire gradebook, choose Compress from the File menu.

Gradebook Options: Security
Security Options include teacher and TA passwords, backup preferences and TA access privileges. These can be edited only in 
the Gradebook Options window.

Guidelines
■ Security options can be edited in the Security view of the Gradebook Options window opened from the Edit menu.
■ Use the Set Teacher Password button to open a window where the teacher password can be entered or changed. This 

password is used to gain full access to a gradebook.
■ Use the Set TA Password  button to open a window where the TA password can be entered or changed. This password is 

used to gain limited access to a gradebook.
■ The Password Protect... options allow you to set whether the gradebook becomes locked whenever you quit or only if you 

choose Lock.
■ The When Close or Quit... options allow you to control the type of backup prompt that appears whenever you quit or close 

your gradebook.
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■ The Allow TA to... options are used to set access privileges for a teacher assistant. The TA mode allows you to give access to 
another person while still protecting your gradebook and student privacy rights. The teacher password is required to turn 
off the TA mode.

Gradebook Options: Clipboard Text
Clipboard text items are stored sentences and paragraphs that can be pasted into score notes, summary notes and student 
reports. There is no limit to the number of clipboard text items and each has a 32,000 keystroke limit. Numerous variables can 
be added to the text; Easy Grade Pro completes the variables with student data at the time the text is printed or pasted into 
notes. A 50,000-word dictionary is available. 

Guidelines
■ Clipboard options can be edited in the Clipboard Text view of the Gradebook Options window opened from the Edit menu.
■ To edit a text item, first select it in the left list. The full text will appear to the right.
■ To create a new text item, select the last list item titled NEW ITEM. Then type the text.
■ To delete or duplicate an item, press on the small blue arrow above the list of items.
■ You can use all basic editing commands on the text.
■ Use the four menus below the text to add text variables. Variables are automatically filled in with the specified student or 

other data at the time the text is pasted into a note or printed in a report. You may need to put a space before and after each 
variable to ensure proper spacing when Easy Grade Pro later substitutes the variable with student data. 

■ Click the Spell button to bring up the Spell Check window (described next).

Gradebook Options: Report Labels
Report Label options allow you to change the titles and labels used in student reports. Easy Grade Pro has labels in three 
different languages (English, French and Spanish) and each can be customized. You can even create labels for a fourth language 
of your choice.
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Guidelines
■ Report Label options can be edited in the Gradebook Options window opened from the Edit menu.
■ Begin by using the Language menu to set the language you wish to customize.
■ Use the last menu item to add your own language or to add an alternate set of labels.
■ Use the Records window or the student chart to assign a language to a student.
■ The built-in label will be used unless you enter your own.

Gradebook Options: Palm Setup
EGP Clipboard, the Palm OS companion to Easy Grade Pro, can be used to record student scores, attendance and notes. 
Contact Orbis Software to purchase EGP Clipboard. To set up a gradebook for syncing with EGP Clipboard, follow these steps:

1 Open the Palm Setup window.
To open this window (shown below), choose Palm Setup from the File menu or click the Palm Setup tool . 

2 Select Turn on syncing for this gradebook.
If a different gradebook is already set up for syncing, a warning window will appear because only one gradebook can be set 
up for syncing at a time. 

Do not turn on syncing for a new gradebook if there are unsynced gradebook changes on the handheld. Sync the data 
first!

3 (Optional) Click the Reset User button.
EGP Clipboard uses the Handheld User name displayed in the window to match the gradebook with the right handheld 
when syncing. If the name is blank, it will be filled in automatically during the first sync. 

Do not reset the user if there are unsynced gradebook changes on the handheld.
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4 From the list, select the classes to be copied to the handheld.
You may select up to sixteen classes from one term. If a selected class has no students, it will be ignored. You may change 
your selection of classes at any time; EGP Clipboard will sync the changes in your handheld before switching to your new 
class selections.

Don’t select unneeded classes: each adds roughly five seconds to the sync time. 

5 Choose the students to be copied to the handheld.
You can choose to include all students, displayed students (based on the items in the View menu) or students with missing 
or blank scores. Withdrawn students are never copied. The students that appear on the handheld can actually change each 
time you sync.

If your selection results in no students to be copied, the class will be ignored and not appear on the handheld.

6 (Optional) Select the Include Assignments box and choose the assignments to be copied to the handheld.
You can choose to include all assignments, displayed assignments (based on the items in the View menu) or assignments 
with missing or blank scores. The assignments that appear on the handheld can change every time you sync based on your 
setting. 

To minimize sync time, only include assignments needed until the next sync.

7 (Optional) Select the Include Attendance box. 
If you want to record attendance on the handheld, be sure to set a calendar for the class in the Class Options window 
before syncing. Calendars cannot be set on the handheld. 

To minimize sync time, only set calendars in classes for which attendance data will be recorded.

Using the Spell Check Window
Click the Spell tool  in the Clipboard Options, Score Note, Summaries and other windows to bring up the Spell 
Check window. This tool will check your text. If it finds an unknown word, it will display the word with possible replacements. 

Guidelines
■ Click Replace to change the unknown word to the selected word from the dictionary.
■ Click Skip for words that you know are correct but don’t want added to the dictionary.
■ Click Learn for words that you know are correct and do want added to the user dictionary.
■ Press on the blue arrow to turn Smart Typing on and off. Smart Typing allows you to type a word in an attempt to find the 

correct spelling. As you type, the spell checker will try to complete it for you.
■ Click Cancel to stop the checking of words.
■ Note that the numbers of unknown and checked words appear at the bottom.
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6
Students

This chapter explains how to add, copy, sort, edit, withdraw, delete and transfer students.

A Class without Students
Whenever a class without students is displayed, a window appears (shown below) requesting that you choose how students 
are to be added to the class. Don’t select the Type Student Names button unless it is your only option. Whenever possible, 
click the Copy Students from the PRIOR TERM button because the students will appear without any more effort on your part. 
And this will ensure that student names are the same in each class. The Copy Students from another Class button should be 
your second choice. If clicked, the Copy Class Data window will open allowing you to copy students. If you have access to 
another Easy Grade Pro gradebook or a TEXT file with the right students, you can click the Import from another file button. 

Adding Students to a Class
1 Open the Records window to the first empty student record.

There are four ways to open this window so that it automatically displays the first empty student record: 1) click the Type 
Student Names button (shown in the last section); 2) select Add Student from the Tool menu; 3) click the Add Student 

button in the score, attendance or student charts; or 4) click the Add Student tool  on the tool bar.
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2 Type the last name and press tab. Type the first name and press tab.
Notice that after both names are typed, the Next Student >> button that leads to the next record becomes framed. Any 
framed button can be selected by pressing enter. After the names have been entered, you can move to the next student by 
pressing enter. Be careful: if you press enter intending to move down to the next field in this record, you will actually 
move to the next student’s record. If this happens, click the << button.

3 (Optional) Enter the ID by typing or have it set automatically. Press tab.
The small button to the right of the ID number field opens a window where automatic ID numbers can be set.

4 (Optional) Set the student’s gender.
Gender is used in custom filters and in clipboard text.

5 (Optional) Change the student’s status.
You may choose between Active, WD (grayed) (grayed in the charts) and WD (hidden) (hidden in the charts).

6 (Optional) Change the student’s grade scale.
Easy Grade Pro will automatically assign the first grade scale to a new student.

7 (Optional) Change the student’s report language.
This option affects the titles and labels used in progress and missing work reports. You can select English, Spanish, French 
or a user-specified language. The labels can be edited in the Gradebook Options window.

8 (Optional) Enter a password.
The password is used to gain access to Easy Grade Pro's HTML Multi- and Single-class Website reports. It is not used with 
any other internet reports. Additionally, the password is used as a filter when creating these reports: only students with 
passwords will have reports created; all other students are skipped. The case of the password is not important but it must 
consists of numbers and letters only. No spaces. It must be at least six but no more than twenty-four characters in length. 
To create a report, choose Internet from the File menu, select the HTML tab and select a 'Website' report.

9 (Optional) Edit the Custom Labels and add Custom Data.
There are twelve custom data fields. You can set the labels of these fields as well as enter any kind of information. You might 
include phone number, parent name, address (to be used in mailing labels), reading group, etc.

10 Press enter to move to the next student or click Done.

Copying Students to other Classes
Whenever possible, copy students from one class to another rather than type student names. It’s faster and ensures that the 

names and other data are identical. Choose Copy->Students from the Tool menu or click the Copy Class Data tool  and 
select the Students tab. In the upper-left list, select the class to copy from. In the lower-left list, select the class(es) to copy to. 
Select the students you wish to copy and click Copy. 
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Changing a Student Record
At any time, you can view, edit or add data to a student record. You may wish to modify the name, change the student status or 

make some other changes. To make changes, choose Records from the Chart menu or click the Records tool . Click the 
Students tab and make the desired changes.

Changing the Order of Students
Easy Grade Pro gives you complete control over the order of students in a class. There are three general ways to change student 
order: sorting, dragging and editing.

You can sort your students by last name, first name and several other ways using the items in the View menu. You can also sort 

students using the Sort tool . This tool sorts student by name in the score, attendance and student charts. In the seating 
chart, it sorts students randomly. In most charts you can change student location simply by pressing on the student’s name 
and dragging up or down. 

Basic editing can be used to move one or a group of students simultaneously. Students can be moved in the same class or to 
other classes. Follow these steps:

1 Click the row number of the student to be moved.
After clicking, the student's row will be highlighted. You can select more than one row if you press on the row number and 
then drag up or down. 

2 Select Cut from the Edit menu.
The row(s) will be removed and placed on the computer's clipboard.

3 Select the row where you would like the student(s) to be by clicking on a single row number.
You may select any currently used row or the row immediately following the last student in the current class, in another 
class, or even in another gradebook.

4 Select Paste from the Edit menu.
The row(s) will be pasted into the list. All students already in the list from the selected row on down will be moved to make 
room for the pasted student(s).

Withdrawing a Student
Easy Grade Pro allows you to withdraw a student without removing the student from the class. When a student is withdrawn, 
you can elect to have the student hidden from the charts or just grayed. If a student is grayed in the charts, cells cannot be 
selected and data cannot be changed. The letters WD are appended to the name of a withdrawn student. When printing reports, 
withdrawn students will be skipped unless specifically chosen. 

1 Open the student record for the withdrawing student.
The easiest way to do this is to double-click on the student's name in any of the charts (except the seating chart).
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2 Use the status menu to select either WD (grayed) or WD (hidden).

3 Click Done to exit. 
If you selected WD (hidden), the student will be removed from all charts. If you selected WD (grayed), the student will be 
removed from the seating chart but will be grayed in the other charts as shown below.

Deleting a Student
To delete a student using editing techniques, select the student’s row number in the score, attendance or student charts. If you 
need to delete a series of students, press on the first row number and then drag down to the last student. Then click the Delete 

tool , press the delete key or choose Clear from the Edit menu.

To delete a student using the Delete window, choose Delete Student from the Tool menu. Select the student(s) to be deleted 
from the list. Click Delete. If a student is to be deleted from multiple classes, you will need to repeat these steps for each class.

Transferring a Student
How you transfer a student depends on whether the assignments and calendars in the original class and the transfer class 
match exactly.

Transferring a Student when Classes Match
If the two classes match exactly (assignment order, assignment settings, calendar settings, score footnotes, etc.), it is easy to 
transfer a student using basic copy and paste. Simply select the student’s row number in the score or student chart to the left 
of the student’s name and choose Copy from the Edit menu. Then switch classes, select any row number and choose Paste 
from the Edit menu. This method is preferred because it not only transfers the student’s name, scores and attendance data, but 
score notes, footnotes and summary notes as well.

Transferring a Student when Classes Do Not Match
Transferring a student is more difficult when the classes don’t match. In this case, you may want to simply print out scores and 
attendance charts and retype the data into the proper columns. If the transfer class has different assignments or different 
settings, it may not be possible to retype all scores and maintain the student’s transfer average. 

In this case, you may want to simply add a new assignment column used solely to give the student a transfer grade. Here are 
some suggestions when doing this:
■ Use an assignment name like Tommy’s Transfer Grade.
■ Set the assignment’s maximum score to 100 since you will be transferring a percent.
■ Set the assignment’s points value to the sum of all the points currently in the class. This will ensure that the student’s 

transfer grade has the same weight as all the assignments currently in the class. The Summaries window (Class or Student 
Grades views) can help determine the number of points possible from all assignments.

■ Set the assignment’s progress report option to Include if student has score. This ensures that the assignment will not 
appear on another student’s progress report.

■ In the score cell for this student, enter the student’s transfer percent.
■ If you use category weighting in the class, you may need to follow these steps for each of the categories instead of for the 

class as a whole. 
■ If you use category weighting and you want to transfer a student to a class in a term that has already ended, you may simply 

type the student’s name in the transfer class and use the Lock/Curve Grade window to enter and lock in the transfer 
percent. Refer to the section Locking and Curving the Overall Grade on page 48 for help. Note: this method should not be 
used in a class without category weighting.
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7
Assignments

In this chapter, you will learn how to add, copy, edit, sort, and delete assignments. At the end you’ll find an explanation of 
how Easy Grade Pro calculates overall grades.

Adding Assignments
Assignments can be added to a class by typing, by copying from another class or by importing from a class in another 
gradebook. This section explains how to add assignments by typing. 

1 Open the Records window to the first empty assignment record.
There are three ways to open this window so that it displays the first empty record: 1) select Add Assignment from the Tool 

menu, 2) click the Add Assignment button in the score or assignment charts or 3) click the Add Assignment tool .

.

2 Type the assignment Name and press tab.
After typing the name, the Next Assignment >> button that leads to the next assignment record becomes framed. Any 
framed button can be selected by pressing enter. After the name has been entered, you can move on to the next assignment 
at any time by pressing enter. But be careful because once you have entered the name, if you press enter intending to move 
to the next field in this record, you will actually move to the next record. If this happens, click the << button.

3 Type the assignment’s Maximum Score and press tab. 
Maximum score refers to the score that earns 100%. The maximum score is used only to determine the student’s percent on 
the assignment. If a student’s score is 15 and the maximum score is 20, Easy Grade Pro calculates (15/20) x 100 and gets 75%. 
Note that maximum score has nothing to do with the assignment’s value. If the assignment is being used for extra credit or 
is a non-graded item, then maximum score is ignored.

4 Type the assignment’s Points and press tab.
The points, or points possible value, refers to the true value of the assignment. The higher the number, the greater the value 
of the assignment. Students earn points based on their score’s percentage value. Using the example above in which the 
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student earned a 75%, the student will earn 15 points if there are 20 points possible, 75 points if there are 100 points possible 
and 150 if there are 200 points possible. In its simplest form, a student’s overall grade is based on the sum of the points 
earned on all assignments divided by the sum of the points possible. 

What’s your Grading Style?
For some teachers, the scores put on papers are not the number of correct problems but the number of points earned. 
In this case, scores and points earned are the same thing. If you grade this way, when you add an assignment to your 
gradebook, you should set the maximum score and points to the same value. If, on the other hand, the scores you put on 
papers do not directly relate to the value of the assignments, when you add an assignment, you will probably set the 
maximum score and points to different values. You may want to use a points value of 100 for typical assignments, 50 for 
assignments that have half the typical value, 200 for assignments that are double, and so on.

5 Select the assignment's due date.
The calendar is initially set to the current date. You can click on the dates, the month arrows and even the year to change 
the date. If the date showing is not the current date, the computer's clock may be improperly set or its battery may be dead.

6 Select the assignment's category. 
The category is used in summaries, reports and in grading (if categories are weighted). 

7 Select the Special Status option. 
Special status options include the following items:

■ Normal. No special action is taken.
■ Extra credit. Any score entered for a student will increase the number of points the student has earned without increasing 

the number of points possible. In other words, the student’s average will go up. Students without scores are unaffected.
■ Can be dropped. Easy Grade Pro will drop this assignment for a student if, by dropping it, the student's overall percent is 

improved more than by dropping any other assignment that can be dropped. A letter d is drawn next to a dropped score.
■ Not for grade. The assignment will not be included when determining grades. It can be used for recording items such as 

whether a progress report has been returned. It can also be used to temporarily turn off a group of assignments so that they 
do not influence the overall grades. This is best done from the assignment chart.

■ (-)Negative Points. A score entered for a student will decrease the number of points the student has earned without 
decreasing the number of points possible, causing the average to go down. Students without scores are unaffected.

8 Select the Display Scores option. 
Use this to set whether the scores will appear as scores, percents or grades in the score chart. A pop up menu in the score 
chart (above-left of the first score) can override this setting.

9 Select the Progress Report option. 
Progress report options include the following items:

■ Include Assignment. The assignment will be included on every progress report whether the student has a score or not.
■ Include if Student has Score. The assignment will be included only if the student has a score. This option allows you to add 

columns to your score chart that only apply to one or some students. If you use this for all assignments, a transfer student’s 
progress report will not show assignments prior to the transfer.

■ Exclude Assignment. The assignment will not be included in any progress report. 

10 (Optional) Enter text in the Note field. 
Text could include the assignment objective or purpose. It can also be used in conjunction with custom filters to allow you 
to show or hide the assignment based on any criteria that you choose.

11 Select Next Assignment >> to move to the next assignment, if any. Then select Done.
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Copying Assignments to other Classes
Whenever possible, copy assignments from one class to another because it is faster and ensures that the assignments are 

identical. Choose Copy->Assignments from the Tool menu or click the Copy Class Data tool  and select the Assignments 
tab. In the upper-left list, select the class to copy from. In the lower-left list, select the class(es) to copy to. Select the 
assignments you wish to copy and click Copy. 

Use caution in copying: you might accidentally copy items that you don’t want copied or copy items to the wrong 
classes. 

Changing an Assignment Record
At any time, you can view, edit or add data to an assignment record. You may wish to modify the name, change the category or 

make some other changes. To make changes, choose Records from the Chart menu or click the Records tool . Click the 
Assignments tab and make the desired changes.

Changing the Order of Assignments
Easy Grade Pro gives you complete control over the order of assignments in a class. There are three general ways to change 
assignment order: sorting, dragging and editing. You can sort your assignments by date, category and name using the items in 

the View menu. You can also sort assignments by date using the Sort tool  on the tool bar. In the score and assignment 
charts you can change assignment location simply by pressing on the assignment’s name and dragging up or down. 

Basic editing can be used to move one or a group of assignments simultaneously. This works in both the score and assignment 
charts but is illustrated below using the assignment chart. 

1 Click the row number of the assignment to be moved.
After clicking, the assignment’s row will be highlighted. You can select more than one row if you press on the row number 
and then drag up or down. 

2 Select Cut from the Edit menu.
The row(s) will be removed and placed on the computer's clipboard.

3 Select the row where you would like the assignment(s) to be by clicking on a single row number.
You may select any currently used row or the row immediately following the last assignment in the current class, in another 
class or even in another gradebook.

4 Select Paste from the Edit menu.
The row(s) will be pasted into the list. All assignments from the selected row on down will be moved to make room for the 
pasted assignment(s).

Deleting an Assignment
To delete an assignment using editing techniques, select the assignment’s column number (score chart) or row number 

(assignment chart). Then click the Delete tool , press the delete key or choose Clear from the Edit menu. If you need to 
delete a series of assignments, press on the first number and then drag to the last. To delete an assignment using the Delete 
window, choose Delete Assignment from the Tool menu. Select the assignment(s) to be deleted from the list. Click Delete.
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How a Student’s Overall Grade is Calculated
At times you may wish to confirm Easy Grade Pro’s calculations. Possibly, this will be at a student’s or parent’s request. The 
information here explains with examples how overall percents are calculated. We’ll use the same five assignments in all examples 
as shown. 

Assignment Data Student Data
Name Max. Score Points Possible Score % Points Earned

Quiz 1
Quiz 2
Hwk 1
Hwk 2
extra credit hwk

10
15

8
12
---

100
100

50
50
---

6.5
12

8
9
2

65%
80%

100%
75%

---

65
80
50

37.5
2

Note that the Max. Score and Points Possible are taken from the assignments’ records; the % is found by dividing the score by 
the maximum score; and the Points Earned is found by multiplying the percent by the points possible. By the way, you can 
print a progress report for a student with all these values and more. (In the Report Options window for the progress report, be 
sure to turn on the Points Earned options for the Grade Summary and Assignment Charts.)

Example 1: A Simple Situation
If category weighting is not used, Easy Grade Pro tabulates the number of points the student has earned and divides this by the 
sum of the points possible on all graded assignments. If there are extra credit or negative points, then these are added to the 
points earned value before dividing. Here’s how:
1. Sum the points earned: 65 + 80 + 50 + 37.5 + 2 = 234.5
2. Sum the points possible: 100 + 100 + 50 + 50 = 300
3. Divide points earned by points possible: 234.5 / 300 = 78.17%

Example 2: Category Weighting
If category weighting is used, Easy Grade Pro goes through the calculations in Example 1 for each category. Then it weights the 
categories and combines them to produce the overall percent. In this example, the quiz category is weighted 60% and 
homework is weighted 40%. 
1. Determine the quiz category percent: (65+80) / (100+100) = 72.5%
2. Determine the homework category percent: (50+37.5+2) / (50+50) = 89.5%
3. Weight the categories: ((72.5% x 60%) + (89.5% x 40%)) / (60%+40%) = 79.3%

Example 3: Combining Term Grades
What if one or more prior-term classes have been combined with the current class? What happens depends on whether the 
classes have been combined using points or weights.

If the terms have been combined using points, then it is a simple matter to sum all the points. For example, if the student above 
earned 234.5 out of 300 points this term and 222 out of 250 points last term, the student will have earned 456.5 out of 550 points 
or 83%.

If the terms have been combined using weights and each term is worth 50% of the grade and the student earned a 79.3% this 
term and an 88.8% last term, then the student will have earned ((79.3% x 50%) + (88.8% x 50% )) / (50% + 50%) or 84.05%.
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8
The Score Chart

The score chart is where you’ll likely spend most of your time while using Easy Grade Pro. The posting of student scores can 
be tedious and time-consuming, but Easy Grade Pro provides numerous tools to make this task both fast and easy. This 
chapter describes a variety of ways to enter scores, to add notes and to manipulate data in the score chart.

Entering Scores by Typing
■ You can enter numbers from zero through 999.9.
■ After typing a score, press return, enter or the down arrow key to move to the next cell. 
■ To move in another direction, use the tab, up, left and right arrow key.
■ Macintosh: To jump to any student, press control and the first letter of the student’s name as it appears in the chart. Press 

them again to jump to the next occurrence.
■ To repeat a score (copy the score from the cell above), press the = key.
■ To delete a score, press the delete key. To delete a group of scores, first select the cells by dragging from the first to the last, 

then press the delete key.
■ You can type the single-key shortcuts for special scores if the Allow typing of Special Score Shortcuts  option is selected in 

the Gradebook Options window.
■ You can directly type grades and special scores if the Allow typing of Grades and Special Scores option is selected in the 

Gradebook Options window.
■ You can switch between these two typing modes using the small menu to the left of the row of grades on the tool bar 

(shown below). 

■ If you type a score that is greater than the maximum score or if you change a non-blank score, a warning may appear if the 
warning options are turned on in the Gradebook Options window. These warnings can help minimize mistyping.

Blank Score Cells
In Easy Grade Pro, a blank score has no value and is completely ignored when calculations are made. This allows you to 
add assignments in advance without affecting calculations. It also allows you to add assignments that are not meant for 
all students. An assignment can be excluded from progress reports when scores are blank using an option in the record 
window for the assignment. Blank scores can be included in filters such as the Show Blanks filter which hides all scores 
but blank ones. Don’t think that you’ll have to spend a lot of time filling in all the blanks with zeros; the Change Scores 
tool  can easily change all blanks (or just some blanks) to zeros (or something else) with just a few clicks.
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Entering Scores by Grade Clicking
You can enter scores by clicking on grade and special score buttons on the tool bar. The tool bar (or palette) must be visible. If 
not, choose Show Tool Bar from the Edit menu. If the grade buttons are not visible on the tool bar, click the triangle (shown 
below) to the left of the class menu. To display grades, special scores or both, use the menu to the left of the first grade. The 
grades that are displayed are always based on the scale assigned to the student or the scale assigned to the category.

When a grade is clicked, Easy Grade Pro will enter a numeric score in the score cell based on the click value of the grade. The 
click value is set automatically to 100% for the top grade and to the middle of the grade’s range for the rest. You can edit the 
click values for any grade scale in the Scale view of the Class Options window.

Entering Scores using Fill Down and Fill Across
To fill down means to copy a score from a starting cell downwards to the last row. It is typically used when most of the scores 
on an assignment are the same. If there are a few scores that are different, they can be changed after filling down. Begin by 
selecting the starting cell. Type the score but do not press enter or else the score will no longer be selected. Finally, select the 

Fill Down tool  or choose Fill Down from the Tool menu.

To fill across means to copy a grade from a starting cell across to the last column. It is normally used on a transferring student 
to apply the transfer grade to all assignments given prior to the transfer. Note that the grade, not the score, is filled across. Each 
assignment may have a different score but each will have the same grade value. Begin by selecting the starting cell. Type the score 

but do not press enter or else the score will no longer be selected. Finally, select the Fill Across tool  or choose Fill Across 
from the Tool menu. An assignment whose special status is Not for grade is ignored during filling across.

Entering Scores directly from Student Papers
By using the Find tool’s continuous search mode, it is easy to enter scores directly from student papers -- even if the papers 
consist of an unsorted mixture of assignments, classes and students. Here’s how:

1 Open the Find window.
There are two ways: 1) click the Find tool , or 2) choose Find from the Tool menu.

2 Choose by Name from the menu and select Use Continuous Search Mode.
By selecting the continuous search mode, Easy Grade Pro will reopen this window after each score is entered.

3 (Optional) If the stack of papers includes several classes, select Search all current-term classes.
If this is selected, Easy Grade Pro will search other classes if the student cannot be found in the current class. If you have the 
same student in multiple classes, you may wish to search using some other search field that you’ve set up for this purpose.

4 Click Exit or press enter to exit this window.
The window will close. You are now ready to begin entering scores.
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5 Select the score cell for the first paper. Enter the score and press enter.
The Find window will reopen.

6 Enter a few letters of the name from the next paper.
After typing a few letters of the last name (or first name if the students are displayed with the first name before the last), Easy 
Grade Pro will attempt to complete the student’s name for you.

7 Click Find or press enter.
Easy Grade Pro will find the student and select the score cell in the same column as before. If the wrong student is selected, 

edit the search text and click the Find Again tool , choose Find Again from the Tool menu or simply press enter twice to 
find to the next match. If the selected cell is in the wrong assignment column, use the arrow key to switch columns.

8 When you are done, deselect Continuous Search Mode and click Exit.
The window will close and remain closed.

Editing Scores
Easy Grade Pro allows you to use basic editing (cut, copy, and paste) on one or more scores. This allows you to copy scores 
from another program, such as a spreadsheet, into your gradebook. This also allows you to easily move a group of scores from 
one location in the chart to another. Maybe you entered some scores only to realize later that you were off by one student or 
assignment. This section explains how to move a group of mistyped scores.

1 Select the group of scores by pressing on the first score and dragging to the last one.

2 Choose Cut from the Edit menu.
The scores will be removed and placed on the computer's clipboard.

3 Select the new score cell where pasting will begin and choose Paste from the Edit menu.

Using the Change Scores Tool
The Change Scores tool allows you to change all occurrences of a score to another score. It can be used to change all blank 
scores to zeros, or to change a score that counts as missing to something else. It can also be used to change all automatically 
dropped scores to manually dropped scores (dr) allowing you to drop more than one score per student. You can choose to 
change scores on all assignments, displayed assignments or just selected assignments.

1 Open the Change Scores window.
To open this window, either select the Change Score tool  or choose Change Scores from the Tool menu.

2 Use the first menu to select the score to change.
If you select Text Score--> from the menu, be sure to type a numeric score.

3 Use the second menu to select the new score.
As before, if you select the last item in the menu, be sure to type a numeric score.
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4 Select the range of assignments to be included.
If you choose All displayed assignments, any assignments hidden by filters will not be affected. Choose Selected 
assignments ONLY if you selected at least one assignment column before opening the window. To select a column, click on 
the column number at the top. Drag left or right to select more than one column.

5 (Optional) If you want ungraded assignments to be included, select the Include “Not for Grade”  item.
The “Not for Grade” attribute is set in the record window for an assignment.

6 Click the Change button.

Adding Footnotes to Scores
A footnote can be attached to a score to provide additional meaning about the score. Perhaps the assignment was turned in 
early or late. You can attach one of seven custom footnotes to a score. When a score has an attached footnote, a small number 
appears in the lower-left corner of the score cell. The actual text of a footnote can appear with the score in a student progress 
report. To define or edit a footnote, use the Class Options window. There are several ways to attach or remove a footnote:

■ Double-click the score to open the Score Note window and select a footnote. To delete a footnote, select the first list item.
■ Select the score and press option and a number from 1 through 7 (Macintosh). Press option-0 to delete a footnote.
■ Select the score and click on a footnote in the Mini-summary palette. If the palette is not visible, choose Show Mini-sum. 

from the Edit menu. Use the menu on the palette to display the list of footnotes. Select the first list item to delete a footnote.
■ Right-click (Windows) or control-click (Macintosh) in a score cell and select the footnote from a contextual menu. 

Adding Notes to Scores
In addition to score footnotes, you may attach a unique note to any score. The note can provide some history or clarification 
about a score or the note can be used in place of a score. The note can be for your eyes only or can be included in student 
progress reports next to the score. A note can be a few words, sentences and even pages in length. A note can be stored, reused 
and can even include variables that are filled in automatically when the note is pasted into the window. A 50,000-word dictionary 
is available to help ensure the note is error-free. To open the score note window, double-click on a student’s score cell, click the 

Open Score Note tool  or choose Open Score Note from the Tool menu.

Use the menus at the top to choose the student, the assignment and the note format. If you choose the first format Note is for 
teacher; footnote is for student, you also may attach a footnote to the score which can be included in a student progress 
report. The second format Note is for student and the third format Note is for student in place of score don’t allow footnotes 
because a score in a progress report cannot have two notes attached.
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  There is a sample score cell in the upper-left corner of the window which shows how the score cell 
changes based on what you do. If you add a note using the first or second formats, a small, black box appears in the upper-right 
corner of the cell. A footnote number may appear in the lower-left corner when using the first format. If you choose the third 
format, a picture of a notebook covers the score cell indicating that a score is not allowed.

The small icon of a clipboard  in the window is a menu that allows you to copy the selected part of your note to the 
Clipboard Text window, paste a stored note or open the Clipboard Text view of the Gradebook Options window where you can 
create or edit a note to be used later. Refer to Gradebook Options: Clipboard Text on page 32 for help. By clicking the Spell tool 

, the Spell Check window will open. For help in using this window, refer to the section Using the Spell Check Window 
on page 34.

Curving an Assignment
Occasionally, a set of scores on an assignment may have a distribution that is not desired. For example, maybe the assignment 
was too difficult causing the majority of students to do very poorly. Whatever the case may be, Easy Grade Pro allows you to 
curve or alter the distribution of scores to match your goals. 

Because curving can be complex, this section explains how to curve using an example. In this example, a group of twenty 
students was involved in a computerized treasure hunt. Although the maximum score possible was 950, the students earned 
scores ranging from 50 to 925. Using the teacher’s normal grade scale, fourteen students failed, five earned D’s and one 
earned an A+. This activity requires curving! Here’s how:

1 Open the curve window for the assignment.
To open the window, first select the assignment. Then click the Curve tool  or choose Curve Assign. from the Tool menu. 

This window provides a row of statistics at the top. Below this is a row of menus that are used to prepare for the curving. In 
the middle is a graph where the actual redistribution of grades occurs. The Shift buttons at the bottom can help with this 
task. When ready, the Curve button is clicked to initiate the actual curving on the score chart.

2 From the Curve menu, choose Create New Curve.
A window will open where grades can be listed and given values. Each value is not a minimum or cutoff percent like in a grade 
scale; rather, each is the percent of the assignment’s maximum score that a student will receive for any given grade. To keep 
things simple, the teacher decided to create a scale with only five grades. A student who ends up with an A will get 100% 
of the maximum score, a B will earn 85% and so on. Be sure to give the curve a name. Then click the Create button. Note: if 
you already created a curve for another class or assignment, you can select it instead.

3 From the Interval menu, choose the desired interval for the graph.
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The interval affects curving because all the scores in an interval are curved as a group. In general, you should use an interval 
value in proportion to the range of students. Because the range of students is so great in this example, the teacher chose 
an interval value of 10. Notice that the graph interval marks are all multiples of 10.

4 From the Size menu, choose the desired screen width for each interval.
The size does not affect curving -- only the readability of the graph. The teacher chose the smallest size to minimize the 
length of the graph. 

5 Change the distribution of grades by dragging the vertical lines left and right to the desired locations 
and by clicking the two Shift buttons.
This is the step in which you control which students get which grades. The teacher moved all the lines towards the left so 
that most students earned A’s, B’s and C’s. 

There are special tools hidden in the graph as follows:
■ To show the true percent or the curved percent of any grade bar, press on the grade label at the top of the bar. A menu will 

appear with options.
■ To see the names of students and their curved percents, click on any box in the graph.

6 When ready, click the Curve button.
After clicking, Easy Grade Pro will give each student a score based on the percents in the curve scale. A new assignment 
column will be added to the score chart immediately after the curved assignment. The original column will still be present 
but will be set to non-grade status and exclusion from progress reports. If desired, it can be deleted but may be kept as a 
record of the original scores or used to re-curve the assignment later.

Displaying Scores in Different Ways
Scores in the score chart can be displayed as raw scores, percents and grades. Although an assignment’s display is set in its 
record window, you can override this setting so that all are displayed as raw scores, percents or grades. Use the small menu on 
the score chart found next to the intersection of the first student row and the first assignment column.

Press here

Locking and Curving the Overall Grade
You may override automatic calculations of overall grades in two different ways: locking and curving. To lock an overall grade 
means to enter a new percent for a student. Typically, this is something that is only done at the end of a term because, once a 
grade is locked, it does not change even when scores are added. A padlock appears in the score chart next to the overall grade 
for any student whose grade has been locked. 

To curve an overall grade means to enter a percentage offset for the student using a '+' or '-' and the offset (i.e. '+5.0' or '-5.0'). 
The grade does not become locked; rather, the grade is adjusted by the offset amount every time it is calculated. A '+/-' symbol 
appears in the score chart next to the overall grade for any student whose grade has been curved. Locking and curving can be 
done only in the Lock/Curve Grade window. To open the Lock/Curve Grade window, choose Lock/Curve Grade from the Tool 
menu, or click on the small square after the student's grade in the score chart. 
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Guidelines 
■ To lock a student's grade, type the new percent in the Locked/Curve% column.
■ To curve a grade, type a '+' or a '-' and the offset percent in the Locked/Curve% column.
■ To change the grade scale, press in the Grade and Scale column.
■ To unlock a grade or to remove a curve offset, select the percent and press the delete key.
■ After the window is closed, a small +/- icon will be drawn next to a curved grade and a small padlock will be drawn next to a 

locked grade (shown below).

Adding Extra Credit
Extra credit can be added in three different ways: by curving the overall grade (discussed in the previous section), by increasing a 
score on a normal assignment and by adding an extra credit assignment.

Giving Extra Credit by Increasing a Score
With this method, simply add the desired number of points to the student’s score. Typically, this will cause the student to 
receive a score that is greater than the maximum score for the assignment. When this happens, Easy Grade Pro may display a 
window asking if this is a mistake.

Giving Extra Credit by Adding an Assignment
An assignment can be dedicated to extra credit by setting its Special Status attribute to Extra Credit in the record window for the 
assignment. Sometimes it can be difficult to know what score to enter for a student on an extra credit assignment. It may be very 
helpful to open the student’s summary window by double-clicking on the student’s row number and clicking the green percent 
tab. This displays the number of points possible and points earned by the student overall, in each category and on individual 
assignments. If you know what impact you would like the extra credit to have, the values in this window can help determine the 
score that should be typed.

Dropping Scores
Scores can be dropped in two different ways: manually and automatically. To drop a score manually, simply enter the special 
score dr into a score cell. This built-in special score stands for drop and has no value. 

To have Easy Grade Pro drop scores automatically, you must choose the Can be Dropped special status attribute in the record 
window for one or more assignments. Whenever a score is entered, Easy Grade Pro goes through a series of calculations to 
determine which score, if any, to drop for the student. It only looks at scores on assignments with the Can be Dropped status. 
Which score is dropped? Surprisingly, it is often not the lowest score because the lowest score may be on an assignment with 
little point value or in a category with little weight. The score that is dropped is the one that, by being dropped, causes the 
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student’s average to increase the most. When a score is dropped, a small letter d is drawn in the upper-left corner of the score 
cell. As scores are entered, the d may move about, disappear and reappear.

Because Easy Grade Pro drops scores in real time (as scores are entered), it can only drop one score automatically per student. 
However, it is possible to have more than one score automatically dropped if you use the Change Scores tool. Here’s how:

1 Set the Special Status option to Can be Dropped on two or more assignments.
You can set this option in the record window for an assignment. Double-click on the assignment’s name to open this 
window. You can set this option for several assignments using the assignment chart.

2 Open the Change Scores window.
To open this window, either select the Change Score tool  or choose Change Scores from the Tool menu.

3 Set the first menu to Dropped Score and the second menu to dr.
This will cause Easy Grade Pro to change all automatically dropped scores to manually dropped scores.

4 Click Change.
The small letter d is replaced by dr, and a new automatic drop calculation is made.

Adding Columns to Show Special Data
Up to eight columns of data can be included in the score chart before the first assignment. These can be set to display student 
name, grade, class rank, points, term grades, attendance and a variety of other things. In addition, the columns can be resized 
and arranged in any order.

Guidelines
■ The titles of the columns are actually menus that pop up and show lists of all the items that the column can display. 
■ To add a column, press on a column title and choose Add NEW Column. A new column will appear to the right. Press on the 

new column’s title to bring up the menu but, this time, choose the desired content for the column. 
■ To delete a column, press on the column title and choose Delete THIS Column.
■ To move a column to a new location, press on any data beneath the column’s title. The cursor will change to a hand. Drag 

left or right. Note: this does not work with the column that contains student names because this location is used to drag a 
student’s row up or down. To move the student name column, drag the other columns around it.

■ To resize a column, press on the vertical line after the title and drag left or right.
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Resizing the Assignment Title Region
The height of the rotated assignment titles can be customized. If your assignments’ titles are long, you can give them more room 
in the score chart. If the titles are consistently short, you can take away some space so that more student rows can be shown 
on your screen. To resize the column height, press and drag the thick, horizontal line below the assignment titles up or down. 

Filtering Students, Assignments and Scores
Easy Grade Pro provides extensive tools for filtering the display of students, assignments and scores. Filters allow you to show 
and hide items so that your chart shows just what you want to see. Several reports allow you to include all data or just the data 
displayed in a chart. The rest of this section explains the different types of filters.

The Show Selected and Hide Selected Filters
After selecting one or more students or assignments (by clicking on row and column numbers and dragging), choose Show 
Selected or Hide Selected from the View menu to display just the desired items. This can be used to hide all assignments but the 
current ones or to show just failing students after sorting by grade. You may need to use Hide Selected more than once to show 
just the items you want. Choose Show All to “unhide” all items (except for students whose status is WD Hidden).

Show One Student menu

Custom Filters menu

Show One Assignment menu

The Show One  Filters
Above the first row number in the score chart is a small menu called the Show One Student menu that allows you to select and 
display a single student only. To the left of the first column number is a second menu called the Show One Assignment menu 
that allows you to select and show one assignment only. Both menus (shown above) cause Easy Grade Pro to switch to the 
show one mode in which the function of the scroll bars changes. The scroll bars scroll the students or assignments one at a 
time drawing each in the first position.

One of the best times to use the show one mode is during conferences when the privacy rights of students must be protected. 
The Find tool works in the show one mode allowing you to find any student or assignment and still never have more than one 
item visible.
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The Show One Assignment menu also has category filters which allow you display only assignments in a single category. This is 
great when assessing student performance in individual assignment categories.

The Custom Filters
To the right of the last visible column number is a special menu which holds filters to show and hide students, assignments and 
scores simultaneously. For example, the Show Missing filter displays only students with missing work, assignments with 
missing scores and the missing scores. Custom filters can also be selected using the View menu. Note: to select a filter using the 
keyboard, you must press shift-command-filter key (Macintosh) or shift-control-filter key (Windows). All of the filters in this 
menu can be edited, deleted and reordered. The next section explains how to create custom filters.

Creating Custom Filters
You can create filters to show just the students, assignments and scores you want to see. Filters can be used in all charts but 
the seating chart. Before creating your own filter, you should study the built-in filters to see how they were set up. Choose Edit 
filters from the View menu. In the window that appears, select a filter and click the Edit button.

To create your own filter, first open the Filters window using the Filters tool  or by choosing Edit Filters from the View menu. 
Click the New Filter button to open the New Filter window (shown below).

Guidelines
■ Put a short but clear name in the Filter Name field at the top. It will be placed in the View and Custom Filters menus and can 

be selected in all charts but the seating chart. 
■ (Optional) Use the Keyboard menu to select a unique key to be used with shift and command (Macintosh) or control 

(Windows) to activate your filter.
■ Your filter may contain individual filters for students, assignments and scores. Use the tabs to switch between these three 

parts.
■ Each filter consists of from one to four rules. The rules can be connected using and and or found in the small menus to the 

left of all rules but the first. And connects two rules so that they must both be met while or allows either rule to be sufficient.
■ Each rule consists of a subject and a condition that are selected using menus. Depending on the type of condition, the rule 

may or may not have an object that must be completed by typing letters or words into a text field. Case is not important.
■ Be sure to test your filter; you may find that it needs refinement to work properly.
■ Note: filters have no effect on students whose status is WD (hidden).
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9
The Other Charts

Although the score chart is the most comprehensive of the five charts, the attendance, seating, student and assignment 
charts share many of its tools and offer a variety of new ones. This chapter describes the other charts. Be sure to refer to the 
Quick Reference sheets in Chapter 2 for detailed, concise information on these charts.

Tools Common to all Charts
Many of the tools and techniques found in the score chart can also be used in the other charts. Some of these are...
■ After typing a score, press return, enter, or the down arrow to move to the next cell. 
■ To move in other directions, use the tab, up, left and right arrows.
■ Macintosh: To jump to any student (or assignment), press control and the first letter of the item’s name. Press the keys 

again to jump to the next occurrence and so on.
■ Right-click (Windows) or control-click (Macintosh) on a student or assignment name to display a contextual menu.
■ To repeat an item (copy the data from the cell above), press the = key.
■ To delete an item, press the delete key. To delete a group of items, first select the cells by dragging from the first to the last, 

then press the delete key.
■ Fill down can be used in all charts but the seating chart. Fill across can be used in the score and attendance charts.

■ The Find tool  can be used to find students and assignments in any view.
■ Editing (cut, copy, paste, clear) can be used in all charts.
■ The order of items (students, assignments, seats, furniture) can be changed by sorting, dragging and editing in all the charts.
■ Custom filters can be used in all the charts but the seating chart. The one-student and one-assignment views can be found 

in most charts.

The Attendance Chart
The attendance chart allows you to view, record and edit attendance data for a single term. It uses a format very similar to the 
format found in the score chart. Before attendance data can be recorded, a class must have calendar and attendance options set 
in the Class Options window. Refer to the sections Class Options: Attendance Categories and Class Options: Calendar (page 
26) for help. Use the following information to guide your use of the attendance chart.

■ Each column represents a single date in the calendar for the class. No-school days are grayed and cannot be selected. When 
entering attendance data, Easy Grade Pro will automatically scroll over all no-school days. 

■ Note that each column number indicates the number of days into the term.
■ You can enter the one- and two-character attendance codes by typing, clicking on marks on the tool bar, by filling down and 

across, or by using the Find tool .
■ To add a note to an attendance mark, first double-click on a cell to open the student note view of the Summaries window. 

Tools in this window allow you to quickly add dates.
■ Elementary teachers may choose to take attendance in a single class. The multi-class progress report will find the class with 

the greatest number of attendance marks for a student and use it when completing the attendance portion of the report.
■ To filter the dates displayed in the chart, use the menu to the left of the first column number. You can choose between 
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showing all days, the current day, current week, current month or a selected range of dates. If the current day, week or 
month is selected, the actual dates will automatically change at the right times.

■ To quickly hide all dates but one, click on the date you wish to view. When only one date is visible, you may use the 
horizontal scroll bar to scroll through all dates while keeping only a single date visible at a time. To return to the normal 
view, click on the date again.

■ You can use the Export Attendance tool  to export one day’s attendance over a network. (See page 81).
■ The height of the rotated date titles can be customized. You can raise the titles so that more student rows can be shown on 

your screen. To resize the title height, press and drag the thick, horizontal line below the titles up or down. 

The Seating Chart
You can set up a seating chart to match your classroom, furniture included. Students can be sorted into the seats randomly or 
in a variety of patterns. The arrangement of seats can be copied to and from any class. In addition, attendance can be taken 
directly from the seats. This section explains how to do all of this.

Setting up a seating chart
The first time the seating chart is entered, Easy Grade Pro automatically places the first 128 students into seats using a built-in 
arrangement. Most likely, this arrangement does not match your situation. Use the guidelines below to create your own 
structure.

■ Use the Seat Format Options in the Class Options window to set the shape, size, name format and attendance format of all 
seats in a class. See Class Options: Seat Format on page 29 for help.

■ To move any seat, simply drag it to the desired location. 
■ To swap two students, drag the first seat on top of the other. If you are swapping students and one seat is rotated left or 

right and the other is not, be sure to drag the upper-left corner of the first seat to the upper-left corner of the second. The 
names and colors will be swapped; the orientation of the seats will not be swapped.

■ To move or swap a group of seats, first select the seats by clicking on each one while holding down the shift key. Another 
way to select multiple seats is by dragging a rectangle that encloses or touches all the seats. To move the group of seats, grab 
one and drag. All the selected seats will move with it. 

■ To deselect all selected seats, simply click on an empty place. 
■ Use the items in the View menu to sort seats randomly or to sort using one of eight patterns. The patterns use the order of 
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the students in the Records window when placing the students into seats.

■ To randomize your students, click the Sort tool  or choose Randomly from the View menu. This tool, when used only 
once, ensures that every student moves to a new seat.

■ To add furniture to a chart, choose Add Furniture from the Tool menu or click the Add Furniture tool .
■ Furniture can be copied and pasted using the tools in the Edit menu.
■ To set the color, rotation or locked status of a seat, double-click on the seat or select the seat and choose Seat Format from 

the Tool menu. The Seat Options window will open with options. 
■ A seat that is locked cannot be moved or sorted.
■ To change the size, drag in the small rectangle in the lower corner of the item. To set the format or name of a piece of 

furniture, double-click on the item or select the item and choose Seat Format from the Tool menu. The Furniture Options 
window will open. 

■ To delete a piece of furniture, select the item and click the Delete tool  or press delete.
■ The structure of a seating chart and its furniture can be copied to and from classes within a gradebook. Choose Copy Seats 

from the Tool menu. When furniture is copied from one class to another, it always replaces any furniture that the class might 
already have.

Taking attendance in a seating chart
Before a seating chart can be used for attendance, the class must have a calendar and attendance categories, and the seat format 
must be set to allow attendance. These can only be set in the calendar, attendance and seat views of the Class Options window. 
Choose Class Options from the Edit menu to open this window. Once these have been set, it is easy to take attendance from 
the seats. Use the guidelines that follow.
■ The current date, if it is within the calendar for the class, will be displayed in the lower-left corner of the window. Use the Set, 

+ and - buttons to switch to other dates. If the date is not the current date, it will be grayed. Attendance can be taken on 
any day.

■ One way to take attendance is to use the menu in the upper part of each seat. A second way is to select seats and then click 
on an attendance code on the tool bar. No matter how attendance is taken, the attendance code is displayed in the seat.

■ You can use the Export Attendance tool  to export one day’s attendance over a network.

The Student Chart
The student chart and the Records window (students view) have a lot in common. Both display student names, ID numbers, 
gender, status, grade scale and twelve custom fields. While the Records window displays one student at a time, the student 
chart can display all students together. If you have a lot of student record data, the student chart is the better place to work 
with the data. Many of the tools found in the other charts, such as fill, cut and paste, find and filters are also available here. 
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The student chart does display some data not found in the Records window. At the right end of the chart, there are six columns 
with student comment numbers. Although it is easier to enter student comments in the Summaries window, the student chart 
can be used to view and edit groups of comments.

Use the following information to guide your use of this chart.
■ Data can be entered into any cell except the cells in the column of student names. 
■ The gender, status, language, and scale fields actually are menus that appear and can be used to select data.
■ The titles of the last twelve columns can be changed in the Records window. To open this window, double-click in a cell 

below the title.
■ To change the order of the columns, press on a column’s title. The cursor will change to a hand. Using the hand, drag the 

column left or right to the desired location. 
■ To change the width of a column, move the cursor until it is over the vertical line to the right of a column title. The cursor will 

change to a spreader bar. Press on the line and drag the line to the desired location.
■ Like the score chart, you can move rows up and down by dragging on student names. Students can be filtered in the normal 

way so that only the desired students are visible. Text can be filled down, cut, copied and pasted from one column to 
another.

The Assignment Chart
Just as the student chart is related to the student view of the Records window, the assignment chart is related to the 
assignment view of the Records window. Both display assignment names, maximum scores, points, dates, categories, special 
attributes, display settings and notes. While the Records window displays one assignment at a time, the assignment chart can 
display all assignments together.

When entering numerous assignments, it is easy to set the wrong category or enter the wrong number of points. The 
assignment chart can be used to help ensure that your assignment settings are correct, because it allows quick inspection of 
your assignments.

Since the assignment chart is so similar to the student chart, refer to the prior section for guidelines in using this chart.
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10
Security

Electronic data is susceptible to a variety of problems: unauthorized access, software conflicts, hardware breakdowns, etc. 
This chapter first explains how to prevent unauthorized access to a gradebook. It then presents a plan to ensure that if a 
problem occurs, student data will not be lost. Finally, it shows how to use the TA mode to protect a gradebook and the 
privacy rights of students when others assist in the managing of student data.

Locking a Gradebook
Easy Grade Pro allows a gradebook to be automatically locked whenever it is closed. It also allows a gradebook to be manually 
locked while it is still open but left unattended. A gradebook that is locked cannot be viewed unless the correct password is 
entered (shown below). To set the teacher password and lock option, use the Security view of the Gradebook Options window 
which is opened from the Edit menu. Refer to the section Gradebook Options: Security on page 31 for help. To manually lock a 

gradebook, choose Lock from the File menu or choose the Lock tool .

Forgot the Password?
If you are unable to get back into your gradebook because you don’t remember the password, don't worry -- 
there is a way. First double-check all of the passwords you’ve used in the last year. If you still can’t get in, contact 
Orbis Software. See the appendix for the email address, phone number and times in which technical support is 
available. If you are a registered user, you will be given a one-day password that will allow you to open the 
gradebook and set a new password.
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A Plan for Securing your Student Data
Because computers are prone to problems, it is imperative to follow a plan to protect your gradebook file and student data. For 
greatest security, it is best to maintain student data in different ways and at different locations. Here is a simple 3-part plan that 
offers great security:

■ Part 1: Daily Backups. Make a copy of your gradebook every day that you make changes. Save your backup to the 
server, your computer’s hard drive or another convenient volume. One day’s backup can replace a prior day’s backup copy. 
For greater security, use the name of the day of the week for your backup (Monday, Tuesday, etc.) and let one day’s backup 
replace the backup from the prior week.

A backup copy of a gradebook is like an insurance policy -- it’s something that you hope you never have to use. Don’t 
get your gradebook and its backup copies confused, and don’t work on a backup of your gradebook unless there is a 
good reason. Just as you would not use a photocopy of your paper gradebook for data entry, don’t use a backup copy 
of your Easy Grade Pro gradebook for data entry.

■ Part 2: Printed Reports. Produce printed reports for each class on a weekly basis. 

■ Part 3: Archived Backups. At least twice a month and at important times, make a backup copy of your gradebook to a 
floppy disk or other removable media and store it away from your site. Do not erase any copy until you are absolutely sure 
the data is no longer needed.

To make a backup of your gradebook from within Easy Grade Pro, choose Save Copy from the File menu or select the Save 

Copy tool .

Using the TA Mode
The TA or teacher assistant mode is designed to allow someone other than the teacher to enter student data, while protecting 
the gradebook and the privacy rights of students. When the TA mode is on, many student data fields are grayed and access to 
menus and tools is limited.

It is suggested that, before turning on the TA mode, you use assignment and calendar filters to hide all columns except for those 
to receive data from the TA. 

To turn the TA mode on, choose TA Mode from the File menu or select the TA Mode tool . The menu item becomes 
checked. If the teacher and TA passwords have not been set, a prompt will appear directing you to open the Gradebook 
Options window where the passwords and the TA access privileges can be entered. TA access options include entering data 
into charts, switching charts, switching classes, adding assignments, copying data to other classes and printing reports. Refer to 
the section Setting Security Options on pages 31 for help. To turn off the TA mode, choose TA Mode as before. The password 
window will appear and the teacher password must be typed to regain full access.
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11
Summaries

Easy Grade Pro provides two powerful tools for analysis of student performance: the Summaries window and the Mini-
Summary window. Each can be a tremendous aid in understanding the performance of students individually, on specific 
assignments, and as a class. This chapter explains where to find and how to use these tools.

Using the Summaries Window
The Summaries window is one of the most important tools in Easy Grade Pro. There are graphs, lists, calendars, notes and 
comments. You can quickly jump to any view, class, student or assignment for thorough analysis. 

Use these tabs to switch 
between the class, student 
and assignment views.

Use these tabs to switch between the 
graph, scores, attendance, notes and 
comments views.

To switch to 
any class, 
click here.

To switch to 
any student, 
assignment or 
class, use 
these.

There are several ways to open the Summaries window:
■ Select Summaries from the Chart menu. 

■ Click the Summaries tool . Select a student, assignment or seat first before clicking to view a summary on the item.
■ Double-click a row or column number in any chart (except for the seating chart).
■ Right-click (Windows) or control-click (Macintosh) on a student or assignment name and choose View Summary from the 

contextual menu that appears.

To switch between the different views, use the three tabs on the left (Classes, Students, Assignments) along with the five tabs on 
the right (graph, scores, attendance, notes, comments). The menus and buttons below the tabs allow you to quickly switch to 
different classes, students and assignments. Whenever you use the class menu to switch classes, Easy Grade Pro will attempt to 
find the same displayed item in the new class. This allows you to quickly switch classes to see how a student has done in other 
classes or to see how other classes have done on an activity.
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Student Summaries
There are five student views in the Summaries window. Three of them provide information about a student and two allow you to 
enter notes and comments about the student. All of the information in these views can be included in progress reports.

Use the Student (Line) Graph to view changes in a student’s performance over the course of a term. One line in the graph 
displays the overall grade; you can include up to three additional lines to display performance in different categories. Select the 
Graph Options button to set the categories and colors. The changes you make apply to the current class only. 

Use the Student Grades view to see a complete breakdown of a student’s grade. You’ll find the overall, term, completed work, 
category and assignment grades. Not only are scores, percents and grades displayed, but also points. If you ever need to 
confirm or verify the calculations for a student, the Student Grades view can make the task easy. 

The Student Attendance view displays calendars with attendance data for a student for a term. Attendance totals for the 
current term as well as prior terms are found in a list.

Use the Student Notes view (shown below) to enter notes up to pages in length. Notes can be used to document events, 
record attendance notes and anything else about a student. Notes can be for your eyes only or can be included in reports. Use 

the Clipboard tool  in the upper-right corner of the Student Notes view to store reusable text, to paste stored text and to 
open the Clipboard window where you can design text with variables. These variables are filled in with current student data at 
the time the text is pasted into the summary window. Refer to the section Gradebook Options: Clipboard Text on page 32 for 
help.

 

Use the Student Comments view (shown below) to apply comments to students for progress reports or grade export 
files. There are two lists in this view: the upper list displays the comments that have been applied and the lower list displays the 
available comments. 
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Guidelines
■ To apply a comment, click the item in the lower list. Up to six comments can be applied.
■ To remove a comment, click the comment’s number in the upper list.
■ To change the order of comments in the lower list, press on a comment number and drag up or down.
■ Use the small menu above the lower list to sort or edit the comments. To insert the student’s first name in a comment, use 

the ^ symbol (shift-6). An additional item in the menu allows you to create a plug-in of the comments to make it easy to 
distribute comments to other Easy Grade Pro users. See Using Plug-ins on page 84 for help.

■ Use the small menu above the upper list to erase comments, copy comments from the prior term or copy comments to all 
students in the class.

■ To have up to six comments automatically selected for a student, click the Auto-Select button. To set the rules for the 
automatic selection of comments, press on the arrow to the left of the upper list and choose Edit Auto-select comments. 
The Auto-select Comments window will open (shown below) where the rules for the automatic selection can be entered. 
There are six tabs and under each you can set up to four rules and assign a comment to each rule. Note: Easy Grade Pro 
will select the comment from the first rule under each tab that is true for a student.

Class Summaries
There are four class summary views. Three of them provide information to you and one allows you to enter notes. All of the 
information in these views can be included in different reports. The Class Graph view includes a bar graph showing the 
number of students who have received each grade in the class. Grade and cutoff percents are shown below the bars. To see the 
students that a bar represents, press on the bar; a list will appear. To print one or more class graphs, use the Class Graphs 
report.

The Class Grades view shows a list of students with overall points, percents and grade names for the class. The list is ranked 
from highest to lowest average and provides some statistical information at the bottom. To print this, use the Class Summary 
report.

If you need to view attendance totals by category and student, use the Class Attendance view. Use the menu to choose the 
category to display. To print attendance totals for a class, use the Attendance Summary report.

The Class Notes view, like the Student Notes view, allows you to enter notes that can be several pages in length. These notes 
are for your eyes only. The small Clipboard menu in the upper-left corner can be used to store and reuse text. Refer to 
Gradebook Options: Clipboard Text on page 32 for an explanation of how to use this menu. To print this view, use the Class 
Notes report.
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Assignment Summaries
There are two assignment summary views. All of the information in these views can be included in different reports. The 
Assignment Graph view includes a bar graph showing the number of students who have received each grade on an 
assignment. Grade names and cutoff scores are shown below the graph. You can choose any grade scale available to the class. 
To see the students that a bar represents, press on the bar; a list will appear. To print one or more assignment graphs, use the 
Assignment Graphs report. The Assignment Grades view shows a list of students with scores, percents and grade names on 
a particular assignment. The list is ranked from highest to lowest score and provides some statistical information at the bottom. 
To print this, use the Assignment Summary report.

Using the Mini-summary Window
The Mini-Summary floating window can display graphs and lists while you are working in any of the five charts. It can also be 
used to attach footnotes to scores and show score notes in the score chart. To make the summary window visible, choose 
Show Mini-Summary from the Edit menu. Select the item again to hide it. The small menu in the upper-left corner of the 
window can be used to switch between the seven views. These include Class Graph, Assignment Graph, Student Graph, Student 
Grades, Student Attendance, Score Footnotes and Score Notes.
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12
Printed Reports

Easy Grade Pro offers nineteen comprehensive reports. Regardless of which report you want to print, you’ll follow the same 
steps: select the report, set options, preview one or more reports and then print the reports. This chapter begins by 
explaining this process in general. It then describes each of the reports.

Using the Print Windows
1 To print any report, open the Print Reports window.

Open this window by clicking the Print tool  or by selecting Print from the File menu. Notice (below) that this window 
lists reports using tabs. The first tab lists all reports meant for students. The second tab shows reports that correspond to 
the five screen charts. All other reports are found under the last tab.

2 View/Edit the School (single-user version) or Teacher (site version) name.
This name will appear in the heading of each report.

3 (Optional) Click the Labels button to edit the labels for student reports.
See Gradebook Options: Report Labels on page 32 for help.

4 Select a report and click Next.
After clicking, the Report Options window will open (shown on the next page) where options for the report can be set. Every 

report has its own Report Options window. To get a description of an option, click on the Help tool .

5 Select the range of reports.
Use the three top buttons to select the students, assignments or classes for which reports are to be printed. If you select 
the last one, be sure to select at least one list item.
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6 Select the report options.
The boxes found in the lower half of the window have options for the report. Two options found in all reports are font and 
font size. These are unique to each report.

7 Select Page/Print Setup and set printer options.
The Page/Print Setup window allows you to set the orientation, scale, and other printer options.

Select one of these to set the range of reports. If you select the third 
option, be sure to select one or more items from the list.

Click to set the 
orientation, 
enlargement, and 
other printer 
options.

Click to 
preview the 
report based 
on the current 
settings.

Click to save 
the reports as 
disk files.

Click to set the 
number of pages, 
the number of 
reports per page 
and to print.

Report-specific options are found here.

6 Select Preview to view the reports.
Previewing a report before printing is a good way to learn how certain options affect a report. You can use Print Preview to 
ensure that a progress report fits on one page, or that you are maximizing the data that will fit. There are two views in the 
preview window: fit-in-screen (shown below) and full-size. The fit-in-screen view shows the entire page. Depending on the 
size of your monitor, the details on the page may be unreadable. In this view, the cursor is a magnifying glass. By clicking 
once on any part of the page, the view automatically switches to the full-size view. The full-size view shows the page at its 
actual size. In this view, the cursor becomes a hand. By pressing the mouse button, the page can be grabbed and dragged 
about. Windows: Right-click on the image to display a contextual menu with multiple zoom levels.
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9 Select ePrint or Print.
■ Print. Use this option to print paper reports. The standard Print window for your type of printer will open where you can 

set some final print options and begin printing. 
■ ePrint. Use this option if you want to save each page as a file so that it can be manipulated using a graphics program or 

used in another document such as a presentation file. Each report page will be saved as a separate file in PICT format 
(Macintosh) or BMP (bitmap) format (Windows). Be sure to create a new folder (in the window that appears) to hold all the 
files. The files will be automatically named using the student, class or assignment names. 

Printing Multiple Reports Per Page
Many printers today allow you to choose the number of pages to be printed on each sheet of paper. They do this by 
shrinking each page the correct amount and placing the pages at different locations on the paper. These options are known 
as layout options and can be found in the print window that appears after you click the Print button window.

Student Reports
Easy Grade Pro provides three comprehensive reports for communicating information about individual students. This section 
describes the purpose and features of each report. The best way to learn about each report is to explore the options and 
features in the Report Options, Page/Print Setup and Preview windows. 

One feature common to all student reports is the ability to change report titles and labels. You can customize the labels using 
options in the Gradebook Options window. See Gradebook Options: Report Labels on page 32 for help.

The Progress Reports
Easy Grade Pro offers two progress reports. The multi-class progress report is designed for teachers who have the same 
students in two or more classes. Each report can include a great variety of information about a student’s performance in up to 
eighteen classes. The single-class progress report is designed to report information about performance in a single class only.

The features of the two reports are essentially identical. You can display student grades as percents, grades or both. 
Introductory and postscript text can be included and Easy Grade Pro can complete text variables with student data at the time 
of printing. A summary chart with overall, term, category and other data for each class can be included as well as a chart of some, 
missing or all assignments. The line graph, note and comments found in the Summaries window can all be included. Attendance 
data can be displayed using a chart, calendars and list of dates. Blank comment lines can be added for handwritten comments 
by teacher or parents. 

There are some differences between the reports. In the multi-class report, if the report is customized to include an overall grade, 
Easy Grade Pro will combine all the subject grades using the class weights found in the Records window for each class. In the 
single-class progress report, you can filter the students based on overall percent so you get just the reports you want.

Multi-class Progress Report    Single-class Progress Report    Missing Work Report
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The Missing Work Report
The missing work report can be used to inform students and parents about missing work. A student’s missing work from more 
than one class can be included in the same report. (The scores that count as missing are set in the Class Options window for 
each class. If you would like blank scores to be included in this report, use the Change Scores tool to change blank scores to 
scores that count as missing.) Introductory and postscript text can be included. You can filter the missing work report to 
include only missing assignments on or after a certain date.

Chart Reports
The five screen charts (score, attendance, seating, student and assignment) can be printed using the reports in the chart 
category. They can be printed to look exactly as they appear on screen or can be customized in a variety of ways. This section 
describes the purpose and features of each report, but you are encouraged to explore the options and features of each report in 
the Report Options, Page/Print Setup and Preview windows.

You may find that the chart reports print better if you use the Page/Print Setup window to set the orientation to landscape view 
(sideways printing) and the scale to between 60% and 80% if your printer allows this. This will maximize the number of columns 
per page.

The Score Chart Report
The score chart report mirrors the onscreen score chart. You can exclude the assignments and include blank rows and columns 
so that it can be used like a paper gradebook. This report works well as a poster because students can be sorted in a variety of 
ways and can be displayed by name or ID. You can choose to include a footnote key on the last page.

The Attendance Chart Report
The attendance chart mirrors the onscreen attendance chart. Like the score chart report, you can include blank rows and then 
use it like a paper gradebook. A key to all of your attendance codes can be included on the last page of the report.

The Seating Chart Report
Use this report to print your seating charts as they appear on screen. You can choose to include a frame around the chart, to 
include furniture and to print in color. Use font size and the options in the Page/Print Setup window to get the chart to fill a 
single sheet of paper.

Score Chart Report   Attendance Chart Report   Seating Chart Report

The Student and Assignment Chart Reports
The student and assignment chart reports can be set to mirror the onscreen charts or they can be highly customized to include 
the data and order of data that you desire. You can print book number reports, parent name and phone number reports, etc. 
You can change the report title so that it matches the data in the report.
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Other Reports
There are eleven other reports that can be used to print graphs, rosters, charts, missing work, labels and notes. Several of the 
reports include data found in the different views of the Summaries window. This section describes the purpose and features of 
each report, but as always, you are encouraged to explore the options and features of each report in the Report Options, 
Page/Print Setup and Preview windows.

The Assignment and Class Graphs Reports
The assignment and class graphs reports allow you to print one or more bar graphs found in the Summaries window. The 
options for these reports allow you to choose the scale, include the class name, class average, standard deviation, cutoff scores, 
cutoff percents, and cutoff grades. The graphs can be printed in color using the colors set in the Class Options window for each 
class. It is suggested that you use the Page/Print Setup window to set the orientation to landscape view (sideways printing), and 
the scale to between 75% (six graphs per page) and 150% (one graph per page) if your printer allows this.

The Assignment Summary Report
The assignment summary report includes ranked student lists on one or more assignments. This report works well as a poster 
because students can be sorted in a variety of ways and can be displayed by ID number. Options allow you to include the class 
name, date, average and standard deviation. You can also display the students with scores, percents and grades. 

The Attendance Summary Report
The attendance summary report includes a chart of students and attendance totals. You can control the students who appear 
in the report and the number, content and order of the attendance columns. You can include a key with attendance codes. It is 
suggested that you use the Page/Print Setup window to set the orientation to landscape view (sideways printing), and the scale 
to between 60% and 80% if your printer allows this. 

The Class Summary Report
The class summary report is a concise compilation of overall points, percents and grades broken down by term and category. 
This report works well as a poster because students can be sorted and displayed by ID number. You can set the order and 
content of the columns. If you include many columns, it is suggested that you use Page/Print Setup to set the orientation to 
landscape view (sideways printing), and the scale to between 60% and 80%. 

Class Graphs Report    Assignment Summary Report    Class Summary Report

The Class Missing Work Report
The class missing work report includes all missing work from selected classes in a single report. Although this report is meant 
to be used by the teacher, it can be cut up and given to students. You can choose to have the missing work sorted by student 
or by assignment. If sorted by student, the report will list each student with all missing assignments. If sorted by assignment, it 
will list each assignment with the students who have missing scores on it.
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The Class Notes and Student Notes Reports
The class notes and student notes reports print the information in the two notes views in the Summaries window. The student 
notes report can also include the notes found in the Score Notes window.

The Class Roster Report
Class rosters are very similar to score chart reports except that the data cells are always left blank. They can be used in a variety 
of ways, including being used to record grades. You can set the width of the columns to normal or narrow. You can include 
room for hand-written titles and even have Easy Grade Pro print your own custom column titles.

The Labels Report
Labels for envelopes, folders, lockers, etc. can be printed to all popular Avery™ labels for laser printers and ink-jet printers. You 
can set the content of up to three lines on a label and have the text justified to the left or centered. Since you can use cutoff 
percents for selecting students, it is easy to print both progress reports and mailing labels for students who are failing or at 
certain grade levels.

The Multi-class Gradesheet Report
The multi-class gradesheet report produces a chart with students and their overall or term grades from multiple classes. 
Elementary teachers can use this report to list all subject grades for each student. Secondary teachers can use this report to 
produce a single list of all students and their grades. Since students can be displayed by ID and can be sorted in a variety of 
ways, this report can be used as a poster.

You can choose to have the report display individual term grades or overall grades. A term grade is the grade for a single term. If 
term options have not been set in the Class Options window, then the overall grade and the term are the same.

The Show Combined Class Average option can be used to combine all displayed grades for a student using the class weights 
found in the Records window. You can sort by the combined class grade to produce a ranked list of students across multiple 
subjects or classes.

 Class Roster Report          Labels Report Multi-class Gradesheet Report       
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13
Internet Reports

Easy Grade Pro offers different ways to post student reports on the internet with security. Once set up, it can be easy to 
regularly update internet reports for parent and student viewing, saving both time and resources.

Internet Report Options
Easy Grade Pro 3.6.0 offers three types of options for internet viewing: HTML, Edline and Basmati. Each is very different and has 
its own set of features and requirements as the chart below illustrates.

HTML 

Edline

Basmati

 Web 
Server

Designed 
for...

To upload 
reports... Security

Requires 
school or 
district web 
server 
running NT/ 
2000, Linux, 
Unix, or OSX.

Secure server 
provided and 
maintained 
by Edline.

School or 
district web 
server or web 
space 
provided by 
an ISP of your 
choice.

Individual 
teachers 
primarily, 
but also 
schools.

Schools and 
districts.

Teacher creates a 
folder of reports 
using Easy Grade 
Pro and uploads 
it to the web 
server using an 
ftp program.

Easy one-click 
uploading of 
reports directly 
from Easy Grade 
Pro (using Mac 
OS 8.6+ or 
Win95+).

Teacher creates 
a report file 
using Easy 
Grade Pro and 
uploads it to the 
server using a 
web browser.

Schools and 
districts.

Password 
protection.

Encryption of 
uploaded reports. 
Secure web site. 
Passwords for 
school personnel, 
students and 
parents. 

Password 
protection. Single 
password for 
access to grades 
from multiple 
teachers.

Pricing/Other

Free.
Can work with 
existing school or 
personal web pages. 
Must add link to 
main password 
page.

$$ based on 
#students.
Stand-alone, full-
featured service for 
posting grades and 
any school/class 
information.

Free.
Can work with 
existing school web 
pages. Allows easy 
viewing of reports 
from multiple 
teachers.

Report View

Using HTML Reports
HTML Reports are for individual teachers and schools that want a free way to post student reports for viewing on the internet. If 
a teacher doesn’t have access to a school or district web server, web space provided by an ISP can be used as long as the space 
provided is at least 4MB. 

HTML Reports offer security through the use of JavaScript 1.1 and frames. Netscape Navigator 3.0+, Internet Explorer 4.0+ and 
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America Online are capable of viewing student HTML reports as long as frames and JavaScript have not been turned off in the 
browser’s preferences window. The majority of browsers in use at the time of printing are capable of viewing the reports. 

It is best to view HTML reports from a computer that is not shared by others in a public environment because of the 
browser history stored by most web browsers which may allow access to reports previously viewed.

Follow these steps in setting up HTML Reports with password security:

1 Enter passwords for one or more students.
Open the record window for a student (double-click on a student’s name in most charts) and enter the password in the 
Password field. Or choose Student from the Chart menu and enter the passwords in the Password column. Not only are 
passwords used to gain access to reports on the internet, they are used as filters when creating reports: students without 
passwords are skipped.

Passwords must consist of letters and numbers only and must be between six and twenty-four characters in length. 
They are not case sensitive.

2 Select Internet from the File menu or use the Internet tool  to open the Internet Reports window.

3 Enter the name of the school or your name in the field at the bottom of the window. 
This name is used in the title area of the reports. 

4 Select the HTML tab and select either Multi-class or Single-class Website Reports. Click Next.
Select Multi-Class Website Reports if you have the same students in multiple classes or subjects and wish to produce reports 
that include all subjects. Otherwise, select Single-class Website Reports. After clicking, the Report Options window will 
appear with a variety of options.

5 Set the desired options in the Report Options window.
Many of the options found in this window are identical to those found in the window for the printed progress reports but 
there are differences as follows:
■ Students without passwords will be skipped.
■ Main Page Options. The main page is a password page where the viewer must choose a class, enter a name and 

password. Optionally, it can include a message from the teacher and the teacher’s email address. To include a message, 
select the Include Main Page Text option. Then click the set button and enter the text. The text might include a 
greeting, directions, and a request to sign up and send a password. If you would like parents to be able to click on a 
button to send you email, enter your email address in the Email field.

■ HTML Options. Click this to open a window where the style and colors used in the tables of the report can be set.
■ Label Options. Click this to open the Gradebook Options window so that labels used in the report can be edited.
■ Use Custom Student Title. For security, it is strongly recommended that you turn on this option. Then click the set 

button to open the Custom Student Title Options window (shown below) and set the display of the student in Line 1 
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to ID only or turn on the Exclude ‘Line 1’ from Internet reports which causes any reference to the student to be 
omitted. 

6 Click the Create button.
Follow the prompt to create a folder on your desktop. Give the folder an exact name such as ‘teacher name’ Grades. 
Perhaps your school will provide you with a name. Easy Grade Pro will automatically create the main page, named 
index.html, other special files as well as a folder for each class with reports. 

You must use the same folder name every time you create reports so that the link to your index.html does not break.

7 Quit Easy Grade Pro and view the reports using your web browser.
Although there is no way to preview the HTML reports within Easy Grade Pro, it is easy to view them using your web 
browser before you upload them to the web server. Find the folder you created, open it and double-click on the index.html 
page. If it doesn’t open, first open your web browser, choose Open from the File menu, then navigate to the index.html page 
and open it. If there is an element in the main page or in the reports that you would like to change, delete the folder and start 
over.

8 Use an ftp program to upload the folder to your web server.
You will need a File Transfer Protocol (FTP) program to transfer the folder with pages to the server. Your school may provide 
you with the instructions and software necessary to complete this step.

For security, be sure to delete the folder from your computer when done with the transfer.

9 Using a web design program, provide a link from you school’s web page or a personal web page to the 
index.html page within your folder of grade reports.
You will need a web design program to set up the link. Your school may provide you with the instructions and software 
necessary to complete this step or it may it may be done for you.

Using Edline
Edline provides a complete Internet platform that serves as your school’s website or a companion website. It allows one-click 
uploading of student reports directly from Easy Grade Pro making it the easiest way to regularly upload reports. For information 
view www.edline.com or call 1-800-491-0010. Once your account has been set up, Edline will provide your school with 
information about how to get started and set things up. You will be given an access code that is used to gain access to the 
website where you can upload announcements, calendars, news, pictures and more using your web browser. Follow these 
steps in uploading student reports from Easy Grade Pro:

1 Ensure that each class in your gradebook has a Class ID.
Every class must have a unique ID number that identifies it in Edline. When you post reports from your gradebook, Edline 
uses the Class ID to determine where to put the reports. Your school will provide you with a unique Class ID for each class 
you teach. These may be imported into your gradebook directly from school administration software or you may need to 
manually enter them. The Class ID will be entered into one of the fields in the Records window for each class you teach. To 

open this window, choose Records from the Chart menu or click the Records tool . Then select the Classes tab. If you 
must manually enter a Class ID, enter it in the first field under the Custom Data title (shown on the next page).
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2 Ensure that each student has a Student ID.
Every student must have a unique ID number that identifies him or her in Edline. When you post reports from your 
gradebook, Edline uses the student ID to determine which student or parents should be allowed to see the report. Your 
school will provide you with a unique Student ID for each student. These may be imported into your gradebook directly 
from school administration software or you may need to manually enter them. The Student ID must be entered into Student 
ID field in the Records window or can be entered directly into the Student chart (choose Student from the Chart menu).

3 Select Internet from the File menu or use the Internet tool  to open the Internet Reports window.

4 Enter the name of the school or your name in the field at the bottom of the window. 
This name is used in the title area of the reports. 

5 Select the Edline tab and select a report from the list. Click Next.
Select the Multi-Class Edline Reports if you have the same students in multiple classes or subjects and wish to produce 
reports that include all subjects. Otherwise, select the Single-class Edline Reports. After clicking, the Report Options window 
will appear with a variety of options.

6 Set the desired options.
Many of the options found in this window are identical to those found in the window for the printed progress reports but 
there are differences as follows:
■ For the Multi-class Report, you must enter the Class ID given to you by your school. It is critical that you use the 

correct value. You must also enter a Class Title, such as Ms. Demo’s 6th Grade. 
■ For the Single-class Report, you must select from a menu the field in the Records window that is holding the Class ID.
■ The Report/Folder Name is the name of the folder to hold the reports on Edline and is visible to viewers. You can use 

one or more folders for different reports such as Quarter 1 Reports, Quarter 2 Reports, Final Reports, Missing Work 
Reports, Grades 9/5/02, etc. If you want to upload reports that replace older reports for your student, use the same 
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name for the folder. If you want to upload reports that do not replace older reports, use a new name.
■ HTML Options. Click this to open a window where the style and colors used in the tables of the report can be set.
■ Label Options. Click this to open the Gradebook Options window so that labels used in the report can be edited.

7 Click the Upload button.
If you are not using an always on connection to the internet, be sure to connect before clicking Upload. Easy Grade Pro will 
open your web browser to the Edline server and send the reports. During the process you will be prompted to enter your 
Edline screen name and password. Then Edline will scan the reports and inform you of any errors. 

If you enter your screen name or password incorrectly, uploading will be canceled.

8 View one or more reports.
To view the reports, go to the home page for any class whose reports you uploaded. Click on the name of the report folder 
in the Contents box. You will see a list of reports. The title of each report is the student's name. To view an individual report, 
click on a student's name. You, as the teacher, will see all the reports. When students and parents click on the folder, they 
will only see their own reports.

Using Basmati
Basmati is open-source software that will run on your school or district’s Linux, Unix, Windows NT/2000 or Mac OS X web 
server. Software and documentation are free and are available for downloading at http://www.sourceforge.net. (Search for 
Basmati.) Parents and students can use a single password to view grades from all classes and teachers. Once your school or 
district has set up the software on its server, you can use Easy Grade Pro to generate a single grade file with information on all of 
your students and classes and upload it to the server using your web browser. Follow these steps:

1 Ensure that each class in your gradebook has a Course Code and other values.
Every class must have a unique course code that identifies it in Basmati. Optionally, it may also have a section number and 
period. These codes may be imported into your gradebook directly from school administration software or you may need to 
manually enter them into fields in the Records window for each class you teach. To open this window, choose Records from 

the Chart menu or click the Records tool . Then select the Classes tab. Typically, the Course Code will be in the first field 
under the Custom Data title (shown below) and the others below it. Follow the instructions provided by your school.

2 Ensure that each student has a Student ID.
Every student must have a unique ID number that identifies him or her in Basmati. These ID’s may be imported into your 
gradebook directly from school administration software or you may need to manually enter them. The Student ID must be 
entered into the Student ID field in the Records window, under the Students tab or can be entered directly into the Student 
chart. Choose Student from the Chart menu to view this chart.

3 Select Internet from the File menu or use the Internet tool  to open the Internet Reports window. 
Select the Other tab and select Basmati from the list. Click Next.
After clicking, the Basmati Options window will appear (shown on the next page).
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4 Set the desired Basmati options using these guidelines:
■ Include Students in. Use this to set the classes to be included.
■ Course#. Set this to the appropriate custom field in the Records window. This field is required.
■ Section#  and Period#. Set these to omit or the appropriate custom fields in the Records window.
■ Students and Assigns. Use these to set which students and assignments are to be included. Use these in conjunction 

with the filters found in the View menu.
■ Teacher. Put your name in this field.
■ Email. Put your email in this field. This field is required.
■ TchrID. Put your password  in this field for access to Basmati. This field is required.
■ Phone. Put your school phone# in this field.
■ Control. Leave this field blank unless instructed to use it.

5 Click Create and save the Basmati.txt file to the desktop of your computer or some other location.

6 Quit Easy Grade Pro.

7 Upload the Basmati.txt file using your web browser.
Using your browser, access your school’s Basmati Faculty page. After logging in, click the Submit File button. Then click the 
Browse button (shown below). Find and select the Basmati.txt file your created with Easy Grade Pro. Then click the Submit 
File to Basmati button. 

For security, be sure to delete the Basmati.txt file when done uploading.
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14
Email Reports

Using Easy Grade Pro’s HTML reporting features, it is easy to create a folder of student reports for each of your classes. These 
reports can be attached to your email messages, sent and viewed by parents and students using their web browser. This 
chapter explains how.

Creating the Reports
1 Select Internet from the File menu or use the Internet tool  to open the Internet Reports window.

2 Enter the name of the school or your name in the field at the bottom of the window. 
This name is used in the title area of the reports. 

3 Select the HTML tab and select either Multi-class or Single-class Email Reports. Click Next.
Select Multi-Class Email Reports if you have the same students in multiple classes or subjects and wish to produce reports 
that include all subjects. Otherwise, select Single-class Email Reports. After clicking, the Report Options window will appear 
with a variety of options.

4 Set the desired options in the Report Options window.
Many of the options found in this window are identical to those found in the window for the printed progress reports but 
there are differences as follows:
■ HTML Options. Click this to open a window where the style and colors used in the tables of the report can be set.
■ Label Options. Click this to open the Gradebook Options window so that labels used in the report can be edited.
■ Use Custom Student Title. For security, it is strongly recommended that you turn on this option. Then click the set 

button to open the Custom Student Title Options window (shown on the next page) and set the display of the student 
in Line 1 to ID only or turn on the Exclude ‘Line 1’ from Internet reports which causes any reference to the student to 
be omitted.
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5 Click the Create button.
Follow the prompt to create a folder on your desktop. You may wish to name it Email Reports.  Easy Grade Pro will create a 
folder inside it with student reports for each class.

6 Quit Easy Grade Pro and view or more reports using your web browser.
Although there is no way to preview the HTML reports within Easy Grade Pro, it is easy to view them using your web 
browser before you email them. Find the folder you created, open it and double-click on any report page. If it doesn’t open, 
open your web browser, choose Open from the File menu, then navigate to the report and open it.

Emailing a Report
1 Using a email program, write an email to the parent or student.

 You may wish to write a set of instructions for opening the attached report. Save the instructions so that it can be reused. 
The instructions might include something like this. 

“Please find the grade report attached to this email. You may be able to view the 
report by double-clicking on the report’s name. Otherwise, save it to the desktop or 
other location of your computer. Then start your web browser, choose Open from 
the File menu and open the report.”

2 Attach the report to your email message.
With many email programs you can simply drag the report file into the message window. If this doesn’t work, use the Attach 
tool of the email program to attach the report. Be sure you attach the right student’s report! For greatest security, change 
the report’s filename from the student’s name to something generic like Grade Report.

Be sure to delete the folder of reports when done.
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15
Porting

Porting refers to the transfer of data to and from your gradebook. To import means to copy data from another file to your 
gradebook. To export means to create a new file that holds data from your gradebook. This chapter explains the many 
ways you can port data. 

Importing
Typically, importing is used to bring student names and other student record information into a gradebook, but it can also be 
used to import options, scores and more. You can import from two types of files: Easy Grade Pro gradebooks and text files. Text 
is a standard file format that many programs use for transferring data to other programs and platforms.

1 Select Import from the File menu or use the Import tool  to open the Import window.
The Import window (shown below) has two tabs. Under the first tab, you’ll find the built-in import formats. Under the 
second tab you’ll find user-defined and other editable formats. A format is used to specify the fields and structure of the data 
to be imported. Note: the items listed under the tabs can vary with the different custom versions of Easy Grade Pro.

2 (Optional) Select the New Format button.
If the format that you need is not present, you can create one using the New Format button. This button can only be 
selected if the Other Formats tab is front most. For help in creating a format, refer to the section Creating Formats for 
Importing and Exporting on page 79.

3 Select a format, click Next. 
What happens after clicking depends on the selected format. The formats include:
■ Import from an EGP Gradebook. Use this format to copy students, options, assignments, a whole class, etc. from 

another Easy Grade Pro gradebook. The Import Gradebook window will appear where you can select the items to be 
imported.

■ “Easy Import” of Students. Use this format to import students from most tab-separated or comma separated text 
files. Many database and spreadsheet programs use this format when creating text files. The Easy Import window will 

Chapter 15: Porting      77



open where you can identify the fields in a record from the file. You must identify the first and last names but all other 
fields are optional. You must also name the format so that it can be added to the Import window where it can be reused 
directly.

■ “Easy Import” of Scores. Use this format to import scores from most tab-separated or comma separated text files. 
The records may be in any order as long as each contains a score and an ID number (or student name) to be used for 
matching. The Easy Import window will open where you must identify the score and the ID number (or student name) 
fields.

■ Import Summary Comments. Use this format to import a list of summary comments from a text file. This will replace 
the list in the Student Comments view of the Summaries window.

■ Combine Gradebooks. Use this format to combine one or more gradebooks from other teachers into a single master  
gradebook to be used for the printing of multi-class progress reports or other reports. Note: there is a 250 class limit for a 
gradebook which means that you can typically combine around five to ten gradebooks.

■ Other Formats. The formats that appear under the Other Formats tab can only be used to import students and 
student record data from text files. There is a small blue arrow above the list of formats which allows you to duplicate a 
format or create a plug-in of a format. A plug-in is a small file that makes it easy to distribute a format to other Easy Grade 
Pro users. See Using Plug-ins on page 84 for help.

4 If the Import Preview window appears, select the records to be imported and click the Import... button.
For most formats, the Import Preview window will appear so that you can select the records (students) to be imported. Be 
sure to check that the data in the columns properly match the column titles. If they don’t match, click the Cancel button.

If a selected student has the same ID number as a student currently in the class, the import data will be used to update 
the student’s record information. The student will not be duplicated in the class.

Exporting
Exporting is typically used to transfer student grade data to a program used to print report cards but it can also be used to 
transfer all kinds of student information to word processor, spreadsheet or database software to take advantage of the unique 
tools of these programs. When exporting, you can create two types of files: Easy Grade Pro gradebooks and text files. Text is a 
standard file format that many programs use for transferring data to other programs. Follow these steps:

1 Select Export from the File menu or use the Export tool  to open the Export window.
The Export window (shown on the next page) has two tabs. Under the first tab, you’ll find export formats that are built-in. 
Under the second tab you’ll find user-defined and other editable formats. A format is used to specify the fields of the data to 
be exported. Note: the items listed under the tabs can vary with the different custom versions of Easy Grade Pro.

2 (Optional) Select the New button.
If the format that you need is not present, you can create one using the New button. This button can only be selected if the 
Other Formats tab is front most. For help, refer to the section Creating Formats for Importing and Exporting on page 79.
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3 Select the classes and students to be exported.
Select the classes from the list. Select the students using the menu near the bottom.

4 Select a format and click Next. 
What happens after clicking depends on the selected format. The formats include:
■ Export One Class. Use this format to create a new gradebook with a single class. This can be used to create a file with 

data to be imported into another gradebook.
■ Export Gradebook Template. Use this format to create a new gradebook with gradebook and class options (from 

the selected class) only. The new file can be used as a stationery  template. When you open this template, a copy of the 
gradebook is created, leaving the original unchanged.

■ Export Attendance. This format is usually not selected directly because it is automatically used whenever the Export 
Attendance tool is selected from the tool bar. For help, refer to the section Exporting Attendance on page 81.

■ Export Report Card Data. This format can be used to export student grade data to database software that prints 
custom report cards. This is explained in detail in the section Using the Report Card Data format on page 82.

■ Export Summary Comments. Use this format to create a text file of the list of comments found in the Summaries 
window. 

■ Other Formats. The formats that appear under the Other Formats tab can only be used to export student data to text 
files. There is a small blue arrow above the list of formats which allows you to duplicate or create a plug-in of a format. A 
plug-in is a small file that makes it easy to distribute a format to other Easy Grade Pro users. See Using Plug-ins on page 
84 for help.

4 If the Export Preview window appears, verify the data and click the Export button. 
For most formats, the Export Preview window will appear so that you can verify the data being before saving.

Creating Formats for Importing or Exporting
If you wish to import or export student data with spreadsheet, database, school administration and other software, you may 
need to create an porting format. This section explains how to create formats that appear under the Other Formats tabs in the 
Import and Export windows.

Creating formats requires a certain amount of knowledge of file formats and ASCII codes. In addition, it requires 100% 
accuracy or else unpredictable results may occur. Proceed with caution!

If you will be porting to or from a spreadsheet or consumer database program, things are easier because these program typically 
use a tab-delimited format. This means that fields (data in columns) are separated by tabs (ASCII 9) and that each record (all the 
data in one row of columns) is separated by a CR (carriage return, ASCII 13). By default, Easy Grade Pro uses this format when 
you create a format. In the PC world, many programs use a CR/LF ( carriage return/line feed, ASCII 13/10) combination instead of 
a lone CR. You can modify an Easy Grade Pro format to include the LF. See step 5 below.
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If you will be porting to or from school administration software, things can be much more difficult because these programs tend 
to use custom formats. For example, some files may use fixed-length fields (instead of variable length fields) that are left or right 
justified, with special fill characters and no delimiters except at the end of a record. In many but not all cases, formats can be 
created in Easy Grade Pro to work with school administrative software.

1 From the Import or Export window, select the Other Formats tab. Then click the New button.
The New Format window will open (shown below). On the left side of this window is a list of fields that are available for use 
in the format. On the right side of the window is a list (blank at first) of fields in the format you are creating. In general, you 
will select a field in the left list and click the Copy button below the list to put the field in the list on the right.

2 To add a field to your format, select it in the list on the left and click the Copy button.
When the Copy button is clicked, the field is copied to the list on the right. If a field is in the wrong position in the format 
list, press on it and drag it to the new location. 

A format is limited to thirty fields (columns of data) per record.

3 (Optional) Select the Quotes button.
Set this item if the data has (if importing) or should have (if exporting) quotation marks around each field. Under many 
circumstances, Easy Grade Pro will remove quotation marks automatically during importing.

4 (Optional) To customize a field, select it and click the Edit button. 
Easy Grade Pro automatically uses a tab-delimited format in which each field is variable in length and is followed by a tab 
(ASCII 9) for most fields and a CR (ASCII 13) for the last field in a record. To change this formatting, or to make a field 
required (for export formats), select the field in the list on the right and click the Edit button. A small window will open with 
options for changing the format of a field. Only those with sufficient knowledge of file formats should attempt to make 
changes in this window. Any field that has been customized will have an asterisk appended to its name in the list.

If you set the Field Data Required item in an export format, Easy Grade Pro will block exporting until all required data are 
complete. 
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5 (Optional) Add a LF Record Delimiter
By default, Easy Grade Pro adds a CR (ASCII 13) to the end of a record. If your format requires a CR/LF (ASCII 13/10) 
combination, follow these steps: 
a) Change the delimiter of the last field to CR (ASCII 13). To do this, select the last field and click the Edit button. In the 

window that opens, change the delimiter to CR.
b) Add a Blank Field to the format. To do this, select Blank Field (the last field) in the list on the left and click the Copy 

button.
c) Change the delimiter of the Blank Field to LF (ASCII 10). To do this, select the field and click the Edit button. In the 

window that opens, change the delimiter to LF.

6 Name the format in the text field at the top of the window and click Done.
The name will appear under the Other Formats tab in the Import or Export window. 

Exporting Attendance
Easy Grade Pro makes it easy to export attendance over a network. After entering attendance data in the attendance or seating 
chart, the teacher can export the data in just a few steps.

Macintosh: The EGP Attendance Compiler software (a companion product from Orbis Software) can be used by the 
attendance secretary to compile all the individual teacher files for a day so that the data can be collected from the server, saved, 
printed, recorded or placed into school management software. Contact Orbis Software for information on this product.

For the exporting of attendance to be successful, careful preparations are required. These are outlined next.
■ Attendance Folder. A folder must be set up on a shared volume to hold the daily attendance export files. The pathname 

(name of folder, enclosing folders and volume) must not change once exporting has begun. The volume should be 
automatically mounted on each teacher’s computer. 

■ Attendance Categories. Each teacher’s gradebook must have the school’s attendance categories and codes. Although 
these can be set by each teacher using the Class Options window, it is suggested that a gradebook template be set up and 
made available to teachers. Creating a gradebook template is explained on the bottom of this page.

■ Export Attendance Format. Easy Grade Pro has a built-in export format for attendance. This format has the name Export 
Attendance and can be found under the Built-in Formats tab of the Export window. It has the following fields:

Field 1 Selected Date 
Field 2 ID
Field 3 Last Name, First
Field 4 Selected Day’s Attendance 

If desired, you can create your own custom format. See the section Creating Formats for Importing and Exporting on 
page 79 for help. In order for Easy Grade Pro to automatically use your format, it must be named Export Attendance. Every 
gradebook must have the custom format. Although it can be imported into a gradebook, it is best to include the format in a 
gradebook template.

■ Calendar Settings. Attendance data cannot be recorded until calendar options have been set in the Class Options 
window.

■ Export Attendance Tool. The Export Attendance tool  is used to start the export process. It must be placed on either 
the tool bar or tool palette. To add the tool, press and hold on any occupied or unoccupied tool location. Select the Export 
Attendance tool from the menu that appears. It is best to include this setting in the gradebook template.

A gradebook template can be used to ensure that all teachers’ gradebooks have the same settings. It also minimizes the work 
that teachers must do. First create a gradebook with the right settings. Then create a template of the gradebook using the 
Export window. Refer to the section Exporting starting on page 78 for help. Teachers should create their gradebooks directly 
from the template. 
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Before you can export attendance, your gradebook must have the correct attendance categories and export format. The Export 
Attendance Tool must be on the tool bar or tool palette and the volume to receive your attendance data must be mounted on 
your computer. You must know the name to use for your export file and the location in which it is to be saved. Be sure to enter 
your attendance data in the attendance chart or seating chart first. Then follow these steps:

1 Click the Export Attendance tool. 
A small calendar will appear (shown below). This calendar will automatically display the current date but you may change 
this by clicking on the calendar.

2 Click OK in the Calendar window. 
After clicking, Easy Grade Pro will gather the attendance data for the selected date and present it in the Export Preview 
window (shown below). This window is used to verify the attendance data. Note that only students with attendance marks 
appear.

3 Click Export Records in the Export Preview window. 
Even if you do not have any students with attendance data for the selected date, it is important to export so that a file is 
created indicating that attendance has been sent.

If this is the first time that you are exporting attendance from the gradebook, the standard Save dialog window will open 
allowing you to name and save the export file. Use the unique name given to you. The location to save the file should be the 
attendance folder set up on a shared volume. Easy Grade Pro will remember the name and location and use them automatically 
in the future. If you saved the file using the wrong name or location, you must reset Easy Grade Pro. To do this, click the Export 
Records button (shown above) while holding down the option (Macintosh) or control (Windows) key . You will be able to 
reset the name and location.

Using the Report Card Data Format
This section explains the Report Card Data export format found in the Export window of Easy Grade Pro. This format can be 
used to export student data to database software designed to print your school’s report cards.

One of the more popular and affordable database programs available is FileMaker® Pro from FileMaker Inc. (a subsidiary of 
Apple Computer, Inc.). It can be used to print your school’s report cards using data from Easy Grade Pro. If the database is well-
designed, the whole process can be fairly easy. But to create a well-designed database requires skill and time. Many resources are 
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available to make the task easier. (Check out www.filemaker.com).

The Report Card Data format consists of 157 fields (listed below). Virtually every piece of data about a student is included 
(other than individual attendance marks and assignment scores). Even the text found in the Summaries window is included. 
This format results in a tab-separated text file. The field information below is needed when creating a report card database.
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1 Last Name, First
2 Last Name
3 First Name
4 ID
5 Gender
6 Status
7 Grade Scale
8 Language
9 Student Custom 1

10 Student Custom 2
11 Student Custom 3
12 Student Custom 4
13 Student Custom 5
14 Student Custom 6
15 Student Custom 7
16 Student Custom 8
17 Student Custom 9
18 Student Custom 10
19 Student Custom 11
20 Student Custom 12
21 Class Name
22 Class Weight
23 Class Custom 1
24 Class Custom 2
25 Class Custom 3
26 Class Custom 4
27 Class Custom 5
28 Class Custom 6
29 Class Custom 7
30 Class Custom 8
31 Overall Points
32 Overall %
33 Overall Grade
34 Class Rank
35 Class Average %
36 Class Average Grade
37 Current Term Points
38 Current Term %
39 Current Term Grade
40 Category 1 Points
41 Category 1 %
42 Category 1 Grade
43 Category 2 Points
44 Category 2 %
45 Category 2 Grade
46 Category 3 Points
47 Category 3 %
48 Category 3 Grade
49 Category 4 Points
50 Category 4 %
51 Category 4 Grade
52 Category 5 Points
53 Category 5 %

54 Category 5 Grade
55 Category 6 Points
56 Category 6 %
57 Category 6 Grade
58 Category 7 Points
59 Category 7 %
60 Category 7 Grade
61 Category 8 Points
62 Category 8 %
63 Category 8 Grade
64 Category 9 Points
65 Category 9 %
66 Category 9 Grade
67 Category 10 Points
68 Category 10 %
69 Category 10 Grade
70 Category 11 Points
71 Category 11 %
72 Category 11 Grade
73 Category 12 Points
74 Category 12 %
75 Category 12 Grade
76 Category 13 Points
77 Category 13 %
78 Category 13 Grade
79 Category 14 Points
80 Category 14 %
81 Category 14 Grade
82 Category 15 Points
83 Category 15 %
84 Category 15 Grade
85 #Missing Assignments
86 Completed Work Points
87 Completed Work %
88 Completed Work Grade
89 Term 1 Points
90 Term 1 %
91 Term 1 Grade
92 Term 2 Points
93 Term 2 %
94 Term 2 Grade
95 Term 3 Points
96 Term 3 %
97 Term 3 Grade
98 Term 4 Points
99 Term 4 %

100 Term 4 Grade
101 Term 5 Points
102 Term 5 %
103 Term 5 Grade
104 Term 6 Points
105 Term 6 %
106 Term 6 Grade

107 Term 7 Points
108 Term 7 %
109 Term 7 Grade
110 Term 8 Points
111 Term 8 %
112 Term 8 Grade
113 Term 9 Points
114 Term 9 %
115 Term 9 Grade
116 Term 10 Points
117 Term 10 %
118 Term 10 Grade
119 Master Attendance 1
120 Master Attendance 2
121 Master Attendance 3
122 Master Attendance 4
123 Master Attendance 5
124 Master Attendance 6
125 Master Attendance 7
126 Master Attendance 8
127 Master Attendance 9
128 Master Attendance 10
129 Attendance 1
130 Attendance 2
131 Attendance 3
132 Attendance 4
133 Attendance 5
134 Attendance 6
135 Attendance 7
136 Attendance 8
137 Attendance 9
138 Attendance 10
139 Attendance 11
140 Attendance 12
141 Attendance 13
142 Attendance 14
143 Attendance 15
144 Today's Date (short)
145 Comment 1 (number)
146 Comment 2 (number)
147 Comment 3 (number)
148 Comment 4 (number)
149 Comment 5 (number)
150 Comment 6 (number)
151 Comment 1 (text)
152 Comment 2 (text)
153 Comment 3 (text)
154 Comment 4 (text)
155 Comment 5 (text)
156 Comment 6 (text)
157 Student Summary Note



Using Plug-ins
Plug-ins are small files created using Easy Grade Pro that can be used to make import formats, export formats and summary 
comments readily available to other users of Easy Grade Pro.

To create a plug-in of an import or export format, choose Import or Export from the File menu, click the Other Formats tab and 
select the desired format from the list. Press on the small blue arrow above the list and choose Save Item as Plug-in from the 
menu that appears. Then name and save the plug-in.

To create a plug-in of the list of comments in the Summaries window, choose Summaries from the Chart menu, click the 
Students tab on the left and the Comments (balloon) tab on the right. Press on the small blue arrow above the lower list and 
choose Save Comments as Plug-in from the menu that appears. Then name and save the plug-in.

Plug-in files should be placed in the same folder as the Easy Grade Pro application or should be placed in a folder titled Plug-ins 
placed in the same folder as the Easy Grade Pro application. Whenever a person opens an Easy Grade Pro gradebook using 
version 3.5.6 or higher, Easy Grade Pro scans the plug-ins and transfers their contents to the gradebook. 

Be careful with plug-ins. A plug-in with comments will prevent the user from making lasting changes to comments in the 
Summary window. If the user makes changes to comments, the next time the gradebook is opened, the changes will be erase 
and replaced with what is found in the comments plug-in.

To remove a plug-in, simply drag it out of the plug-ins folder and out of the Easy Grade Pro folder.
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16
Working Cross Platform

This chapter explains the information you’ll need to use an Easy Grade Pro gradebook on both Macintosh OS 7.0+ and 
Windows 95+ platforms.

The Basics
Easy Grade Pro 3.6 for Macintosh and for Windows can share gradebooks easily and seamlessly. Since both platform versions of 
Easy Grade Pro use identical gradebook formats, you don’t have to convert them, save them in a special format or go through 
any importing process. Just copy the gradebook from one platform to the other using a network, email or disk and open it.

Because floppy disks are slow and unreliable, you should never work from a gradebook that is on a floppy disk.

It is crucial to remember to transfer the gradebook from one computer’s hard drive to the other before working at the other 
location. Don’t forget this and find yourself in the situation in which you have entered data into gradebooks on both computers 
so that neither has all the data. The only solution in this case is to reenter data into one of the gradebooks. Be careful that you 
don’t mix up copies of gradebooks with your main gradebook. Make a clear plan and follow it -- or stick to using one computer!

You must be using the same version number of Easy Grade Pro on both platforms. If you are using Easy Grade Pro 3.6.0 for 
Macintosh, then you should be using Easy Grade Pro 3.6.0 for Windows. Choose About Easy Grade Pro from the Apple menu 
(Macintosh) or Help menu (Windows) to find version information. Versions of Easy Grade Pro earlier than 3.5.5 cannot be used 
for cross platform work. To obtain software and licensing to work on both platforms, contact Orbis Software.

Transferring a Gradebook to Windows
You can transfer a gradebook from a Macintosh computer to a Windows computer using a network (see your network 
administrator), floppy disk or email. Once a gradebook has been transferred, simply double-click on it to open it. Before 
transferring it, be sure that the gradebook’s name ends with the extension ‘.egp’. For example, if your gradebook’s name is My 
Gradebook, change it to My Gradebook.egp. 

Using a Floppy Disk
To use a floppy disk to copy a gradebook to a Windows PC, the following steps may work for you: Insert a floppy disk into 
the Macintosh computer. If the disk is formatted for Macintosh, select it and erase it using a PC/DOS format. Drag the Easy 
Grade Pro gradebook to the floppy disk. Insert the disk into the PC. Double-click on the My Computer icon; double-click on 
the A: Drive icon. Find the icon of the gradebook on the floppy disk. Right-click on it and choose Copy from the menu that 
appears. Find an empty space on your computer’s desktop; right-click on it and choose Paste from the menu that appears. 

Using Email
Open your email program and create a new email. Click the Attach button or choose Attach from a menu. Locate the gradebook 
and select it. Look for encoding options and choose an encoding option like MIME/Base64 which is appropriate for sending 
attachments to a PC. (If you are emailing from one Macintosh to another, use a Macintosh-specific encoding method such as 
BinHex.) Then send the file. On the receiving computer, save the gradebook to the desktop of the computer.
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Transferring a Gradebook to Macintosh
You can transfer a gradebook from a Macintosh computer to a Windows computer using a network (see your network 
administrator), floppy disk or email. Once a gradebook has been transferred, simply double-click on it to open it. Before 
transferring it, be sure to use the File (or PC) Exchange Control Panel on the Macintosh to map the ‘egp’ file extension to Easy 
Grade Pro. Open the File Exchange Control Panel and click the Add button (shown below-left). In the window that opens 
(shown below-right), type egp into the Extensions field and select Easy Grade Pro 3.6.0 from the list. 

    

Using a Floppy Disk
To use a floppy disk to copy a gradebook to a Macintosh computer, the following steps may work for you: Insert a PC floppy 
disk into the Windows computer. Find the Easy Grade Pro gradebook. If it is not on the desktop, it may be found at this path: 
C:\Program Files\Orbis Software\Easy Grade Pro. Right-click on the gradebook and choose Copy from the menu that appears. 
Right-click on the A: drive icon and choose Paste from the menu that appears. Insert the disk into the Macintosh computer. 
Double-click on the floppy disk’s icon. Find and drag the gradebook’s icon to the hard disk’s icon. Eject the floppy disk.

Using Email
Open your email program and create a new email. Click the Attach button or choose Attach from a menu. Locate and select the 
gradebook. Look for encoding options and choose an encoding option like MIME/Base64 which is appropriate for sending 
attachments to a PC. (If you are emailing from one Macintosh to another, use a Macintosh-specific encoding method such as 
BinHex.). Then send the file. On the receiving computer, save the gradebook to the desktop of the computer.

Differences between the Platforms
Easy Grade Pro for Windows is virtually identical to Easy Grade Pro for Macintosh. There are some differences as follows:
■ Menu item terminology, keyboard keys, keyboard equivalents (accelerators) for menu items and highlight colors have some 

platform-specific differences.
■ Different characters are found in fonts (typefaces). Some characters on the Mac (such as the check mark) are not available in 

Windows and vice versa. Easy Grade Pro will convert some of these to alternatives.
■ Easy Grade Pro for Macintosh saves all Page Setup (orientation, paper type, scaling, etc.) options. Easy Grade Pro for 

Windows does not; you will need to reset any non-default page setup options each time you print. 
■ Macintosh printers typically allow scaling. Since fewer Windows printers offer this, Easy Grade Pro for Windows allows 

smaller typefaces in reports and allows right-clicking in the print preview window to select from multiple zoom levels.
■ When ePrinting, Easy Grade Pro for Macintosh creates files in PICT format. Easy Grade Pro for Windows creates files in BMP 

(bitmap) format. These formats are the most common formats on their respective platforms.
■ Easy Grade Pro for Windows offers status bar help and automatic reopening of the last gradebook. Easy Grade Pro for 

Macintosh offers balloon help and allows quick-searching by pressing the option key with the first letter of the item’s name.
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17
Technical Support

This chapter includes the most frequently asked technical questions about Easy Grade Pro. If you can’t find your question 
in this section, at the end you’ll find email and phone information for contacting technical support at Orbis Software.

FAQs (Frequently Asked Questions)
■ The wrong gradebook opens even when I choose Easy Grade Pro directly. How do I open a different 

gradebook or start a new one? (Windows only)
Easy Grade Pro for Windows automatically reopens the last used gradebook. When this happens, choose Close from the File 
menu and follow the prompts.

■ I read that Easy Grade Pro saves automatically. What does this mean?
Like most database programs that can deal with large amounts of data, Easy Grade pro automatically saves your changes 
while you work. When you switch classes, switch charts or choose most menu commands, you trigger Easy Grade Pro’s save 
feature causing it to write your changes to the gradebook file you created in the beginning. It even saves your changes if you 
leave your computer idle for a few minutes. What this means is that you never manually save your changes. Besides, there is 
no Save command in the File menu, only a Save Copy command used to make backup copies. When you close a gradebook 
or quit, Easy Grade Pro will prompt you to make a backup copy of your gradebook. It is a good idea to make the copy but 
keep in mind that it is a copy that is to be used only if the original gradebook becomes unusable. The next time you use 
Easy Grade Pro, use your main gradebook, not the copy.

■ My gradebook’s name is ‘Copy of copy of...’. What is going on?
Many programs prompt you to save your changes when you quit. However, with Easy Grade Pro, since all changes are saved 
automatically, it prompts you to make a backup copy of your gradebook and suggests a name of ‘Copy of gradebook 
name’ (Windows). If you have a gradebook with a ‘Copy of copy of...’ in its name, it means you are opening and using your 
backup copies instead of your main gradebook. See the prior question for more information on this.

■ How do I work on grades at both school and home? 
First be sure that you have the same version of Easy Grade Pro at both locations. For example, if you are using Easy Grade 
Pro 3.6.0 at school, then you must use the same version at home. Choose About Easy Grade Pro from the Apple menu 
(Macintosh) or Help menu (Windows) to find version information. Keep in mind that, just as with using a paper gradebook, 
you have to physically move your Easy Grade Pro gradebook from one computer to the other before working on it at any 
location. You don't want a situation in which you have entered data into two different gradebook files so that neither has all 
the data -- this would be like having two paper gradebooks and entering some assignments into one and other assignments 
into the other. The most important things to remember is to always transfer the current gradebook before working at 
other computer and don’t get your gradebook mixed up with any backup copies of your gradebook! Most teachers use 
a floppy disk to transfer their gradebook between computers. Simply copy the gradebook file (not the Easy Grade Pro 
program) to the floppy, move the floppy to the other computer, and copy the gradebook to the location of choice on the 
other computer. Double-click to open it up. Quit, copy it back to the floppy, and so on. For more information, and refer to 
the question How do I copy my gradebook to a floppy disk? below. You can also use email to transfer a gradebook. First 
create the email message, click the attach button (or menu item) and attach the gradebook (not the Easy Grade Pro 
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program) to the email. If you are sending from a Macintosh to another Macintosh, use BinHex or some other Macintosh-
specific encoding method if given an option. If your home and school computers use different platforms (Macintosh and 
Windows), refer to Chapter 16, Working Cross Platform on page 85 for additional information. If your home and school 
computers are both Macintosh computers, you may have to set up File Exchange Control Panel options if your email 
programs do not preserve certain internal codes. Refer to Transferring a Gradebook to Macintosh, on page 86 for help.

■ How do I copy my gradebook to a floppy disk?
Windows (one method): To copy a gradebook to a floppy disk, first find the gradebook. If it is not on the desktop, it may be 
found at this path: C:\Program Files\Orbis Software\Easy Grade Pro. Right-click on the gradebook and choose Copy from 
the menu that appears. Right-click on the A: drive icon and choose Paste from the menu that appears.
Macintosh (one method): To copy a gradebook to a floppy disk, first find the gradebook. If it is not on the desktop, it may 
be found in the Easy Grade Pro folder on the hard drive or in the Documents folder. Drag the icon of the gradebook to the 
floppy’s icon.

■ How do I get my gradebook to fit on a floppy disk?
If your gradebook is too large for a floppy disk, choose Compress from the File menu to make it smaller. Optionally, you can 
set compression to occur automatically as you work. Refer to the section Gradebook Options: General on page 31 for help.

■ Why am I getting disk error messages when saving to floppy disks?
Floppy disks are prone to a variety of problems, especially when used with two or more computers. Don’t trust your 
important data to a floppy disk. Use a floppy disk only to transfer a file from one computer’s hard drive to another or to 
store a copy of a gradebook.

■ Easy Grade Pro comes on a CD. How do I install it onto a computer without a CD-ROM drive?
The Easy Grade Pro CD has a folder titled Floppy Disk Folder  with instructions and files for making a floppy disk installer. 
To find this folder, insert the CD. On a Macintosh, the folder is easy to find. On a Windows computer, when you insert the 
CD, the installer software may start automatically. Cancel the installation. Then right click on the icon of the CD and choose 
Explore to view the floppy disk folder.

■ Can Easy Grade Pro be networked?
A gradebook can be placed on a network allowing access from any computer. A gradebook cannot be opened by multiple 
users simultaneously. Macintosh: The Easy Grade Pro application (site version) can be placed on a server allowing multiple 
users to work from a single installation. Windows: Unless you use network utility software, the application must be installed 
on each computer. 

■ Why are the dates wrong in the main chart and in calendars?
This indicates that the computer’s clock is not set properly or the clock’s battery is dead. Use the computers Date and Time 
control panel to set the clock. Refer to your computer’s user manual for help in replacing a dead clock battery.

■ When I calculate a student’s overall percent manually, why is it different from Easy Grade Pro’s?
Since most teachers want some assignments to be worth more than others, Easy Grade Pro does not simply average scores 
or percents to calculate the overall percent. Like most grading programs, Easy Grade Pro allows teachers to assign point 
values to assignments to make some assignments worth more or less than others. Students earn points based on their 
scores. In general, a student’s overall grade is based on how many points a student has earned out of the number of points 
possible. To read a thorough explanation of how Easy Grade Pro calculates, see the section How a Student’s Overall 
Percent is Calculated on page 42. Use the Student Grades view of the Summary window to view a helpful breakdown of 
grades.

■ How do I set up my 5-point (or some other point) grading system?
There are two different ways to do this as follows.
Method 1: Using Numbers and a Modified Grade Scale: You can simply set the maximum score on assignments to five and 
type the numbers one through five into score cells. Although this is simple to do, there is one side effect that must be 
considered. Since a score of 1 out of 5 is a 20%, 2 out of 5 is a 40%, etc., student’s may have assignment and overall percents 
that are lower than what is typically considered acceptable. You can compensate for this by using a modified grade scale and 
hiding percents from view. See page 23 for help with setting up a scale. See pages 30 and 48 for turning off percents in charts.
Method 2: Using Special Scores: You can create special scores to be used instead of regular numbers. Your special scores 
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could be +5 (100%), +4 (90%), +3 (80%), +2 (70%) and +1 (60%). The plus symbol is used to minimize confusion with true 
numeric scores. You can choose to enter special scores by direct typing or by using shortcuts but not both. Open the 
Gradebook Options window to the General view to set your preference. Refer to the sections Class Options: Special Scores 
on page 25 and Gradebook Options: General on page 31 for help. With this method, you do not have to use a modified scale 
or hide percents.

■ How do I drop multiple scores for a student?
Easy Grade Pro drops scores in real time, changing the dropped scores as new scores are added. It performs extensive 
calculations to ensure that the process always results in the greatest possible improvement. Because of this, only one score 
can be automatically dropped per student. However, there is an easy way to manually drop multiple scores using the 
Change Scores tool. Refer to the section Dropping Scores  on page 49 for help.

■ What is the best way to start a new term? 
Choose Start New Term from the Tool menu. 

■ How do I combine grades across terms? How do I add a weighted Final Exam? 
Refer to the section Class Options: Combine Terms that starts on page 27.

■ I’ve combined terms but now the prior term grades are wrong in my current class. What’s going on?
Refer to the section How often do I need to combine terms? on page 28.

■ How do I get the overall grade to reflect a subset of the assignments?
Change the status of the assignments to be excluded to Not for Grade in the assignment chart.

■ My overall grades are too low. How can I modify them before sending/printing progress reports?
To raise grades, you can lock or curve the overall grade (page 48), add extra credit (page 49) or drop scores (page 49).

■ How do I change the name that appears on reports?
Site license version: The school’s name is entered into the program when it is first used. It can only be changed by 
reinstalling the program. The teacher’s name can be changed in the Print Reports window (File->Print). It is safe to reinstall 
Easy Grade Pro without losing any data as long as your gradebook is not named Demo Gradebook or Demo.egp.
Single-user license version: The teacher’s name is entered into the program when it is first used. It can only be changed by 
reinstalling the program. The school’s name can be changed in the Print Reports window (File->Print). It is safe to reinstall 
Easy Grade Pro without losing any data as long as your gradebook is not named Demo Gradebook or Demo.egp.

■ Why are classes missing on a student’s multi-class progress report? Why am I getting two different multi-
class progress reports for a student, each with different classes?
The student’s name or ID number is different in the different class(es). Correct the name or ID number and print again.

■ How do I remove the Overall column in a multi-class progress report?
If you have combined two or more terms, the multi-class progress report automatically includes columns for each term and 
for the overall grade. If you want to include individual term grades but not the overall column, combine your terms using 
weights of 0% for each prior term class and 100% for each current term class. Also, do not curve or lock the overall grade for 
any student in any current term class. Under these conditions, Easy Grade Pro will automatically omit the Overall column.

■ How do I show points in my progress reports?
In the Report Options window for a progress report, click the set button after the Include Grade Summary Chart options 
and turn on Points Earned. Click the set button after the Include Assignment Chart option and turn on Points Earned.

■ How can I import a whole class in another gradebook into my gradebook?
Choose Import from the File menu and select the Built-in Formats tab. From the list, select Import from an EGP Gradebook 
and click Next. In the next window that opens, you must choose to import into an existing class or a new class. If you select 
the latter, you will be prompted to name the new class and to sets the term. Then you will be prompted to open the other 
gradebook. Find it, select it and click Open. The Import window will appear. Very import: select the Class tab. Then, from 
the upper-left list, select the class in the other gradebook to be imported. In the lower-left list, select the class in the current 
gradebook to receive the class data. Select the only item in the list on the right. Check your selections and then click Import.
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■ How can I print reports that include grades from multiple teachers?
If you wish to print multi-class progress reports that include data from multiple teachers, it may be easiest to create a master  
gradebook that contains gradebooks from multiple teachers. To do so, start a new gradebook. When a window appears 
stating that the gradebook has no classes, click the Import button (or choose Import from the File menu). Under the Built-
in Formats tab, select Combine Gradebooks and click Next. In the window that appears, select one of the other gradebooks 
and click Open. In a matter of seconds, all classes in the other gradebook will be imported in the master gradebook. 
Continue using the Combine Gradebooks format until all gradebooks have been imported. Print reports. It is important 
that the students’ names or ID numbers are identical in all teachers’ gradebooks. Note: there is a 250 class limit for a 
gradebook which means that you can typically combine around five to ten gradebooks.

■ Every time I switch classes, my gradebook displays a message stating that the file is locked and changes 
could not be saved. What is happening?
There are different kinds of locks with computers. First of all, Easy Grade Pro allows you to set a password  lock on a 
gradebook using the Lock command (File menu) or Lock tool. With this type of lock, you cannot open your gradebook. 
Since your gradebook is open, the lock is of a different type. Another type of lock is a hardware  lock, usually found on 
floppy disks and other removable media. To unlock a disk, move the tab on the actual disk to the unlocked position. A 
software  lock, the last type of lock, is set at the operating system level. To check for this, right click on the gradebook’s icon 
and choose Properties from the menu that appears (Windows), or select the icon and choose Get Info from the File menu 
(Macintosh). Look for a field titled Locked with an x in it. Another type of software lock involves network permissions. If you 
have to log in to your computer on a network to use it, perhaps your log in account does not grant you permission to save 
data to the location of your gradebook. Contact your network administrator for help with this type of lock.

■ How come my student data is grayed out and I can’t switch charts or use most menu commands?
The gradebook is in TA mode. Choose TA Mode from the File menu and enter the teacher (not the TA) password. See Using 
the TA Mode  on page 58 for help. 

■ I have a student with modified assignments. How do I handle this?
Add the regular assignment. Be sure to sets the assignment’s Progress Report option to Include if Student has Score. Then 
add the assignment a second time with the modified settings. Be sure to set the Progress Report option the same way. Use 
the first copy of the assignment for most students. Use the modified assignment for the special student. Because blank 
score cells are ignored by Easy Grade Pro, the assignment without a score for each student has no impact. Because of how 
you set the progress report option, an assignment without a score won't appear on anyone's progress report. And because 
Easy Grade Pro allows up to 1000 assignments per class, you can have any number of modified assignments.

If you would like a quick and easy way to show just the special assignments, put a code (such as 'X') in the Note field of the 
assignment record for any modified assignments. Create a custom filter (View menu) that, when chosen, hides all 
assignments except for those with an 'X' in the note field. Above the right, vertical scroll bar, is a small triangle that, when 
pressed, allows you to quickly choose a custom filter. Anytime you want to see the modified assignments without the clutter 
of all the other assignments, choose the filter. Then choose Show All from the View menu to restore the view.

Contacting Orbis Software for Technical Support
Orbis Software provides free technical support to registered users. Before you contact us, please be sure that you have read the 
FAQs above and you have searched this manual and your computer manual and could not find a solution. Be sure to have the 
following information: your registration (serial) number, the version number of Easy Grade Pro (e.g. version 3.6.0), your 
operating system (Window 98, Mac OS 9.0.4, etc.) and a clear description of the problem. If calling for technical support, you 
are encouraged to be at your computer.

Address: P.O. BOX 73745, Puyallup, WA 98373
Phone: (253) 848-6899 (Pacific Time)

Fax: (253) 848-6505 (fax only
Web: www.orbissoft.com

www.easygradepro.com
Sales: sales@orbissoft.com

Support: support@orbissoft.com
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