
Syncing music to iPod is a one-way street 
To get tunes into iPod for your enjoyment, you generally either sync your iTunes library with your iPod, or use iTunes to manually 
copy songs to the player. But if you want to copy music from your iPod to your computer (maybe a friend put a song on your iPod or 
you want to back up your music), you can't do that.  
Synchronization occurs in one direction only—from a computer to your iPod. This means you cannot transfer music, automatically or 
manually, from your iPod to a computer, and you cannot use iPod to copy a music library from one computer to another. 

 
How to use your iPod to move your music to a new computer 

Got a new computer and want to move your entire iTunes library? Starting with iTunes 7 there is a new backup feature that will 
archive your entire library to CD or DVD, including ratings and playcounts, which can be moved to another computer. If you are 
interested in moving your library using this method click, here. 

If you do not have access to a CD or DVD burner then there is another option if you own an iPod. Because your iPod contains a high-
capacity hard drive, you can use it to move all your music from your old computer to the new one. 

Note: While you can use the Transfer Purchases from iPod option under the File menu to copy iTunes Store purchases from the the 
iPod to another computer, you can't transfer songs from other sources from the iPod library to iTunes, so you'll need to follow the 
steps below to use iPod as a hard disk to transfer music files from one computer to another. This process will require the use of iTunes 
7 on all computers. Any computers running iTunes 6 or earlier will need to be updated to follow these steps. Download the latest 
version of iTunes here. Once you have the files transferred, you'll need to authorize any iTunes Store content. If you won't be using 
your old computer, you'll want to deauthorize it. 

Important : Windows operating systems don't recognize Mac OS-formatted disks (HFS or HFS Plus formats), so you can't use a Mac-
formatted iPod to move your music to a Windows PC. See "iPod: How to determine iPod's hard disk format" if you're not sure what 
format your iPod is. 

Switch the iPod to manual update and enable disk use 

The first thing you need to do is make sure have configured your iPod to enable disk use. To do this: 

1. Open iTunes on your old computer.  
2. Connect your iPod to your old computer and wait for it to appear in iTunes.  
3. Select your iPod in the Source pane under the Devices section to display your iPod preferences in the main library window.  
4. Click the Summary tab in the main iTunes window.  
5. Click the Manually manage music button. Changing from automatic updating to manual puts a check mark by Enable disk 

use. A message says  

"Disabling automatic update requires manually unmounting the iPod before each disconnect."  



 

6. Click OK in the message window.  
7. Click Apply in the iPod preferences section of the iTunes window.  

Is all the music together? 

To make the move as easy as possible, be sure your music is all in one place. 

1. Open iTunes Preferences: 
Mac: From the iTunes menu, choose Preferences. 
Windows: From the Edit  menu, choose Preferences.  

2. Click Advanced and then click General.  



3. Look to see if the checkbox for "Copy files to iTunes Music folder when adding to library" is selected. If it is, skip ahead to 
Is there enough room on the iPod. If it is not, continue to step 4. 

 
4. Select the "Copy files to iTunes Music folder when adding to library" checkbox.  
5. Click OK. Note: Clicking OK will cause iTunes to copy all of your music files to another location on your computer. You 

will need to manually remove the files from their previous locations if you are concerned about space. If your computer 
does not have enough hard-drive space this process will not work correctly. Please speak to your computer manufacturer or 
Microsoft for more information on how to obtain more space to perform this action.  

6. From the Advanced menu, choose Consolidate Library. A window appears reading: "Consolidating your library will 
copy all of your music into the iTunes music folder. This cannot be undone."  

7. Click Consolidate.  

Is there enough room on the iPod? 

iPod shares its hard disk space between the songs that iTunes puts on it and any files you've added when using its disk mode. To 
transfer music with your iPod, you need enough free space to hold a copy of all your music files in addition to any copies that may 
already have been placed by iTunes (this is because non-purchased songs placed on the iPod by iTunes cannot be copied off the iPod 
while in disk mode). To figure out how much space you have on your iPod: 

1. Open iTunes on your old computer.  
2. Click on Music in the Source pane. The size of your library appears at the bottom of the iTunes window:  



3.  
4. Connect your iPod to your old computer and wait for it to appear in iTunes.  
5. Click the iPod under the Devices section of the Source pane.  
6. The amount of free space on the iPod appears near the bottom of the iTunes window:  

7.  
8. If the amount of free space left on your iPod is larger than your library, skip to Copy iTunes folder to iPod.  

Free up space on the iPod 

If your library is larger than the amount of free space on your iPod, you'll need to free up some space on it. Here's how: 

1. Click your iPod in the Source pane.  
2. Click on the Music option listed under iPod in the Source pane. (If you do not see this option, click the gray arrow next to 

the iPod to reveal the iPod's contents)  
3. Click any song that appears in the main part of the iTunes window (to the right).  
4. From the Edit  menu, choose Select All.  



5.  
6. Important : The next step will delete all music from your iPod. If you have been using automatic update you don't need to 

worry, because all your music is also on your computer. If you have not been using automatic update, and your iPod has 
music on it from another source (other than your iTunes library), following the next step will delete that music.  

7. Press Delete on the keyboard. If you see a message that says "Are you sure you want to remove the selected items from the 
list?", click Yes.  

Copy iTunes folder to iPod 

To copy all your music files (including the library file that holds all your playlists and other settings) to your iPod: 

1. Quit iTunes.  
2. Locate your iPod: 

Mac OS X: On the desktop 
Windows: In My Computer  

3. Locate your iTunes folder: 
Mac OS X: /Users/username/Music 
Windows: \Documents and Settings\username\My Documents\My Music\  

4. Drag the iTunes folder to the iPod. This can take a while if you have a lot of songs.  



 

From your old Mac to the iPod  

 

From your old Windows PC to the iPod  

5. When the copy completes open iTunes.  
6. Click on the iPod in the Source pane  
7. Click the Eject button in the lower right corner of the iTunes window.  
8. Disconnect the iPod from the computer when the "Do not disconnect" message no longer appears on the iPod screen.  

Get iTunes ready on your new computer 

To get iTunes ready to accept all your music on your new computer: 



1. Download and install the latest version of iTunes.  
2. Open iTunes on your new computer. If this is your first time to open iTunes on your new computer you will need to choose 

your options in the iTunes Setup Assistant.  
3. Connect the iPod to your new computer.  

Backup any music that's already on your new computer 

Do you already have some music showing up in your Library in iTunes on the new computer? If so follow these steps to make sure 
this music gets saved (You can see how to add it back into iTunes in the Adding music on new computer back in section below). If not 
you can skip down to the Copy music to new computer section. 

1. Open iTunes Preferences Mac OS X: 
From the iTunes menu, choose Preferences. 
Windows: On the Edit menu, click Preferences.  

2. Click the Advanced tab.  
3. Click the Reset button next to iTunes Music folder location.  
4. Make sure the checkbox next to Copy files to Music folder when adding to library is checked.  

 

5. Click OK.  
6. From the Advanced menu, choose Consolidate Library. An alert message appears: "Consolidating your library will copy 

all of your music into the iTunes music folder. This cannot be undone."  
7. Click Consolidate.  



8. Quit iTunes.  

Copy music to new computer 

To copy all your music files (including the library file that holds all your playlists and other settings) to your new computer: 

1. Locate your Music folder (Mac OS X) or your My Music folder (Windows) on your new computer: 
Mac OS X: /Users/username/Music 
Windows: \Documents and Settings\username\My Documents\My Music\  

2. Drag the iTunes folder in this location out to the desktop.  

 

From the Music folder to the Desktop on your new Mac  

 



From the My Music folder to the Desktop on your new PC  

3. Locate the iPod on the new computer: 
Mac OS X: On the desktop. 
Windows: In My Computer.  

4. Double-click on the iPod to open it.  
5. Drag the iTunes folder from the iPod to the Music folder (Mac OS X) or My Music Folder (Windows) on your new 

computer. This can take a while if you have a lot of songs.  

 

From the iPod to the Music folder on your new Mac  

 

From the iPod to the My Music folder on your new PC  



6. Open iTunes.  

There you go. All your music, playlists, and other information like play counts and ratings have all been moved from your old 
computer to your new one. 

Add existing music on new computer back in 

If you already had some music on your new computer, and you want to incorporate it into the music you just moved from your old 
computer: 

1. From the File menu in iTunes, choose Add to Library (Mac OS X) or Add Folder to Library  (Windows).  
2. Navigate to the iTunes folder on your Desktop.  
3. Click Choose (Mac OS X) or OK (Windows).  

Note: Information like ratings and play count are not preserved for these songs. 

Free up room on the iPod 

To free up room on your iPod so iTunes can put all your music back on it: 

1. Quit iTunes.  
2. Drag the iTunes folder out of the iPod to the Trash (Mac OS X) or Recycle Bin (Windows). 

Mac OS X: From the File menu, choose Empty Trash. 
Windows: A Confirm Folder Delete window appears. Click Yes.  

Switch the iPod back to automatic update 

To set up your iPod to be updated with all your music from iTunes on your new computer: 

1. Open iTunes.  
2. Select your iPod in the Source pane and click the Music tab that is available on the right in the iPod Settings.  
3. Click the “Sync music” option, and the “All songs and playlists” option. An alert message appears:  

"Are you sure you want to enable automatic updating? All existing songs and playlist on the iPod "ipod name" will be 
replaced with songs and playlists from the iTunes music library."  

Optional: Uncheck the Enable disk use button in the Summary tab if you don't want to use the iPod as a disk. If you leave 
this option checked you need to eject your iPod from iTunes before you disconnect the iPod from your computer. 

4. Click Apply.  

The iPod update begins. All your music is now on your new computer, and after the update completes it will be on your iPod again 
too. 

http://docs.info.apple.com/article.html?artnum=300173 

 

Where iTunes for Windows stores your audio files 

You can find the song files in the iTunes Music folder using Windows Explorer or by choosing the Get Info command in iTunes.  
 
iTunes stores the songs you import in the iTunes Music folder. You can find the iTunes Music folder in the My Music folder inside 



your My Documents folder (My Documents\My Music\iTunes\iTunes Music). In Windows Vista, you can find the iTunes Music 
folder in the Music folder (C:\Users\username\Music\iTunes\iTunes Music). 

�  All of your songs or spoken word files are in the iTunes Music folder, including: 
�  Songs imported from CDs. 
�  Songs purchased from the iTunes Store. 
�  If you have turned on the "Copy files to iTunes Music folder when adding to library" option in Preferences: 

�  Files copied from the desktop to iTunes. 
�  Files added to iTunes using either the Add File to Library or Add Folder to Library commands in the File menu.  

 
You can also find where an audio file is stored using iTunes:  

1. Open iTunes  
2. Select the song.  
3. From the File menu, choose Get Info .  
4. Click the Summary pane, if necessary. The Where section indicates the path where the song is stored.  

 
 

 
 
The Where section of the Summary pane 
 

http://docs.info.apple.com/article.html?artnum=93358 
 
 


